Setup network between home and office PCs for remote access

It would be really convenient if I could setup a network between my home and office PCs so that I could access files at home. It would be even more convenient if I could run programs installed on my office PC from home. Both PCs are running SUSE 11.1. Is this possible to do?

I found a nice looking instructional piece on setting up computers for remote access (Remote Access to SUSE - openSUSE), but it says a prereq is having a network already setup between the PCs, so I stopped there since I don’t know how to do that.

VNC and RDP work just fine – no prior network requirements.
TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)
Windows Linux RDP Remote Desktop Connections using openSUSE as Client or Server (terminal server)

I like xRDP as the better of the two (just a personal preference though).

The only thing I recognized there was VNC, but that’s not as secure as SSH, right?

Anyways, I read chapter 34 of Beginning SUSE Linux: Accessing Linux Remotely, and learned a few things. It looks like I could just type

ssh username@IP

to run bash on the remote pc and use the sftp command to transfer files. The chapter also talked about using the GUI remotely, which pretty much covers everything I want to do, but the book isn’t up to date for SUSE 11.1, so his instructions aren’t completely accurate as far as I could see. Before I could do anything like this, I have to configure the firewalls of both PCs. So, I need to go into yast>security and users>firewall>allowed services and enable secured server shell, right? Then I need to click advanced and open up a port through which to communicate? Here’s a screenshot of the screen I wound up at. I believe I should type in 5900 for the port, but which box do I type that in? There are three entries for ports and one for IP protocols. Do I need to enter anything else to make ssh possible between these two machines?](
Free Image Hosting by

So I kind of got SSH working. I configured the firewalls on both computers to allow SSH and VNC and then I selected ‘advanced’ and typed ‘22 5900’ in the UDP Port box. After that, I got a hostname for my home PC since it doesn’t have a static IP address using the tutorial given at HOWTO run an ssh server without a static IP address [Archive] - Ubuntu Forums.

I tried using

ssh <home domain>

from my office and it worked perfectly. I was even able to start up the X window remotely (although it was unbearably slow). However, now I tried the same thing from home and I can’t access my office PC. The PC is turned on but I’m logged off of it. When I try it, the connection just times out after a while. I pinged the PC and everything goes well, but I can’t connect via SSH. What could the problem be that’s causing this? Router settings set by IT?