Setting up wireless using WPA for PS3 with SUSE 11

Can any guru out here post a guide on how to set up the wireless connection in PS3??? is it possible at all?? I have noticed there is WPA option available. With YDL you can get the wireless working except you need to use WEP. WPA can still work but it’s really pain in the ass

please do not double post, other will now be closed


Sorry I just dont know which category should I put it under?? Thank you for letting me know…I will let you decide to put it under which section. Sorry…

anything you don’t know google it my friend and if you’re looking for something specific be specific!!

i could tell you exactly how to set your router up if i know what router you have so-

type the model number in on google (on a sticker at the back if not the front)then after that type in “ps3 wpa settings” and do the search

-also it’s possible to better set up your router generally for ps3 so reapeat the model number and add “ps3 settings” and do another search-then click on the portforward link at the top

being specific means you don’t have to wade through everything about the router to find the info you need without getting very confused (as i used to)

oh and if you didn’t know don’t bother using the instalation disc-just open firefox or explorer or whatever and type in into the address bar at the top-this takes you straight to the router homepage where you can change the settings

hope this helps

Yes, WPA used to be a pain - but in general for Linux - nothing to do with PS3 - especially when combined with a hidden SSID. Of course opensuse 11 makes it much easier than earlier distros.

First, you need to make sure wpa_supplicant is installed (installed by default in opensuse 11 I believe):

zypper search wpa_supplicant

If not marked with an “i”, then:

zypper install wpa_supplicant

opensuse 11 has full WPA support, so try configuring with yast2:

yast2 lan

Select your wireless device - which should say not configured under IP address.

Click edit.

Click on the general tab and select activate at boot time.

Click the next button.

Enter your SSID, WPA-PSK for auth mode, and your passphrase.

Click next and then click finish.

At this point, your network has likely been restarted, but just to be sure:

/etc/init.d/network restart

Now, if you broadcast your SSID everything should be working out of the box - try going online or just see if you’ve successfully gathered an IP (note that the output of network restart should also show assigned DHCP address in opensuse 11)


Look for the wlan0 entry and see if you’ve got your 192 IP or something similar successfully assigned by DHCP.

If not, you can check if your access point is at least connected with:


If successful, you should see your SSID listed, and a 54MB/sec rate for G let’s say.

If you have an hidden ssid (not broadcast) or are unsure/unsuccessful, edit this file with your favorite editor:

vi /etc/sysconfig/network/ifcfg-wlan0

Add the following line at the bottom:


Now restart the network and you should be good:

/etc/init.d/network restart

Hope this helps.