Setting up openSUSE & Win10 file sharing

Hello openSUSE forums! I’m pretty new with openSUSE (haven’t really got my hands too deep in Linux for 8 years) and have had a bit of a hiccup in getting my file sharing sorted out. All I want to do is be able to send file from my Windows 10 desktop (where I capture game recordings from) and my openSUSE laptop, where I’m trying to edit them while on the go. I’ve followed the guide here:

Which seems accurate except when I go to smb:// I get a server time message immediately. I’ve also tried having my Win10 connect to openSUSE’s IP without any luck. I’ve made sure that network discovery is on in Windows 10 and I’ve made the folder I want to share available to the “Everyone” group so there’s not read/write permissions errors (I’ll sort that out later, I just want the basic communication to work between these two). I’ve got the Smaba Client and Samba Server options allowed in the YaST2 firewall settings.

I also tried the instructions here, also without success:

I’m attempting to connect via WiFi, if that makes a difference.

Systems are:
openSUSE 42.3 LEAP
zypper patched & updated
WiFi and ethernet are both recognized, unit has internet access
Samba is on (I think)

Windows 10** box
**network discovery is on
no 3rd party security/anti-virus (just built-in Windows Defender/Security Center/whatever Microsoft calls it these days)
firewall is open
My mac can see the win10 to transfer files without a problem

If there’s any advice anyone can offer I’d appreciate it.

Hi and welcome to the Forum :slight_smile:
If you just want to transfer files, use ssh. Just install winscp on the WinX system, on the openSUSE system fire up YaST firewall and under allowed services ensure the secure shell server is added via the drop down on the right, save and then just point winscp at your system ip address.

Hey Malcom,
Thanks for the advice. Unfortunately winSCP tells me that my connection is refused every time I try to connect.

That being said, and I don’t know what’s magically changed, but I can go to file explorer on Win10 & type in the IP address: works magically now. Not sure what changed but I won’t complain about it.

Thanks a ton!

Jim_Survak: Don’t change anything now because it’s working.

But passing people with this problem, maybe do this. (A logical procedure):

From the Linux side:
My policy for easy access between win10 and Leap is to have a folder on my KDE desktop. Suppose the user name is donald and the directory on the Desktop is named “Transfer”. I place this setup/coding in the smb.conf file located at /etc/samba/smb.conf

path = /home/donald/Desktop/Transfer
valid users = donald
read only = no
force user = donald

Also in the same file there’s a stanza at the top named [global]. In that stanza put this line:

netbios name = chocolate

(if you don’t like chocolate, try anything else)

I add an access password in case I want to send the occasional sensitive file e.g. a folder of bitcoins. Do that by running this cli code:

sudo smbpasswd -a donald

The command will then take you through the process of creating a password. Then once win10 asks “what is that password” and you tell win10 what it is not to forget it, bingo, you have a degree of security.

Now from the win10 side:
I right-click on the win10 desktop and select “New” then “Shortcut” then it asks “Type the location” and I respond by typing this:


See where chocolate and Lizard fit in the patterns of things. Change them as you like.

And that’s the lot, you have a link on the win10 desktop that takes you into the folder on the Linux Desktop.