Setting up eth0 from scratch


I got a new laptop and having had Ubuntu on my second computer for a while and decided to try openSUSE. I have had the WLAN working on windows 8 and ethernet working on Ubuntu 12.04 LTS on this machine out of the box/DVD, but I have no eth0 or wlan device after installing openSUSE 12.3.

Has anybody got the time to help me go through steps to get eth0 into existence for a start, so I can start one of the decent looking guides to setting up with the Network Manager program?

Thank you.

First step go to Yast and try configuring the card. Also tell use what the hardware is.

Thank you. OK, after letting YaST2 take over from Network Manager, for the ethernet controller I get

“Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.”

Regarding the hardware brand/model numbers i tried hwinfo inspired by some posts:

nsa@linux-1bmd:/etc/sysconfig/network$ /usr/sbin/hwinfo --netcar
29: PCI 100.0: 0200 Ethernet controller                         
  [Created at pci.319]
  Unique ID: VCu0.YLAopfhREjE
  Parent ID: 8otl.G5Dfw+ssufC
  SysFS ID: /devices/pci0000:00/0000:00:04.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Attansic Ethernet controller"
  Vendor: pci 0x1969 "Attansic Technology Corp."
  Device: pci 0x1090 
  SubVendor: pci 0x1179 "Toshiba America Info Systems"
  SubDevice: pci 0xfa86 
  Revision: 0x10
  Memory Range: 0xf0100000-0xf013ffff (rw,non-prefetchable)
  I/O Ports: 0x3000-0x3fff (rw)
  Module Alias: "pci:v00001969d00001090sv00001179sd0000FA86bc02sc00i00"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

30: PCI 200.0: 0280 Network controller
  [Created at pci.319]
  Unique ID: B35A.hq4BHdYGoI0
  Parent ID: CvwD.nV9PPa_ZQ2D
  SysFS ID: /devices/pci0000:00/0000:00:05.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Realtek Network controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8179 
  SubVendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  SubDevice: pci 0x0181 
  Revision: 0x01
  I/O Ports: 0x2000-0x2fff (rw)
  Memory Range: 0xf0000000-0xf0003fff (rw,non-prefetchable)
  Module Alias: "pci:v000010ECd00008179sv000010ECsd00000181bc02sc80i00"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

I didn’t see anything obvious in the dmesg output, but I may not know what to look for.

Could I steal the ethernet driver/settings from Ubuntu, maybe by using a live CD?

There was a bug in the 12.3 installation which meant that you had to reboot before Network Manager would start. I suggest you give control back to Network Manager and reboot.

I have never had to configure eth0 - it just works.

No such luck, unfortunately (Hibernation/Standby doesn’t quite work, so I have been rebooting a few times already).

Has anybody got any ideas? I guess I can only cannibalise from Ubuntu if the network part of the kernel is in a dynamically loaded module?

Can you post output of

/sbin/lspci -nnk

Preferably just the output pertaining to the network devices

I note your ethernet chipset details

Vendor: pci 0x1969 "Attansic Technology Corp."   Device: pci 0x1090 

Read this thread:

You need to install 2 packages:
compat-wireless-scripts-3.7-5.1.noarch.rpm and one of:


or the equivalent for x86_64 systems. Pick the right one according to the kernel you have installed. Normally this will be “desktop”. The version numbers must match your kernel and may change in the future.

Follow the instructions given…

Thanks to voodoo!

This is written from the new machine - thank you very much.

(Had to shelve it a few weeks due to moving and the lead time to get an internet connection in the new place, which can take 3-4 weeks in certain parts of the world…)

Next challenge: Wi-fi in a few days!)

Just as a point of interest, since the issue is fixed now, the mii-tool may be able to help in issues like this.