Setting up access point - Help needed

I am following the instructions at Set up a wireless accesspoint - LinuxIntro rather than http://forums.opensuse.org/english/get-technical-help-here/wireless/410475-how-setup-access-point.html as it uses openSuse 12.1 which is closer to my version 12.3.

It uses a USB WLAN device while I am using a PCI card.

The first error was

#ifup wlan0
    wlan0     name: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
command 'iwconfig wlan0 power off' returned
 Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.
wlan0     warning: wpa_supplicant already running on interface

I assumed this was because the PCI card was always powered on and continued.

# hostapd /etc/hostapd.conf
Configuration file: /etc/hostapd.conf
Using interface wlan0 with hwaddr 00:11:50:62:2f:96 and ssid 'test'
wlan0: STA 60:21:c0:e9:57:42 IEEE 802.11: authenticated
wlan0: STA 60:21:c0:e9:57:42 IEEE 802.11: associated (aid 1)
wlan0: AP-STA-CONNECTED 60:21:c0:e9:57:42
wlan0: STA 60:21:c0:e9:57:42 RADIUS: starting accounting session 52793DAC-00000000
wlan0: AP-STA-DISCONNECTED 60:21:c0:e9:57:42

…produced a signal that I could find scanning with my Chromebook. So far so good. I then set up a network bridge. But when I…

# brctl addif br0 wlan0
can't add wlan0 to bridge br0: Operation not supported

Any assistance would be much appreciated.

I assume you’re trying to share a wired internet connection, is that correct? You should not need to configure the bridge manually, because hostapd can do all this with the appropriate settings in /etc/hostapd.conf, as outlined here:

hostapd - Linux Wireless

Wireless Interface Setting Summary:

  • interface: Tells hostapd what wireless interface to use
  • bridge: Set to a bridge if the wireless interface in use is part of a network bridge interface
  • driver: For our purposes, always nl80211

If you only have 1 wireless interface, and it’s going to be bridged with a wired interface, a good example setup would be:
interface=wlan0
bridge=br0
driver=nl80211

Yes, I am trying to share a wired connection. My hostapd.conf is…

driver=nl80211
bridge=br0
channel=3
hw_mode=g
auth_algs=1

…so are you suggesting I don’t have to…

# brctl addif br0 wlan0

I tried that. I still couldn’t connect from the Chromebook.

Are you saying that the wireless connectivity is failing? (ie wireless issue)
Or is it that you just don’t get internet connectivity yet? (ie network issue)

Another thought I had was to install ‘wifi-hostapd-ap’ (GUI to create WiFi access point based on Hostapd). That might simplify things for you.

software.opensuse.org:

If you prefer to do set up the AP by hand, rather than with the GUI application I mentioned earlier, I’ve found a couple of guides that use the more preferable technique of using NAT, (rather than bridging your wireless and ethernet interfaces).

Hostapd : The Linux Way to create Virtual Wifi Access Point | Foo, Bar and Foobar

https://wiki.archlinux.org/index.php/Software_Access_Point

I recommend you consider using ‘dnsmasq’ (like the GUI applicationdoes), as it is reasonably simple to setup, and provides the required DHCP and DNS services, needed to get a wireless LAN up and running. It is as simple as starting ‘dnsmasq’ from the CLI (or script). It will use

A minimal /etc/dnsmasq.conf configuration might look like this

interface=wlan0
dhcp-range=192.168.0.2,192.168.0.255,1h;
server=/www.google.com/8.8.8.8

Hope this helps.

I am reasonably sure that there is a connection as the Chromebook identifies the wireless card specifically. The Chromebook’s browser does not find any page. So yes, I think it’s a network issue. I need to look at the DNS addresses more closely.

Working on a different box. Old, no ancient Compaq.

I followed the first link and now have a functioning access point. Learned a few things along the way. Now to document the steps for the next installation. Thank you very much.

Well done. You might want to share those steps for other openSUSE users who come looking… )