Setting up a home wireless network through a router box

Hi All,

I have been struggling through network configuration using Suse, and have not had much luck getting my laptop connected to my desktop.

Here is my setup.

I have a cable router connected to eth0
I have the wireless router connected to eth1. The wireless router is a Belkin Wireless-G plus router, and I have the eth1 cable connected to one of the four regular computer connections, not the one labelled ‘connection to modem’

I have used yast to set the configuration of both ethernet connections to DHCP, since one is assigned a network address by the cable router to the www, and the other is assigned a network address by the DHCP server built into the wireless router.

I have checked the ‘Enable IP forwarding’ box in the routing tab of Network Settings, though the ‘Default Gateway’ lines are both blank, since with DHCP enabled I don’t know what (if anything) needs to go into these rows.

I have set up the firewall so that eth0 is in the external zone, and eth1 is in the internal zone.

I have checked the ‘Masquerade Networks’ box in that section of the Yast firewall configuration, though again I don’t have anything setup in the redirect rows under that check box.

I also tried setting up a fixed IP and configuring the eth1 server as a DHCP server, then connecting the eth1 cable to the ‘connection to modem’ terminal on the wireless router. When I did this, I could not even see the configuration page for the wireless router, so that appeared to be even worse. With the other configuration, I could at least see the wireless router configuration page and connect to the wireless networked printer in another room.

I suspect that I have either (or both) of the IP forwarding or the Masquerade network configurations incomplete, and I’m hoping that someone can help me fill in the gaps.

Any assistance gratefully received.

Thanks in advance.


I am always suspicious for the unexpected. You use two DHCP servers on two different networks. They not, by accident, serve the same network range?

If it were me, I would take the cable router connection and instead of plugging it in to eth0, I would plug it in to the Belkin Wireless-G plus router’s connection labeled ‘connection to modem’. … But I don’t have the manuals on those devices to read up, so that may be a bad approach.

The first DHCP server is provided by the cable company. ifconfig tells me that the IP range provided by this connection is 65.87 etc.

The internal DHCP server connection is set for the 192.168.2 range.


Ok, as long as they are different. But you did not tell that you checked this and my experience is that those are often the holes in problem assessment.

Not a problem - anything which gets me closer to a solution.

To eliminate a couple of variables, I removed the router from the setup, and connected my second machine directly to the eth1 port of the first via a hardwired cable.

Prior to making the connection, I set up the network address to a fixed address of, subnet mask /24 and gave it a hostname of desktop. I assigned it to the internal zone of the firewall, and set the MTU to 1500 (Ethernet / DSL / Broadband)

I then used Yast once more to set up DHCP as follows:

When Booting
Clicked on ‘Start server now’
LDAP support is unchecked
No DHCP server startup arguments

Card Selection
eth1 is selected
‘Open firewall for selected interfaces’ is checked

Global Settings
LDAP support is unchecked
Primary and secondary nameserver IP addresses copied from the two entries in /etc/resolv.conf
Default Gateway is blank
Default Lease time is 4 hours
Domain name set to limeyworld
NTP, print and WINS servers all blank.

Dynamic DHCP
Greyed out areas list current network = with a netmask of with netmask = 24 and IP address range to
I left first IP address and last IP address blank, and left ‘Allow Dynamic BootP’ unchecked.

Host Management
Added the IP Address, and hardware address of my eth1 hardware, giving it the name ‘desktop’, and selected the ‘ethernet’ radio button.

I then used the /etc/init.d/net.eth0 restart command on my gentoo based laptop, and I get the error messages
eth0: dhcpcd 4.0.15 starting
eth0: waiting for carrier
eth0: timed out.

While typing this, I realise that it will not work without a swapover ethernet cable, which I unfortunately do not have.

Trying to make the connection via the wireless hub, I can ping the address of my eth1 network location from the laptop (the laptop IP address is configured using the DHCP server built into the wireless hub), but still no internet. The firewall on the hub is disabled.

If I connect the eth1 connection to the modem port of the belkin router, I do not get any connection at all.


Do you mean to say if you plug the cable modem output cable to the modem port of the belkin router you do not get any connection at all? Because I never suggested plugging eth1 to modem port of belkin router.

I always have problems helpiing people with these sorts of things because they talk about ‘tyhe second machine’ and ‘the other’, and the '‘Belkin router’ router, etc. I graphical representation of these sort of networks is almost alway needed. When I read opldcpu’s post I get the idea he has a differnet picture before his eyes then I have. Is it possible to provide us with something like a picture with sysme names, IP addresses, etc.

Also, it is not very wise to have your firewall switch on during these tests. You will never know for sure if it does not work because of the firewall or of something else.

Indeed, … my understanding with routers and cable modems, is one plugs into them with an ethernet connection, and then opens a browser on one’s PC and configures them.

If one has the cable modem plugged into the router, and if one has the PC plugged in to the router, should it not be possible to access the cable modem on a PC via the router? I confess I’ve never owned a cable modem, but I have owned various other High Speed DSL modems, and that is always the way I do this. Why is a cable modem so different?

Ah - OK. I misunderstood.

I definitely get an internet connection to the desktop by plugging the modem connection directly into that. For some reason, I can’t get it to share that connection to the rest of the network via the belkin router.

I also definitely get an internet connection to all parts of the network by plugging in the modem to the wireless router directly.

Let me step back a page to my reasons for doing all of this networking work.

What I really want to do is share files in a secure fashion from the desktop to other computers on my LAN. As a prelim to this, I was trying to set up the system so that the wireless network was controlled by my desktop, and the desktop acted as a firewall for all communications to the internet.

Once I have the server acting a reliable connection to the internet for the internally networked computers, I then want to provide access to certain folders on the desktop as a common file server.

Perhaps there is a better way to do this?


Ok, that is what I expected.

Ahh … Eureka … now I understand why you are looking at alternative approaches.

I don’t know. My apologies for my disruptive suggestions. I had thought you were just trying to get basic functionality, and not delve into something deeper. My mistake.

In truth I can’t help here with the advanced features you are trying to implement.

Good luck !