Setting the Default Browser curiosity

I have opensuse 42.1 and I selected to install the xfce4 desktop. From the settings menu I changed the default browser from Firefox to seamonkey and it had no effect. I had a memory of something like this happening before, so I installed gnome-control-center and changed the default browser in that, and voila! it worked! So I am curious to know why this is? Maybe xfce4 should have a dependency for gnome-control-center instead of whatever it installs by default.

Certainly not because it has its own control center.

How did you install Seamonkey? From where? Usually if you use a third party repo then you can choose the default app in the settings menu from the drop down menu. Change to the correct path where you installed Seamonkey.

It is installed from the standard repository, vendor opensuse. I expect I typed zypper install seamonkey, that’s what I usually do, otherwise I used Yast2.

When I ran seamonkey it did ask me if I wanted it to be the default browser, but I said no, because I don’t know what changes it would have made, or how to reverse them. I have had similar problems with firefox making itself the default browser and then finding it impossible to stop it.

You say xfce4 has its own control center, but it didn’t work. Gnome-control-center didn’t quite work either.

Do you know where the changes go? I think it is in xdg-open somewhere, but it seems to depend on other factors like which desktops are in use or have been in use.

What I want is to have seamonkey as the default, but to be able to easily change it later if I want.

Strange. When I go to Xfce settings, preferred applications, I can select the default browser. I only have Firefox and Chrome so I cannot speak for Seamonkey.
What happens if you choose /usr/bin/seamonkey?

OK I have repeated the experiment to describe exactly what I do. At this point I am starting with seamonkey as my default browser, and I will attempt to change it back to firefox.

  1. So I go to settings -> preferred applications, and change the browser from seamonkey to firefox.
  2. I launch xfce4-terminal and type #
  3. I move the cursor over the link, right click and select open link, and it opens it with seamonkey instead of firefox.
  4. I log out and log in again, repeat 2,3 and the same result.
  5. I launch gnome-control-center and go into “details” option (not a great name for an option, but never mind) and change the browser from seamonkey to firefox. I then repeat steps 2,3, and firefox now launches correctly.

So my conclusion is that xfce4 ignores the settings on the menu and honours the settings in gnome-control-panel.

It’s possible this only applies to xfce4-terminal as described, opening links from within thunderbird or seamonkey --mail is more complicated I think.