setting SMB permissions

can anybody correct me if i am wrong,
i go to Yast/smb server/shares to set permissions?

i try to share folders on one suse computer and on the other suse computer (or on the computer i share it on when i go through network) it asks
“please enter authentication information for: server = aspire Share = groups”

even if i enter root and put correct password i get the thing asking for the password again. then when i click cancel it still asks again or gives: access denied to smb://root@aspire/groups
if root is banned then this must be a bug as all shares should allow root!

on the microsoft computer, it dont even ask for a username or password, nor it wont allow me to see the shares and says “//aspire is not accessible, you might not have permission to use this network resource.”

i had disabled the firewall on the target machine as i found i can see the shared folder names from other suse machine if i disable it, EVEN if i have enabled samba client and samba server in the firewall. so had to disable it.

summary:
problem 1 how to access shares as guest and as root
problem 2 how to make the firewall WORK

windows machine is perfectly accessible.

Charlie.

later the windows pc did work, asking for user/password which none worked.
and how do i get rid of “enter username and password for joining the domain WORKGROUP” it says leave it blank and then i get “unable to find a suitable server for domain WORKGROUP”

Checkout @swerdna’s
openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna

problem 3: get rid of that domain password thing

i clicked the wrong button causing my settings to not be changed. i added Guest OK (saved propper) and can now log in as guest (not as root)

had started looking at that… only looked as far as “on the fly sharing”

Now it says
Timeout on server
aspire

all i did was make a folder in HOME called “public” set write permissions for group and others and this is what it did. (didnt check the specail box of any

does transferring files work for anyone???

i had quite a few attemts at getting this to work that was the reason for the last line.

somehow the permissions interfered it didnt work’

shared public folder specificly and it works now.

On Sat October 9 2010 12:36 am, charlieb000 wrote:

>
> can anybody correct me if i am wrong,
> i go to Yast/smb server/shares to set permissions?
>
>
> i try to share folders on one suse computer and on the other suse
> computer (or on the computer i share it on when i go through network) it
> asks
> “please enter authentication information for: server = aspire Share =
> groups”
>
> even if i enter root and put correct password i get the thing asking
> for the password again. then when i click cancel it still asks again or
> gives: access denied to smb://root@aspire/groups
> if root is banned then this must be a bug as all shares should allow
> root!
>
> on the microsoft computer, it dont even ask for a username or
> password, nor it wont allow me to see the shares and says “//aspire is
> not accessible, you might not have permission to use this network
> resource.”
>
> i had disabled the firewall on the target machine as i found i can see
> the shared folder names from other suse machine if i disable it, EVEN
> if i have enabled samba client and samba server in the firewall. so had
> to disable it.
>
> summary:
> problem 1 how to access shares as guest and as root
> problem 2 how to make the firewall WORK
>
> windows machine is perfectly accessible.
>
> Charlie.
>
Charlie;

This HowTo should help you get things going.
http://opensuse.swerdna.org/suselanprimer.html

Here are a few things to take special note of:

Make sure you open the firewall (Allowed services) for the Samba Server;
Samba Client and Netbios Server.

Create Samba Users with:


su
smbpasswd -a <username>

The username must be a valid Linux user but the password need not be the
user’s login password.

Samba must also obey Linux permissions so make sure your user(s) have access
to the shares.

Make sure the Workgroup is set to the same value on all your machines, Windows
and Linux.

Swerdna’s howto covers all these topics. If you still have problems after
going over this Howto, please post the contents of your /etc/samba/smb.conf.
You can conceal any sensitive data such as domain names or public IPs with
substitute values


P. V.
“We’re all in this together, I’m pulling for you.” Red Green