setting samba with YaST then authentication fails 11.4

I am able to see my samba shares on a windows xp machine, but the username/password combination fails.
I setup samba with YaST.
firewall is disabled.

Let’s have a quick look under the hood, please post here the contents of the config file (smb.conf) located at /etc/samba/smb.conf

PS just to be thorough, what do you get when you issue these two commands in a terminal window:
su -c “rcnmb status;rcsmb status”
su -c “pdbedit -L”

Remember to delete smbd and nmbd (or something like that ;)) profiles in AppArmor (using YaST)
Otherwise samba won’t work properly.

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2011-03-01
	workgroup = WORKGROUP
	passdb backend = tdbsam
	printing = cups
	printcap name = cups
	printcap cache time = 750
	cups options = raw
	map to guest = Bad User
	include = /etc/samba/dhcp.conf
	logon path = \\%L\profiles\.msprofile
	logon home = \\%L\%U\.9xprofile
	logon drive = P:
	usershare allow guests = Yes
	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
	domain logons = No
	domain master = No
	security = user
	usershare max shares = 100
	wins support = No
	ldap suffix = 
	wins server = 

## Share disabled by YaST
# [homes]
#	comment = Home Directories
#	valid users = %S, %D%w%S
#	browseable = No
#	read only = No
#	inherit acls = Yes
	comment = Network Profiles Service
	path = %H
	read only = No
	store dos attributes = Yes
	create mask = 0600
	directory mask = 0700

	comment = All users
	path = /home
	read only = No
	inherit acls = Yes
	veto files = /aquota.user/groups/shares/
	comment = All groups
	path = /home/groups
	read only = No
	inherit acls = Yes
	comment = All Printers
	path = /var/tmp
	printable = Yes
	create mask = 0600
	browseable = No
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin root
	force group = ntadmin
	create mask = 0664
	directory mask = 0775

## Share disabled by YaST
# [netlogon]

both daemons a running but this command :su -c “pdbedit -L”: yields no output.

The [groups] share directs to a directory (/home/groups) that simply doesn’t exist, so can ignore it.
The [homes] share exists and is accessible provided the various users have their credentials added to the Samba password database, run this command to add a user e.g. william to the database: sudo smbpasswd -a william
This is for existing Linux users. Each user who is in the database can then access his/her home directories on addresses like this from windows: \servername\william

The [users] share also needs names to be first added to the samba user database

‘sudo smbpasswd -a username’ worked for me.
thank you.

PS more on the The Suse/openSUSE default shares here: Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x