Setting mic in PulseAudio

When I first installed 11.4 I was unable to access the usb webcam mic on Skype. I use Tumbleweed and after a couple of KDE updates I was able to access the webcam mic in Skype. I did this by setting the webcam mic as the first device to use in either pavucontrol or systemsettings>multimedia>phonon>audio capture. There have been many KDE updates since then and now I am back to having no mic in Skype. I will set my webcam mic as described above but pavucontrol will no longer save my changes. It is permanently stuck using internal audio analog stereo as the first capture device. My webcam mic is listed but it is four down on the list and Skype will not access it.

How can I get pavucontrol to save my preferences?



What is the issue here ? Is the issue that your webcam mic no longer will pickup audio in Skype and no longer record audio ? or is the issue that pavucontrol will no longer save your USB mic settings in Skype ?

Note USB mic settings for Skype should be saved in Skype (not in pavucontrol).

They are both interconnected. The webcam mic will not function unless it is listed in the top position. I cannot get pavucontrol to save my changes placing the webcam mic in the top position.


Also note that Skype only has one mic option which is pulseaudio server (local).

Please be certain that when using pulse audio, you select to show ALL streams/devices.

Can you provide screen prints of your puavcontrol tabs for : configuration, input devices, recording. Again, ensure you select to show ALL streams/devices from the SHOW.

Just how is the webcam mic wired? Is it treated as a USB mic ? What is the output of:

lsmod | grep usb

What is the output of:

arecord -l

Sorry for the delay, I was out of town. Here is what I get when I run lsmod and arecord:

dave@Voyager:~> lsmod | grep usb
usblp 18233 0
snd_usb_audio 125367 1
snd_pcm 108939 5 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_usb_audio
snd_hwdep 13604 2 snd_hda_codec,snd_usb_audio
snd_usbmidi_lib 29145 1 snd_usb_audio
snd_rawmidi 34789 1 snd_usbmidi_lib
snd 86048 20 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_pcm,snd_timer,snd_hwdep,snd_usbmidi_lib,snd_rawmidi,snd_seq_device

dave@Voyager:~> arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Webcam [Philips SPC 1300NC Webcam], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

The dialogue in system settings shows both a webcam camera and webcam audio usb option along with the other options. In pauvcontrol only the webcam camera option is listed along with the internal audio option. Pauvcontrol does not have a way to change the priority order of the devices. This is accomplished in the system settings dialogue. The system settings dialogue is what is not working properly and not allowing me to save my preferred device options.

I have taken screen shots of both pavucontrol and the system settings dialgoues but cannot figure out how to upload them to this site without going through youtube, facebook, etc which is not an option for me.



I typically post my images to Fast, Free Image Hosting - ImageBam and then I select the “BB Code” tumbnail option and post here the code they give for the image. I find it works well.

According to that, your USB webcam is hw:1,0

What happens if you try to record with:

arecord -D hw:1,0 -vv -f cd test.wav

and replay the file test.wav with a media player ?

I uploaded the photos as you suggested, thanks. The urls are:

ImageBam - Fast, Free Image Hosting and Photo Sharing

ImageBam - Fast, Free Image Hosting and Photo Sharing

I also tried the command you suggested. There was no sound recorded. This mic was working a couple of weeks ago until a KDE upgrade. It has not worked since. The camera is working. Here is the output from the command:

dave@Voyager:~> arecord -D hw:1,0 -vv -f cd test.wav
Recording WAVE ‘test.wav’ : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 16000Hz)
please, try the plug plugin
Hardware PCM card 1 ‘Philips SPC 1300NC Webcam’ device 0 subdevice 0
Its setup is:
stream : CAPTURE
format : S16_LE
subformat : STD
channels : 2
rate : 16000
exact rate : 16000 (16000/1)
msbits : 16
buffer_size : 8000
period_size : 2000
period_time : 125000
tstamp_mode : NONE
period_step : 1
avail_min : 2000
period_event : 0
start_threshold : 1
stop_threshold : 8000
silence_threshold: 0
silence_size : 0
boundary : 9007199254740992000
appl_ptr : 0
hw_ptr : 0
#+ | 01%^C
Aborted by signal Interrupt…

There was a kernel upgrade with the KDE upgrade. Could it be possible they broke the phillips (pwc) module?

Thanks again,


I don’t understand this reference to a KDE update.

I’m sorry to read you have not succeeded yet.

Please, am I asking for too much information and thus confusing you? I ask because you are providing different information than what I requested, and hence I am thinking I have confused you.

Here is what I asked:

You provided only “input devices” screen print, (I could not find the configuration tab nor recording tabs screen prints I asked for) and you did not follow my request to show “ALL streams / devices” from the SHOW.

Anyway, FORGET that, as it is a mute point.

Something more important follows …

You mentioned you updated KDE4. To what version ?

If to a non-standard SuSE-GmbH version, then I’m also thinking, given your comment about updating KDE, that I should leave this thread.

Sorry, but its a matter of principle to me.

I’m a volunteer. Not paid. My experience is such KDE updates cause more problems for sound than they are worth for many users who do not understand the KDE sound system. Hence I myself refuse to do such updates on my own PC, and hence I hope you understand since I don’t want the annoyance (that can be caused by such KDE updates) on my PCs (as its irrating when not working), I am very reluctant to be dragged into someone elses KDE update efforts in area that I don’t like doing myself. I’ve never liked doing KDE updates.

IMHO those who want to update KDE and go beyond the tested SuSE-GmbH stock version are into software that I don’t like to provide volunteer support.

On a final note, my guess, thou, is you have either pulse audio configured wrong, or your mixer misconfigured, or its a problem with a non-nominal KDE4 from your update (the sort of update I refuse to do). I can not tell which nor do I want to spend time figuring out which.

I’ll let someone else who likes to play with updated KDE dive in to this thread.

Hopefully someone will help as many people disagree firmly with my KDE view.

Good luck and Best wishes.

once again i did have the same problem with microphone and i fix it trough alsamixer

open terminal type alsamixer then F6 choose your sound card there ( default/usb webcam) after you choose one hit f4 then choose your input source (rear/front/line microphone) then boost up or low whatever you like it in my case after i did this micro work with skype :slight_smile:

As I said in my original post, I update via Tumbleweed. Currently my kernel is and the KDE version in 4.6.4 ‘release 4’. Tumbleweed is an official SuSE-GmbH source or so they like to think. Sorry I misread the quote about what you wanted from pavucontrol but I agree that we have failed to communicate.

Guess I’ll have to live with it until someone else gets it fixed.

Thanks for the idea. I tried doing what you said but it did not help. Skype is seeing the pulseaudio local server as the only input source. I am unable to get pulseaudio to use the webcam mic as the default capture device. Pulseaudio keeps using internal analogue audio as the default capture device. I am not willing to dump pulseaudio and go back to alsa because everything else is working very well.

Thanks again,


We have a separate Tumblweed thread for tumbleweed issues. Maybe I should move this thread there ? I don’t think it belongs here in multimedia.

Tumbleweed is a 1st for SuSE-GmbH and openSUSE and hence in many respects its still a trial and recommended for advanced users, or adventurous average users. I think there is next to no ‘official support’ and probably only limited openSUSE community support from Tumbleweed enthusiasts.

As noted, I don’t have the patience to deal with the impact of KDE updates on sound. I’ve been bitten in the past where I spent too much time trying to solve mine (and later other users) sound problems, only to find it was because of a KDE update. I made myself a promise that I won’t waste my time any more on that. Users who want the latest cutting edge KDE need to get others to help them with their sound.

Now I am a BIG KDE fan, but I use only the stable KDE that comes with openSUSE nominal version (NOT tumbleweed) and I only apply the security updates. I do NOT try to keep pace with the latest KDE’s released by the KDE team, even if ‘they’ think it stable. My Tumbleweed desktop of choice is LXDE.

But so that you are not left out in the ‘cold’, pay careful attention to the ‘pavucontrol’ control options and menu selections. If you do not have the correct “SHOW” setting in the various tabs, you WILL be mislead as to what is possible and can easily draw wrong conclusions.

Do not forget you have many diagnostic tools available for sound … ie commands such as :


which is a script that will give you lots of information on an assortment of things. In particular pay attention to what the hardware audio codec is for your hardware, as if there was a problem introduced by a kernel updating, often searching on that codec and alsa and kernel together will provide information on others with similar problems. One can also discover bug reports by searching on the hardware audio codec.

Don’t forget you can get mixer settings with :


and there are a host of options for amixer that yields all sorts of useful information.

Also don’t forget

aplay -l


arecord -l

and there are a host of aplay and arecord options that yield lots of useful information.

As to what you do with the information, well given the uncertain that the KDE update has introduced, its really up to you to decide if you want to spend the effort to get things working exactly how you want. I don’t have the patience for KDE updates.

Again, my tumbleweed uses the LXDE desktop.

Thanks for replying back. I have a second machine for the kids that has a standard 11.4 install (no Tumbleweed) with all updates current. I put the webcam on this machine last night and had the same problem.

Since I have 2 machines I might as well get a webcam for each one. I have been looking at the Logitech C510. Do you know of a webcam that is known to work. I have already gone to the links posted in the forums for Logitech but their website was last updated in early 2010 and I cannot find the models listed there, too old.

This way I will know whether it is a hardware or software issue.

Thanks again,


Generally speaking, I think some the Logiteh series (ie 210, 310, 910 … ) are pretty good, as they are ‘uvc’ compatible. Being ‘uvc’ compatible is what I believe to be MOST important for GNU/Linux compatibility. Some time after I came to that UVC (being good) view (about a year after) I read somewhere else that Microsoft very recently also started throwing their weight behind pushing webcam manufacturers to make their webcams ‘uvc’ compatible. So IMHO it is even more important in my books that webcams be uvc compatible, and it should not be too difficult to find such webcams.

The problem is, most manufacturers do not state if their webcam is uvc compatible, so one needs to research on this. For information on webcams and openSUSE, I always go here (although the page is out of date and someone needs to update it: HCL:Web cameras - openSUSE ). In particular for uvc webcams it points one here: Linux UVC driver & tools but that is out of date !

I think the Logitech C510 is a UVC compatible webcam, but you need to search for that. I searched and read some posts suggesting it may be UVC compatible. IF it is UVC compatible, then that makes it very likely to be supported, and if it does not work well, there is a VERY active and help mailing list where one can ask the developers to help work on improving the webcam’s UVC compatibility aspects.

For general ‘theoretical’ information, there is a wiki here on UVC (USB Video Class or USB Video device class) which describes devices capable of streaming video like webcams, digital camcorders, transcoders, analog video converters, television tuners, and still-image cameras. The latest revision of the USB video class specification carries the version number 1.1 and was defined by the USB Implementers Forum in a set of documents describing both the basic protocol and the different payload formats. Since Linux 2.6.26 the driver is included in kernel source distribution.