Setting laptop function keys in OpenSuse 11.1

Hi!

I have just installed OpenSuse 11.1 on my Asus f3jp laptop and my function keys like volume control are not working, except display brightness that work but don’t show any bar.

I’ve been searching about how to make them work, but unsuccessfully.

How can I configure these keys? (volume, brightness, wireless, tv-out, touch pad, etc…)

Thanks!

Hi
You need to investigate acpi on your system, here are some links;
<http://www.linlap.com/wiki/asus+f3jp>
<http://www.gentoo-wiki.info/Asus_F3Jp>
<http://www.linux-on-laptops.com/asus.html>


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
up 12:11, 2 users, load average: 0.81, 0.32, 0.22
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Apparently, there is a certain package which needs to be installed, for those keys to become functional. I don’t remember the package name, but you can do a text search for “function keys” in package description, within the software repository.

I’ve found “initial” and “keytouch”. Any of these?

Hi, I’ve also have this problem on a vostro 1500 using KDE. I’ve never had a problem though with GNOME. If you guys can please help me find the answer its still good to know

I have installed kdeutils3, but I can’t find kmilo configuration.
Does anyone know how to do it?

Isn’t there a kdeutils4 (for kde4)?

I have an F3JP too and the problem was the same on all distribution I tried.

Nobody know how to config the keys on this laptop ?

These laptop should all be covered by the kernel. The module asus_laptop takes care of it. The keys on mine stopped working for a while (first KDE4 releases), but I didn’t bother about them too much. Now (see my signature) they are working. Though the extra keys above the keyboard don’t.
You could try to run sax2 and pick the Asus laptop keyboard, and pick that one in KDE as well.

Tried installing hotkey-setup already?

Search for and install keytouch.

Here is the entire how-to on the wiki:
Keytouch - openSUSE
Goog luck.

Keytouch won’t help with some of the hotkeys in laptops since they don’t send a keycode.

I have a similar problem with my Thinkpad. All the function keys worked under Gnome but under KDE only the brightness and volume keys work. The suspend to ram / disk, screen lock, eject from dock, etc don’t work.