Setting Host Name on router

I am running

Linux HPDV7-Linux 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

On my laptop (HPDV7), using DHCP for network access, KDE4.
I use Network Manager to manage wired and wireless connectivity.

I also have Samba server running for connectivity to Windows machines.

My router runs DD-WRT.

How do I tell this HPDV7 system to propagate a Host Name up to the router?
In the DD-WRT status screen, I see Host Name as “*” associated with the assigned IP address.

I cannot, for example, ping my HPDV7 machine from my windows machine, I assume because the router (also providing DNS for my network) does not provide the name to address translation.

I CAN ping the IP address directly, and Samba connectivity from the Windows machine to HPDV7 works.

The file

cat /etc/HOSTNAME
HPDV7-Linux.capenet

is correct.

Thanks

Don’t use kde, but if you right click the knetwork icon and choose edit connections>network card and then edit, there should be a place in the dhcp4 tab to enter the host name.

Thanks for the suggestion, but no luck as yet.
The hostname fields in Yast are set to my hostname, and the following all seem correct:

HPDV7-Linux:~ # cat /etc/HOSTNAME
HPDV7-Linux.capenet
HPDV7-Linux:~ # hostname
HPDV7-Linux
HPDV7-Linux:~ # cat /etc/hosts
#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#

127.0.0.1       localhost

# special IPv6 addresses
::1             localhost ipv6-localhost ipv6-loopback

fe00::0         ipv6-localnet

ff00::0         ipv6-mcastprefix
ff02::1         ipv6-allnodes
ff02::2         ipv6-allrouters
ff02::3         ipv6-allhosts
127.0.0.2       HPDV7-Linux.capenet HPDV7-Linux

I also tried setting under the “Manage Connections Tab” (right click on NetworkManager in tray, navigate to wireless tab, then to my specific connection and edit, the IP Address tab)

DHCP Client ID: HPDV7-Linux

So far, nothing seems to work.

Any other ideas out there?

Solved! sort of.

I found and old item (18Nov2009) that offered up this workaround:

in /etc/dhclient.conf, add


send host-name "*myhostname*";

Log out, log in and hostname shows on router.