Setting Hardware configuration in yast does not work.

I have 2 wireless cards:

wg111v2 - Uses RTL8187 drivers
ur054g - Uses p54usb

I have found out that the RTL8187 drivers don’t work in opensuse. So I went to try my old ur054g usb wireless. The driver for that is p54usb so I plugged it in and as root entered:

modprobe p54usb

When I ran iwconfig it was not in the list all I had was

lo
eth0
eth1
pan0
wlan0 → wg111v2 with rtl8187 drivers

there was no wlan1 which I was expecting

I tried adding a card in yast with:

Device type: wireless
Configuration Name: 1
Module Name: p54usb

But after it was setup Yast says “(no hwinfo)” and it does not appear in ifconfig.

I then tried ndiswrapper to see if I could get either card to work. I got the drivers for both and was shown hardware and driver present in ndiswrapper -l.

I then ran as root:


modprobe -r rtl8187
modprobe -r p54usb
modprobe ndiswrapper
iwconfig

Still nothing appears in ifconfig and iwconfig. And in yast adding a new card with module f ndiswrapper I still get “(no hwinfo)”.

I have no idea what could be wrong.

Dumb Question - Are you sure the driver is loaded?

Your email stated that you ran “ndiswrapper -r” which will remove the driver.

run “ndiswrapper -l” which will show you if the driver is installed.

–over the weekend I ran into a situation where I install the MS Vista drivers for my wireless card and could not get the wireless card to work. I then installed the MS XP driver and the card worked great.

I’m using the correct drivers and they are installed ndiswrapper -l shows me they are there.

I have given up it has been todays of stress and annoyance. I am going to buy a wireless pci card. What is a card that is garunteed to work without bothering to mess with ndiswrapper just appears in yasts network devices?.