Seting static routes HEEElP!!

I have laptop and desktop on wireles router ,both with opensuse 11.1.
Desktop is with eth0 attached on lan1 port,and laptop is using wireless
I am trying to set up NFS , witch works fine until reboot , when (not always) local ip is changed
How to make let say dektop ,and laptop (that ips are now assigned) or whatever diferent,but permanent?
Router is on , and modem is on working perfectly.
On yast>network settings method is ifup
Please help!!!

you need to set the router to permanently give the ip’s to the devices.failing that,do not use dhcp


I agree with deltaflyer44. You do not need static routing, but static IP addresses.

On router interface i found page :IP Config - Route
with table like this :
Network/Host IP ,Netmask ,Gateway,Metric,Interface
and icfonfig gives this:
eth0 Link encap:Ethernet HWaddr 00:1D:7D:C7:7C:CA
inet addr: Bcast: Mask:
inet6 addr: fe80::21d:7dff:fec7:7cca/64 Scope:Link
RX packets:257808 errors:0 dropped:0 overruns:0 frame:0
TX packets:161334 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:341815528 (325.9 Mb) TX bytes:13865354 (13.2 Mb)
Interrupt:220 Base address:0x8000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:776 errors:0 dropped:0 overruns:0 frame:0
TX packets:776 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:43279 (42.2 Kb) TX bytes:43279 (42.2 Kb)

How to fill fields?

You need to go in to YaST & edit your device, & set it NOT to use DHCP.Then set the device to use static ip address with the router as the gateway etc


Sorry ,cant find no dhcp option,im confused

I give upp…

Hey serbianSuseUser, what is this? You cry **HEEElP!! **in distress, we come to the rescue and within a few hours you give up? >:(

I am on 10.3, but on 11 it cannot be very different:
YaST > Networkdevices > Networkcard.

Choose you card and cllick the Change button below (or what the name is, not the Add or Remove ones).
Then, in the Address tab, check “static IP address” (the Dynamic check before the DHCP button will uncheck then). Now fill in the IP address (e.g., netmak ( and the hostname.
Finish this.

Sorry,man ,i’ve spent few days on this, its frustrating.
There is no YaST > Networkdevices > Networkcard on 11.1 , but YaST > Network settings .I can press edit > statically assigned ip adress. But then card stopps working?!(in small window says “card will not be started at all” ,or something simillar)
Adress and netmask are same you wrote,and hostname is desktop (that is hostname in Hostname/dns tab and was no problem so far)
Again, I am verry grateful for any help and hope that will be no bad feeleengs :embarrassed:

Don’t give up, you’re on the right path.

Set the static IP’s to and
Set the gateway to
Set the DNS servers of your provider and as well

Now you should have a network connection, both machines with the right IP’s.

Then start Yast - Network services - NFS server on the desktop computer and export the desired partitions/folders
If you want to check that, your /etc/exports contains the exported NFS shares.

Then go to the laptop. Start Yast - Network services - NFS client, enter for serveraddress, pick share to mount from list, let it mount where you want it to, DONE.

No hards feelings at all. But we all hope that together we will get you where you want to be.

Anyone for a detailed description on how to configure a fix IP address (no DHCP) with YasT (or otherwise) in 11.1?

So far,so good !!:slight_smile:
Done just as @Knurpht said ,and seems ok.
I rebooted laptop,desktop and router and ip’s are same.(hope it will stay that way):wink:
1.When i rebooted ,on desktop remote directory from laptop was auto-mounted, but on laptop was nececary to go yast>nfs client > and simply “ok” (directorys are already set) to mount.On system services on laptop nfs is “yes*” (with *).Can this be auto as well?
Thank you very much, people!!
I’ll bay you a beer some time lol!lol!

Just noticed :
when I turn laptop off some apps on desktop won’t work!
Must go on yast > system services> and disable nfs to unmount remote dir!
Here is no “*” on system services >“yes” like on laptop ?
Maybe automount is not good idea?