set up vnc

Dear all,
I need some help install and configure my vnc session at my Opensuse.
Right now I have installed nx client which works fine and is listening on port 5901.
I also want vnc to use when I want to check exactly what is going on my work’s computer (when I go home)

I am reading the tutorial here:
SDB:VNC usage - openSUSE

and I would like to ask you the following


For VNC client connection remember to open ports 5901-> in the firewall. (1 port/Xsession.) 

nxserver is listening to 5901. How to configure vnc to listen to 5902.

  1. The guide also refers that
User sessions

Here we "Prestart" vnc sessions for specific users, therefore no login screen is presented. This uses more resources as the VNC Session is running even when no client is connected to the session watching it. But there in lies it's advantage, "watching a session" and "using a session" are not the same thing! This method is very usefull for starting long running programs before going home. Once home you can re-connect to the session and see how things are going. 

What the guide means by “here” (first word in the text above). I did not find any code or cli that will help me prestart my service.

I would like to thank you i nadvance for your help


This might be helpful, it’s got coverage of the most important steps, how to setup ports and so on: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

I would like to thank you for your answer.
I tried everything but I do not get any kde4 running. I can the loading screen at the beginning but I end up with TWM. Is there any log file whee I can check why kde4 does not load up?


Let’s check a few things, please run these commands and report back:

  1. To test the RPMs run this:
rpm -qa | grep vnc

I get xorg-x11-Xvnc-7.5_1.8.0-10.3.1.x86_64 and tightvnc-1.3.9-110.1.x86_64. What do you get?

  1. To test which desktop environment is invoked when vnc starts, run this command:
cat ~/.vnc/xstartup

What do you get?

  1. Finally, please tell me what you do to start the vnc server. I run this command to start mine:
dbus-launch vncserver :1

What do you run?