Set up TOR as relay - closed Ports


I’ve been looking for the error in my setup for some hours now - still no luck.

I have TOR, Vidalie, Polipo installed on my OS 11.4 x64 and I’d like to make it into a relay.
The client-configuration works just fine - I can acces the net by using TOR with FoxyProxy for FF.

But each time I start TOR (through Vidalia) I get, after a long time, the message that neither my DIRPort nor ORPort are open.

I have forwarded these ports from my router to my PC (setting a fixed local IP) and have tried to puncture some holes into the OS Firewall in the Allowed Services>Advanced… section by opening the ports 9030, 9001, but it still does not work.

Any Idea what I could try?

Look into firewall logs on your openSUSE. You may need to enable logging of dropped packets with Yast for example (it should be somwhere in the same firewall GUI).

IIRC the logs should be in :


Best regards,

Thanks for the answer, but my problem was another.

Somebody messed with the router-config and changed the ports so everything was set-up OK on the machine, but it never went further than the router.
Had to hunt the password for that one for a week, but it works - finally.

I’m glad it works now :slight_smile: Thanks for the feedback.

Best regards,