Set KMail spell check to French, while system is in English

Can’t import any more dictionaries into KMail, stuck with USA and UK, need French.

Everythings’s in the title. My messages in French all get red underlines which is annoying. I’d like the automatic corrector to know the French dictionary.

Distro : openSUSE Tumbleweed (up to date), with KDE Plasma 5.27.7

System language settings:

  1. British English
  2. français
  3. espanol de Espana

KMail language settings: USA dictonary, UK dictionary, and auto-correction set to French.

Any help would be welcome, thanks in advance!

@ultome:

Do you have the French Aspell, ispell and Myspell dictionaries installed?


I tested here with Leap 15.5 –

  • I had English-US (default),German, English-GB, and French dictionaries installed.

  • Entered some Spanish sentences into KMail (automatic detection of language in the KDE Plasma System Settings Spell Check settings enabled).
    No chance – no way to select Spanish – red underlining everywhere …

  • Installed the Spanish dictionaries – KDE System Settings Spell Checker suddenly offered Spanish as a language to be checked – check the box …

  • Tried again with a new KMail e-mail – no joy.

  • Restarted Kontact – Et voilà !
    No more red underlining – right-click → spell check language → amazing – suddenly Spanish is in the list of available Spell Check languages …

Installed the Spanish dictionaries

How? Can you describe the exact steps?

(I’ll remember to restart Kontact after this)

@ultome:

 > LANG=C zypper search --installed-only spell
Loading repository data...
Reading installed packages...

S  | Name                              | Summary                                                 | Type
---+-----------------------------------+---------------------------------------------------------+--------
i  | aspell                            | A Spell Checker                                         | package
i+ | aspell-de                         | German (deutsch) Dictionary for Aspell                  | package
i+ | aspell-en                         | English Dictionaries for ASpell                         | package
i+ | aspell-es                         | Spanish (español) Dictionary for Aspell                 | package
i+ | aspell-fr                         | French (français) Dictionary for Aspell                 | package
i  | enchant-2-backend-aspell          | Aspell backend for the Enchant spell checking library   | package
i  | enchant-2-backend-hunspell        | Hunspell backend for the Enchant spell checking library | package
i+ | gspell                            | A spell checker library for GTK+ applications           | package
i  | gspell-lang                       | Translations for package gspell                         | package
i  | gtkspell3-lang                    | Translations for package gtkspell3                      | package
i+ | hunspell                          | A spell checker and morphological analyzer library      | package
i+ | hunspell-tools                    | Hunspell tools                                          | package
i+ | ispell-american                   | American ispell dictionary                              | package
i+ | ispell-british                    | British ispell dictionary                               | package
i+ | ispell-french                     | French ispell dictionary                                | package
i+ | ispell-german                     | German ispell dictionary                                | package
i+ | ispell-ngerman                    | New German ispell dictionary                            | package
i+ | ispell-spanish                    | Spanish ispell dictionary                               | package
i  | libaspell15                       | GNU Aspell Library                                      | package
i  | libgspell-1-2                     | Spell checker library for GTK+                          | package
i  | libgtkspell3-3-0                  | GTK3 Spell Checker Interface Library                    | package
i  | libhunspell-1_6-0                 | A spell checker and morphological analyzer library      | package
i  | libqt5-qtvirtualkeyboard-hunspell | Hunspell Plugin for the Qt5 Virtual Keyboard            | package
i  | libQt5HunspellInputMethod5        | Qt5 Hunspell Input Method                               | package
i+ | myspell-de                        | MySpell de Dictionary                                   | package
i  | myspell-de_DE                     | MySpell de_DE Dictionary                                | package
i+ | myspell-dictionaries              | A Source Package for Dictionaries Used by MySpell       | package
i+ | myspell-en                        | MySpell en Dictionary                                   | package
i+ | myspell-en_GB                     | MySpell en_GB Dictionary                                | package
i  | myspell-en_US                     | MySpell en_US Dictionary                                | package
i+ | myspell-es                        | MySpell es Dictionary                                   | package
i  | myspell-es_ES                     | MySpell es_ES Dictionary                                | package
i+ | myspell-fr_FR                     | MySpell fr_FR Dictionary                                | package
i+ | myspell-lightproof-en             | Lightproof for en                                       | package
 >

The French dictionaries you need are –

  • aspell-fr
  • ispell-french
  • myspell-fr_FR

Install with the YaST Software Management: <https://doc.opensuse.org/documentation/leap/startup/html/book-startup/cha-yast-software.html#sec-yast-software-qt>

  • Or, if, you’re comfortable with administration by means of a CLI –

# zypper install aspell-fr ispell-french myspell-fr_FR

1 Like

This worked wonderfully! Now my dictionnaries are in my system, and most apps (LibreOffice, Kate…) underline French words if the spelling is wrong. Most apps, but… not KMail. I have reactivated Spell Check for my outgoing emails, but I still don’t have the red underline I used to have on mispelled words. I can ckeck spelling for my whole email, but on the go I don’t see my mistakes while I’m writting.
So if anyone knows how to get these squiggly red underlines back, I’m all ears!
Thanks!

Did you check these settings (for Kmail and overall)? According your first post it is checked, but to be sure…
https://docs.kde.org/stable5/en/khelpcenter/fundamentals/spellcheck.html

Additional: System Settings > Locale > Spell Checker section → Automatic spell checking