"session_mm_apache2handler0.sem" file gets created in “/”(root) on each apache web server reboot, with the timestamp of the booting time, I suspect it has something to do with php.ini. Is there a bug, or I just need to define right path in php.ini file?

It looks like a recurrence of an old bug. Feel free to report it if you like.


I have uncomment “session.save_path” and set new path.
Now it’s gone :wink:

I don’t think that was the right setting to change. session.save_path is a directory for holding session data, whereas the stray file is a semaphore. Also the commented out setting is in fact the compiled default.

This was the only working solution to uncomment and instead of ;session.save_path = “/tmp” make it session.save_path = “/var/lib/php5” this way file which got created on each reboot of apache2 is gone/moved to var/lib/php5 …

Is there a better solution?

I don’t think it’s critical to put that file in the right directory, but I’m curious why one setting should affect another, which AFAICT is unrelated.

Is there anyone else who is having same problem/bug?