Session is always locked in kde 4

Hi :wink:

in opensuse 11.1 : how come my session is always locked in KDE 4.3.1 “release 179” ?

I did not choose this on purpose and don’t see where to change this.

thanks for ideas to improve this :wink:

When is it locked? When you login? When you leave it a while not doing anything?
You probably need to switch off powersaving and screen locking

When i leave it a while , but the fact is i did not switch on any powersaving, nor screen lock.

in syst config/desktop , the mandatory password box is not ticked

in in syst config/advanced thumb : powersaving general config allows to lock screen, this is off too.

Is there somehting else ?

What’s wrong then ?

Check in Power Management - General Settings
Look for Lock Screen on resume

Check thru all the settings, they are kind of all over the place.

Also check in desktop - screensaver
un-check everything

well , as i said above lock on resume is not used,
features all other the place as you said but not linked with locking the screen.

and in desktop screensaver : i’m just using the screensaver, do you mean using it locks (?)

is this thing just not working ? have you heard of such problems before ? (this used to be ok)

i’m just using the screensaver, do you mean using it locks (?)

I think it tends to, I would just try NOT using it at all and see what happens rather than me trolling thru all the settings to see where you might be going wrong.

Also see here that it’s not checked
ImageBam - Fast, Free Image Hosting and Photo Sharing

Well , you or someone else could have known the source of the problem :wink:

i can uncheck screen savers and maybe it’s gonna solve this lock problem , but isn’t a screen saver mandatory to protect the screen’s life ?
Does it need a bug report ?

On the picture you gave i had ticked the box, i unbchecked it to see if it does the trick, but if so it’s still strange for i can’t see any visible link with this and locking the screen.

You are correct. I personally think the settings in this area are a mess. As for screen savers. I just turn my screen off, which means I just have to press a button. All my screens outlive my use of them. In other words, I’ll want a bigger or better one long before it goes BANG!

manchette fr wrote:
> isn’t a screen saver mandatory to protect the screen’s life ?

no…back at the dawn of internet time (circa 1970s/80s) screens were
made with phosphorus bits which illuminated when hit by the cathode
ray tube’s stream of emitted electrons…

eventually, each tiny phosphorus bit would ‘wear out’ and no longer
glow with expected level of luminance and if you left the same (say)
line of text on the screen long enough it would ‘burn in’ and its
‘ghost’ could be visible even when the text was removed…

today, they are pretty much unnecessary eye candy adding needless
pollutants to the atmosphere by using CPU cycles drawing artistically
interesting shapes, colors, etc…

imo, it is much better to save those cycles (and the electricity
required to calculate and display them) by by selecting “Blank Screen”
and then, when you walk away from the machine, turn off the screen
itself (as do caf and i), for double savings…

more at:

Have a lot of fun…

After setting screensaver to blank screen and unchecking power mamanagement option (in the screen from the image above) i still have the same screensaver as before, which stays locked.

Do you have any packages like powersave or kpowersave installed?

No, i have none of these

What Power profile are you using? Performance or Presentation? or other?

i’m using performance scheme

You could try Presentation. It’s settings are such that it should not allow interference from Powersave.

But IMO you need to do some obvious experimentation. Eg; If you create a New user and modify it’s scheme for no powersaving as you have with your account, does it behave differently? If it does, we have a starting point.
You could then try a re-name on your current .kde4 folder and that will effectively (but not totally) be like a new user account for you, where you can redo all your powersave settings and see how it behaves.

i think i should wait a bit for 11.2, as it’s soon ready.
Then maybe doing such testing for what seems to be a bug will be avoided, in case 11.2 solves this. Thanks :wink:

Hi folks I have read the above and am still, as usual confused. my system locks session after 5 mins or so. I looked in the system settings suggested by Caf, but I WANT the powersaving, I do NOT want the session to lock, ie I do not want the session to lock, or put in a PW on resume, just move mouse or hit a key…
Is this not possible?

ps the help file actually works for this “module” (Woohoo! one of the 5% that do!) but there is no mention of password protecting session.

openSUSE 11.2 is not having this problem anymore, in v11.1 i never found a solution :frowning:

I have 11.2, session still locks…