Server says drive full but it isn't

Hi all

I have a simple file server that is running openSUSE 12.1 I’m aware that this OS is EOL, but this is NOT the problem here

We usually connect to this server over the LAN, with a mix of Linux or Windows machines as “clients”. The linux machines all run openSuse 13.1, regularly updated via “zypper up”

Only few machines (mine amongst them) have write permission to the server, the others can only read from it.

The server’s disks/directories are mounted on each linux “client” as follows:

mount -t cifs "//aaa.bbb.ccc.ddd/groups/dirname" /mnt/MOUNTPOINT -o guest,r,iocharset=utf8,file_mode=0777,dir_mode=0777

or, for those machines having write access

mount -t cifs "//aaa.bbb.ccc.ddd/rewrite_directory/dirname" /mnt/MOUNTPOINT -o user=(...), password=(....)

This has worked flawlessly for quite some time now, allowing reading/writing to/from the server’s disks…

However, as of a few weeks ago, if, from the linux machines, such as the one I’m using now, one tries to write to one particular disk on the server, the server returns a “disk full” message, whether I try copying a file via dolphin (I’m using KDE) or with a simple cp command from a terminal (all of
which I was able to do for years before the problem arose).

The disk in question is a 4 TB disk. This disk is NOT full, but is over half full.
This disk is NOT failing (checked that) nor having any other mechanical problem…
I can copy to that disk from the server itself without any problem.
(i.e. i can copy a file to another disk on the sever, then go to the server, log in there and copy
from that other disk to the one in question w/o any problem).

Now for the strange part:
If, using the SAME client machine (which can double boot into Windows), I try to write the SAME file to the SAME server disk, but from windows instead of from openSUSE, then the write succeeds - no “disk full” message (proving, incidentally that this is not a mechanical disk problem).

And even stranger:
If, using the SAME machine but back in openSUSE, instead of writing to the server using the mountpoint above, I write to the server from withing dolphin but using an smb:/ address (e.g. smb:/aaa.bbb.ccc.ddd/rewrite_directory/dirname), then the write operation ALSO succeeds.

It only fails if I try to write through the mount point. I hasten to add that I didn’t change anything concerning the mount points and that I can read OK from such a mount point.

Any ideas, anyone?

Thanks in advance


Are you using KDE 4.13.1?
This sounds like this bug:

Install libkde4 from here and it should work again:
If that is indeed the problem, you should still be able to copy files to the server with the command line or non-KDE programs though.


Thank you very much, your solution solved this problem!
I downloaded the rpm, installed it rebooted and everything works again.



FYI, this should be fixed now in KDE:Current as well.
So you can just switch back the package to the repo’s version again.

Hi, Thanks I switched back and all is still OK. Thanks for the info. Lenwolf