Serious networking problems with a fresh openSUSE install

Hi everyone,

I installed openSUSE today using a network installer cd, opting for the Xfce environment. Everything went smooth with the installer, but I have some issues with the network.

After the fresh install, nm-applet did not start. I got the following error:

** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area

** (nm-applet:14981): WARNING **: Fallback icon 'gtk-dialog-error' missing: (0) Icon 'gtk-dialog-error' not present in theme
ERROR:applet.c:2800:nma_icons_reload: assertion failed: (applet->fallback_icon)

I don’t know if the problem was with the applet or with the daemon. Fortunately I used Archlinux for a quite long time and I know how to connect to WPA2 encrypted wireless network from command line, so I was able to connect to the internet and do an upgrade - everything went just smooth and fine again.

After the update and restart, I found the nm-applet icon in the system tray. And here comes the second problem: I can connect with the nm-applet, but the connection does lasts only for about 10 seconds. So practically I can’t use the net this way either.

Ok, no problem, I fired up Yast, disabled the networkmanager and choose to start my network with the traditional method. I entered the required stuff from my wireless card ( ESSID and passwd ), set to activate at boot time and reboot.

Surprise, no internet connection this way too, and this one is really strange. I set up the essid and the password correctly, I looked at the output of the init ( Ctrl-Alt-F1 ) and it shows that everything is ok, wlan0 is connected and gets the correct IP address - but still no connection.

If I connect manually with wpa_supplicant and dhcp, it works, with the same IP address. Strange …
So I made a script to run at Xfce startup to set up my network connection … but somewhere there are bugs, which also will prevent me and maybe others to use openSUSE if I will require to switch between networks often.

I will wait to see some responses to this little networking story to see if I made some mistakes, and tomorrow will fill up bugreports, if will be necessary.

Almost forgot, my specs are : openSUSE 11.4 32bit, Xfce desktop on an Asus X55Sv laptop with Intel 4965AGN wifi card, running the default kernel.
I had no problems with this configuration using Archlinux and not so long ago openSUSE, but that time installed from KDE live cd - so there are chances that the problem is with my install, maybe some missing package, I don’t know.

One another strange think, but this one is really for curiosity: with Arch I used the wext driver with wpa_supplicant, with openSUSE I need to use nl80211. Does anybody knows why? I did not looked out yet for the differences between these two drivers, so this one is really just because it popped into my mind right now, the important problems are the ones above.

PS: sorry for the long post

I don’t know about your xfce problem, but you might try the close cousin lxde.
Worked fine for me, no problems including a working network manager.

xfce and lxde are very nearly the same, in fact they actually have the same codebase and so have a similar footprint.

From the error you posted, it looks to me that a lost component is missing. I can’t say whether a missing icon would be catastrophic in itself, maybe you have an empty space in the tray? Or, maybe it’s saying that nm is running but couldn’t setup accessibility? Hard to tell. If you really want xfce, maybe another install try is in order.


I will never find out what the problem was, since then I reinstalled openSUSE ( because of repartitioning ) and have no problems with nm-applet or networkmanager.

Thank You for the feedback.

Best regards,

nice information given about various problem in installing and networking