Ok guys, OpenSuse has hit a dead end. Yesterday I recovered two USBs via testdisk - and instead of running testdisk on the second USB, it scrambled in console on the HDD. My alarm clock rang and I stopped it as fast as I could. System was up, but upon reboot - NO PARTITION. I tested with GParted (shows that my HDD is “not partitioned”) as well as with another LiveCD. Automatic repair through the DVD fails.

Whoa - there´s company work on that system and I haven´t made a backup of it yet… PLEASE, what do you suggest in order to gain access to the system (I still believe it´s on there).


Did you try Parted Magic or Knoppix?

Thanks for replying. Is there a difference between those? I´ve tried GParted and PartitionManager 2008 so far… they all show an unpartitioned drive.

testdisk comes highly recommended. You can not doubt find Live CDs with it on.

If the information is that important, consider professional data recovery. It isn’t as expensive as finding a new job…

Probably the partition table is gone. Should I try to recover it via testdisk live cd?

Testdisk is designed for exactly that. Never used it myself, but I’ve heard many many recommendations.

Just remember, any work you do on it will not be as good as what a pro could do. If your data is really important, you might just be making it worse…

they all show an unpartitioned drive

There are:
Ultimate Boot CD - Overview
Hiren’s BootCD 10.0 -

Yikes? I´ve been recommended PartedMagic too. So yes, I´ll try those suggestions to recover my pertition table.

Dude, you’re moving so quick you didn’t realize it was me that suggested Parted Magic. I’m not sure it will do what you need. The more you try accessing, mounting…whatever… I think it can only exacerbate the problem. But I could be wrong on that. Fortunately I have never had this sort of experience.

Yeah, after I finished my last post, I just knew you´d respond. :wink: PartedMagic has not been just recommended by you, but also on IRC. Let´s see what surprise hides in the box.

While you do not have a backup, at least you have somewhere a backed up listing of fdisk -l, so you know what to restore?

Why do people not have the most basic things about their installation saved somewhere?

Unfortunately I don´t. Are you able to help me find out?

I am afraid not. I do not know if the recommended tools like PartedMagic are able to do intelligent/magical guesss about what the partitions table was. I use fdisk normaly, but it will do no magic.

I will not try to preachto you, because you are already deep into troubles. But to everybody else I would say: do backup some of those information about your system somewhere else. It does not take much space. Saves a lot of trouble.

Used testdisk again. An awesome tool - if used properly. Anyhow, I selected my “non-partitioned” system, clicked non-formatted and testdisk said the structure would be “OK” while highlighting everything green at the same time. Phew… it seems like in order to get back into a working system the only missing file would be the partition table. How to do with testdisk or PartedMagic?

I hope you manage to resolve this. It’s out of the realms of my intellectual capacity anyway - But I’m away for a week from tonight.

Sometimes we post important data like the result of fdisk -l in the forum, but I just tried to find it under your posts and didn’t come up with anything. Ah well.

I’ve just been locking everything down, just in case any remaining members of the family decide to poke around Dad’s computer.

ONLY the partition table? It is the start of everything. Whitout it nobody knows where yoor partitions begin/end. So nobody knows where to find a file system. The disk is now one big bunch of bits.

As I said earlier, only a very intelligent tool (or a person/company specialised in these things) could try to detect a pattern or something that might tell things like: it looks as if an ext3 might start here.

clicked non-formatted
do not use that function on a partitioned hdd even if the partitions are missing from the MBR. Not sure when that function is used but if you read the how-to it says do not use it, for your problem.

‘testdisk’ will normally do a good job , but if the hdd has had the partitions deleted, resized and remade it does have problems finding the correct/current partition structure.

could try to detect a pattern or something that might tell things like: it looks as if an ext3 might start here.
that is what ‘testdisk’ basically must be doing. Along with linux file systems ‘super block’ and MS’s ‘Volume boot record’ has the partition size within it.

Need to add: due to the data is important would make a sector to sector backup to a hdd of the same or larger size. What ever program you use be sure you do not mix up the hdd’s and copy from the backup hdd to the problem hdd or all is lost.

Thanks for your advice guys, but I already told you: I know how to use testdisk - issue in the first place was hitting the wrong key.
Anyhow, I also told you that testdisk actually DOES find out where my partitions start and end. I did the steps mentioned in my previous post and came up with this beautiful message:

Again: What should be the next step from here? :slight_smile:

but I already told you: I know how to use testdisk
then way are you asking whats next ? The proper use of testdisk is all you need to do.