Serial Driver blues


I used to have an outdated ubuntu linux box with a wavecom GPRS serial modem, working fine. Less than 1 month ago I upgraded it to OpenSuse 11.1.

Since then I cannot communicate with my serial port. I can see that the port is found at boot time and listed in /proc/tty/driver/serial:

Linux1:~# cat /proc/tty/driver/serial
serinfo:1.0 driver revision:
0: uart:16550A port:000003F8 irq:4 tx:0 rx:0
1: uart:16550A port:00001228 irq:17 tx:162 rx:0 RTS|CTS|DTR|DSR|CD
2: uart:unknown port:000003E8 irq:4
3: uart:unknown port:000002E8 irq:3

The port in question is /dev/ttyS1. This result is confirmed also with statserial. When I try to use minicom, though, I get no reponse from the modem.

If I move the modem to a windows machine with puTTY I can again communicate with it.

Therefore, modem is OK. The box is also OK since it worked fine before the installation and the RS232 port seems to work fine, since the correct LEDS come up.

Therefore it seems to be a software problem. Either minicom doesn’t work (I doubt it) or there is a problem with openSuse 11.1 and serial drivers.

If you know of any problems either with minicom compatibility or Opensuse issues, and more importantly a solution, please advise me.


Difficult. It appears you have a PCI modem card. Your technique is basically correct. Here are some ideas:

One strangeness I have noticed with minicom is that it appears to recognize a new device only after the configuration has been saved and the program restarted.

You may need to use the setserial command to change device characteristics.


Thanks for the reply and sorry for my delay. I was expecting a mail notification for replies, which never came. I see I hadn’t set the notification option on the thread. Now I did.

I am not using a PCI card. This is the vanilla built-in RS232 port from my PC. I also have tried many times changing and saving settings within minicom. So, I don’t think this is a factor.

At this point I am not interested in changing its configuration, only to communicate with it.

Since then I have also hooked a Zadako USB modem in a USB port. Once I connect it, linux automatically recognizes it and assigns 3 serial ports to it:

/dev/ttyUSB0 - USB2.

This one minicom recognized I also noticed that there is no change in the leds on the RS232 when I disconnect the Wavecom. Could it be that the RS232 somehow got burned between the upgrade?


Hi nbal

Not sure if I understand your problem exactly, but did you try communicating with the serial modem as root? I was just wondering if it was a permissions problem. Group ‘uucp’ is required for serial port access.

Hi deano,

Yes, of course. Cannot even fire up minicom unless you are root.:wink:

My problem in a few words is that while on a outdated Ubuntu, I had no problems communicating with the serial port on my PC. Since i upgraded to OpenSuse 11.1 I can no longer do it. Is it a general issue with Opensuse and the RS232 driver? Or my RS232 port somehow got burnt during the upgrade?