semi-problem with microphone

Hello
I have this kind of problem with microphone.
When I start computer mic does not work. I usually need it for Skype or Linphone.
To solve a problem I tried this: I opened Audacity to check if it sees mic. I start recording and nothing. I close empty file.
I start recording for the second time and this time it works.

So I can force my mic to work, but it is a semi-solution. I’d like to start the system with working mic.

Can anybody help?

Since I cannot change tread title I’d like to mark it as a real problem.
Is there any chance to solve my problem with microphone?

(sorry for answering my own post, I do not want to submit another tread)

Some more information would be useful to understand this.

First: When you 1st boot your PC before running any application, with the PC connected to the internet, please in a terminal / konsole as a regular user send the following command to run a diagnostic script that will upload information to the internet so to share your PC’s audio configuration:


/usr/sbin/alsa-info.sh

select the SHARE/UPLOAD option. Then when the script completes running, copy the web address given and post it here.

also in the terminal run


lsof /dev/snd/*

and post here the output.

Then try your application (skype or audacity) where if I read your post, the mic won’t work.

Second: Then again run the diagnostic script:


/usr/sbin/alsa-info.sh

and post here the output web /address URL.

Also run:


lsof /dev/snd/*

and post here the output content.

then launch audacity (or Skype) and my understanding is the Mic will work this time.

Third: Please again run the diagnostic script, and post here the output web address/url:


/usr/sbin/alsa-info.sh

also run


lsof /dev/snd/*

and post here the output content.

The idea is by comparing these, we may be given some hints as to what is taking place.

To the OP.

Please look at this link
https://forums.opensuse.org/english/get-technical-help-here/multimedia/488016-how-monitor-line-inputs.html#post2566329

The thread link problem is about line-in input but maybe applicable to your microphone issue.

Please follow oldcpu advice also, so he can diagnose your problem.

Thanks.
Here are the answers:

First answer
Your ALSA information is located at http://www.alsa-project.org/db/?f=0edc438400e3a05992b43fe9eba8fcdc50aa0d53

lsof /dev/snd/*
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 5249 boguslaw 20u CHR 116,9 0t0 8197 /dev/snd/controlC0
pulseaudi 5249 boguslaw 26u CHR 116,9 0t0 8197 /dev/snd/controlC0
pulseaudi 5249 boguslaw 32u CHR 116,3 0t0 2039 /dev/snd/controlC1

Second answer
Your ALSA information is located at http://www.alsa-project.org/db/?f=bd368df3d89e4085e61db02d775ce3d4f4682c13

lsof /dev/snd/*
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 5249 boguslaw 20u CHR 116,9 0t0 8197 /dev/snd/controlC0
pulseaudi 5249 boguslaw 26u CHR 116,9 0t0 8197 /dev/snd/controlC0
pulseaudi 5249 boguslaw 32u CHR 116,3 0t0 2039 /dev/snd/controlC1
audacity 5618 boguslaw 13u CHR 116,9 0t0 8197 /dev/snd/controlC0

**
Third answer**
Your ALSA information is located at http://www.alsa-project.org/db/?f=66bd310b15cef501a9f597811952024dd46b5631

lsof /dev/snd/*
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 5249 boguslaw 20u CHR 116,9 0t0 8197 /dev/snd/controlC0
pulseaudi 5249 boguslaw 26u CHR 116,9 0t0 8197 /dev/snd/controlC0
pulseaudi 5249 boguslaw 32u CHR 116,3 0t0 2039 /dev/snd/controlC1
audacity 5971 boguslaw 13u CHR 116,9 0t0 8197 /dev/snd/controlC0

And now microphone stopped working completely :slight_smile:
ups…

Correction:
it appears that this procedure turned the mic input down, so after ‘my’ trick mic can work after pulling volume up (but still at the second run in audacity).
I submit outputs with working mic

our ALSA information is located at http://www.alsa-project.org/db/?f=1efeb1d1a2d91dd36ea27613927a8ab3c8ad52b2

COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 6089 boguslaw 20u CHR 116,7 0t0 6736 /dev/snd/controlC0
pulseaudi 6089 boguslaw 26u CHR 116,7 0t0 6736 /dev/snd/controlC0
pulseaudi 6089 boguslaw 32u CHR 116,9 0t0 6738 /dev/snd/controlC1
audacity 7080 boguslaw 13u CHR 116,7 0t0 6736 /dev/snd/controlC0

Conram - your suggestion did not help

To save me wasting a lot of time comparing outputs, I need you to tell me what mic you are using ?

According to those scripts you have a USB mic (possibly associated with webcam), a rear mic, and a front mic. So please advise as to which one?

Thanks.

I’m using simple headphones with mic on the cable with 2 mini jakcs which I plug-in into motherboard audio input/output.
And I use this one.

Also, there is a usb webcam. And there is a mic in it, but I disabled it in the volume control. So I’m not using it.

Thanks. … It looks to me like this is a basic mixer misconfiguration. I note this from the 4 instances of the script runing:

FIRST !Script ran on: Thu Jul 18 06:49:23 UTC 2013
[Summary : Front Mic OFF (0%), Capture0 OFF (0%), Capture1 ON (90%), Digital (50%), [b]Input Source (Front Mic), Rear Mic OFF (0%)

SECOND !Script ran on: Thu Jul 18 06:50:59 UTC 2013
[Summary : Front Mic OFF (0%), Capture0 OFF (0%), Capture1 ON (90%), Digital (50%), [b]Input Source (Rear Mic), Rear Mic OFF (0%)

THIRD !Script ran on: Thu Jul 18 06:56:15 UTC 2013
[Summary : Front Mic OFF (0%), [b]Capture0 OFF (0%), Capture1 ON (90%), Digital (50%), Input Source (Rear Mic), Rear Mic OFF (0%)

FOURTH !Script ran on: Thu Jul 18 09:55:59 UTC 2013
[Summary : Front Mic OFF (0%), [b]Capture0 ON (70%), Capture1 ON (90%), Digital (50%), Input Source (Rear Mic), Rear Mic OFF (0%)

Note that when you boot your PC, the Front Mic (not the rear mic) is selected. In addition, Capture 0 is OFF (0% capture).

Between the 1st and second time you ran the script, the mic selection was changed from the front to the rear mic. Then no change until between the 3rd and 4th time you ran the script, when you unmuted Capture0 from OFF to ON, and changed its capture levels from 0% to 70%.

Possibly your mixer settings are not be saved when you shut down ? Rather than have the application audacity change the settings (where in this case they are not likely saved) when not change them with your mixer so that they are saved ? (at least they should be saved theoretically if you do that).

Thank you.
But then what messes up my configuration if it is the case?
I just checked my mixer settings before and after the ‘trick’ in audacity. It is the same.
When mic (rear) does not work my settings in mixer are OK.
When I do the trick in audacity (two recordings) it is still the same, the same settings, i can see no changes.

So for me the mixer seems OK, at least gui. But as you say, real settings say something different.

My guess is the new settings are lost upon a reboot, and the bad settings saved.

Next time you switch ON your PC, IMMEDIATELY after it starts, try to send the folling three commands:


amixer -c 0 -- set 'Input Source',0 'Rear Mic'

then


amixer -c 0 -- sset 'Capture',0 70% cap

then in an attempt to store the above commands:


su -c 'alsactl store 0'

and enter root password when prompted.

Try then audacity. Does it work ?

Then try a reboot and do not send the above commands. Does it work now ?

Note absolute pecision is needed in the above commands, as the slightest syntax error and they won’t work. Note GNU/Linux is case sensitive so where it is upper case, use upper case. Note where the ‘spaces’ are located. Its all important. … and its possible I made a syntax error also …

I have already tried your solution 3 times.
First time - did not help. Yesterday - it worked. And just now - did not work (but just after your solution I changed desktop wallpaper and then run Audacity).
I’ll try it few more times and will report.

If it does not work, you should run the diagnostic script , and check to see if the settings were properly applied.

Don’t forget to also configure pulse audio with pavucontrol. One can have the mixer properly configured, but if pulse audio is also not properly configured than that mixer configuration effort is wasted. I blogged sometime back about configuring with pavucontrol : https://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/