Semi-hang or partial freeze. KDE

Hi guys, I have recently been having a very annoying glitch. After a random period of time KDE partially locks or hangs, mainly responses to mouse. It is not easy to fully document but:
Window in focus, I can scroll with wheel, enter text. I can spin through virtual desktops with the keyboard. I can Alt-f2 and launch krunner and applications. But I can’t click the panel to change the application in focus. Sometimes the mouse self-selects a load of text or items from the screen, which cannot be unselected with mouse or escape key.

Nothing is reported to dmesg or anywhere else that I can think of to look.

…! Happily enough it has happened now whilst writing this. !..


So I can click to insert an annoying smiley

I cant use the panel to launch apps or switch to those already running.
I can’t click or hover over ‘task bar’ items like klipper, volume, notifications, clock etc
I can left-click drag the scrollbar.
ATM I can select text and right-click to get a context menu.

I have switched off desktop effects.

I have not yet done an extended test with a new or alternate user.

If I alt-ctrl-Fx to bring up a console, and then alt-ctrl-F7 to bring back the X window, the problem clears itself, even without logging in to ttyx

Are there any log-files which might be illuminating?

Any suggestions gratefully received.

Hmm 66 views and no replies. Another one of those ‘just me’ issues?

Test a new user and see if the problem develops

Thanks Caf. I just tried briefly with a tester account and the freeze-up happened within 10 mins. I will fire up a LXDE session later, and see if it breaks there too.

Your sig says you are using nvidia driver - Is that correct.
And your hardware sounds similar to my old rig, except I had a 8500GT card

I experienced the strange behavior described here on my HP DV7 Laptop as well.

I first experienced it after an update on Saturday (Sept 19).
As described, Alt-F1, then Alt-F7 clears it for a random period of time (minutes, sometimes hours).

I have been travelling with it, no time to debug yet

Yes, 304.108 (patched, installed ‘hard’ way, kernel 3.11.1xxxxxxx from kernel-stable repo. The problem was occuring before the kernel/video driver change)

Just to remove another possibility ( My mouse is old and was filled with gunk and crud, I ‘serviced’ it last week) I swapped the mouse for a newish good-quality one from another PC. Hang/freeze still occurred.

I don’t know about you - but all my machines run a main install and I then have another version of Linux beside it,which I keep as a test/backup OS
In case of the Laptop I am working from now. It’s main OS is openSUSE 12.3 with Mint 14 beside
My main Box is 12.3 with Ubuntu 12.04

With HD real estate being so plentiful these days. It’s perhaps worth considering?
It can help you troubleshoot

A good idea, as usual Caf. I have been thinking about installing mint or the newish mini-Ubuntu LXLE, for a trial, with a view to ‘converting’ my parents, whose PC (like them) is very old and decrepit, and barely runs XP, let alone the “shall I buy this Windows 8” that my father keeps asking me.

I will clear out a space and put the LXLE on to the HDD. And hope that GRUB2 can find it OK!

But I am still getting these annoying hangs. So a little ‘bump’ Any suggestions from anyone?

Mmmmm, does the problem occur when running from a Live USB? If so, I’d consider running memtest, and leave it running for 24 hours. It should report absolutely no errors.
What got me thinking about this, is that the issue occurs after some time, i.e. after linux has started caching data into RAM.

I’m wondering about this
Because my Box, that the wife uses most has had freeze up’s recently, but it seems to be firefox related.

I have had this sort of thing in the past but no instances since I change my entire machine. Last one was a Core2 duo. 2.6gh from memory. Some random causes.

Wireless mouse not communicating correctly due to positioning of the dongle or interference off some thing else. Appeared to be from the screen at one point. Also when the battery in it is near flat.

Many browser tabs and worse still even several browser windows as well along with maybe a few tabs in those. More memory seems to help with this up to a point. Went from 4g to 8gb. Seemed to be worse with Firefox than Opera but wouldn’t want to swear to that but it looked that way. I often used both at the same time. Yahoo used to say what the !!!### is opera. Not the current rewrite opera but the last full release. The rewrite has a long way to go at the moment.

All sorts of strange things - disks near end of life. Disks specify a bit error rate. Gets worse as they age. This is what caused me to replace just about everything apart from mouse and keyboard. Results many strange things from time to time - odd kde menu’s and things coming and going, often the volume control and things like that. Potentially this could cause all sorts of problems.

Last but not least, more like a pregnant pause - desktop indexing. I haven’t ran it for some time. Should get out of the way if any other disk access but takes a noticeable time and things hang. Pass on what would happen if swap etc was also involved in that.

On the Core 2 I had desktop effects switch themselves off if I was very busy even with 8gb. Nvidia silent card as I always use. Also Opera from time to time wanting to switch to turbo mode as it appeared to be on a slow network - doubt if this had anything to do with my connection to the internet.

Perhaps not all directly connected with the OP’s problems but might help.


Thanks guys, sorry for not responding earlier, for some reason I did not get the subscribed thread alerts. I will certainly try an overnight memtest. As for indexing… sigh. nepomuck has been giving me some grief again lately…, I have been asking on KDE forums for assistance, without much joy:

I shall switch off as much of nepo/akonadi and friends as possible.
I am currently trying with LXDE, still have lots of problems on top of the periodic hangs. Dragging windows around fails in various annoying ways. Scrolling using scrollbars is unpredictable at best. I am going to try a LiveCD of 13.1 which I hope will eliminate hardware from the list of suspects… Has no-one any suggestions regarding whether these problems could be logged anywhere?

I have been having a pointed bleat about indexing in general on the KDE mailing list as it seems to me that things have gone in the wrong direction somehow. I suspect it’s down to miss use of OOP.

Anyway I have kdepim3 sitting there doing it;s thing without any signs of any interference with anything. I have the indexing turned off but before replying to the dev mentor that responded to my bleat I did a bit more research. Bleats need to be correct and there is some confusion about one aspect, One page makes an interesting read, it’s linked to from the kde user base

Kontact-Nepomuk Integration: Why data from akonadi is indexed in nepomuk | Finding New Ways…

Seems it’s more difficult to turn off than some may think and doing it may have some surprising consequences.

OT but of interest I tend to stick to complaining about Kmail due comments from larger scale users. They miss it, say there is nothing else like it but it wont handle their mail volumes any more. The dev person just mentions what wonderful techniques are used - me well I point out that this is irrelevant and what matters is the user experience. This has worked in the past but I suspect things have gone too far now.


On Thu, 26 Sep 2013 07:16:03 +0000, wakou wrote:

> for some reason I did not get the subscribed thread alerts.

It’s been broken for a couple weeks. We’re aware of it, and waiting on
our tech team to resolve the issue.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

I am still getting this horrible problem… I ran memtest overnight, (6 hours, 4 passes of the full suite, default settings, no errors). I have detached any unused USB devices and HDD’s. More curious behaviour, and this with a new mouse. I sometimes cannot left-click-drag text. Also, occasionally, firefox spontaneously goes ‘back’ ie without touching the mouse or keyboard, the page you are looking at flicks back, as if the back button had been pressed.

When this problem started I used chromium as my main browser, I switched to FF in an attempt to identify the cause.

@ Knurpht

The hang seems to happen at any time, even directly after boot.

If you want to check with a boot CD or preferably a DVD to check if the same thing still happens as sacrilegious as this may be I would use Knoppix

You can download it here

Knoppix Linux Boot CD, Download Disk and Documents, Discuss, Get Help

Best make a note of “cheatcodes” that are needed from here

Cheat Codes - Knoppix Documentation Wiki

The main thing being selecting the correct type of keyboard but the boot debug might be useful, no acpi etc too.

For a light weight desktop icewm might be worth a look. It’s included.

I suggested the dvd as there are lots of utilities on it some of which may help check your set up. It’s many years since I had to use it last. I don’t think it has ever failed to configure correctly for the machine it;'s running on either. Old or new. :PNot saying OpenSuse would but using a totally different distro isn’t a bad idea anyway.

One other aspect maybe to check you drives is a SMART utility. Details here including using it for tests.

Using smartctl to get SMART status information on your hard drives - TechRepublic

I thought it was possible to get at internal read write error counts with this but a quick look doesn’t show any way of doing this.