selinux setup error

i tried to enable selinux on my OpenSUSE 12.3, i did everything like described in SDB:SELinux - openSUSE except that when i run the selinux-ready command i get the following error:
check_filesystem: ERR. Filesystem ‘selinuxfs’ is missing. Please enable SELinux while compiling the kernel.

in the guide the output is :check_filesystem: OK. Filesystem ‘selinuxfs’ exists.

so i think everything is alright with the kernel (i’m using the default one shipped with suse), but i need to maybe mount the filesystem to /selinux or proc/filesystems ?
any help appreciated

AppArmor - Gentoo Wiki says that fstab entry might be required
Also found this pdf explaining the setting up of SElinux

i tried the fstab entry and it won’t help, because selinuxfs is an “unknown file system”
has anyone tried booting with the selinux kernel parameters or changing CONFIG_SECURITY_SELINUX_BOOTPARAM_VALUE=0 to 1 ???
that’s the only solutions i can think after some reading.
or maybe there is another way to enable a filesystem type? as /sys/fs/selinux directory is missing in 12.3