Selective internet with opensuse 11.2

after upgrading from opensuse 11.1 to 11.2 the following strange thing happened.
I have internet only in the network in which I was when I upgraded. In all other networks no internet neither wired nor wireless. However, NetworkManager always show me that I was connected to the network but when I am trying to open firefox or even software repositories, I can not reach them. Yesterday, I found that somehow skype is working in the network in which I can not get to the internet but that is all what I have. Actually, I ve already discussed the problem in Wireless only works on certain networks but no progress was achieved since then. Any help would be very appreciated

Could it be that you can reach the internet, but that your DNS resolving is not working?

You do not tell how you definitely checked that you have no connection. Opening a browser like FF is not a definite test, it just shows symptoms.

Thank you for your reply. Honestly speaking I am not sure how to check resolving DNS. As I said, the paradox was that network manager always tell me that I have a connection with a network and this network is really connected if I use a different OS. And the problem is that when I open browser I can not see any web-pages and when I tried yast->software repositories I get an error from which I concluded I do not have a real connection. I just dont konw how to manage with this problem, that is why I am here. bwt, I tried to ping through its ip. It is not pinged.

Well, from your description I deduct that you have connection to the network (as network manager says and that is what it is responsible for), but not beyond your network to the internet.

The fact that you can not ping to by IP address indeed is better prove of the fact that you can not reach the internet.

Can you post here the output of

netstat -rn

so we can see if you have a route to the outside world?

You can try checking the file /etc/resolv.conf to find out if you get the proper servers from DHCP. You can do this by issuing this command from terminal

cat /etc/resolv.conf

For me the file looks like this :

### /etc/resolv.conf file autogenerated by netconfig!
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
# or disable DNS configuration updates via netconfig by setting:
# See also the netconfig(8) manual page and other documentation.
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
### Please remove (at least) this line when you modify the file!

It will most likely have different nameservers ip addreses in your case. Anyhow it should contain at least one nameserver address in order for DNS to work. Once you confirm that you can issue the command :


You’ll get an interactive prompt. There you can enter for example and see if the name is resolved to an IP address i.e.

grzes@opensuse:~/.mplayer> nslookup 

Non-authoritative answer:

It means that my primary DNS server ( resolved the name and it’s address is (

here is the output of netstat -rn

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface U 0 0 0 eth1 U 0 0 0 lo UG 0 0 0 eth1

Ok so is your default gateway.

1.Can You ping this address ?
2.Can You ping some external ip address like or ?

If the answer to both questions is true it is most likely a problem with DNS. Did You check if it works already ?

I am fully with glistwan here. is your default gateway and thus the address of your router/modem. Ping it to see if you can reach it, etc.

But pease put all your computer input/output between CODE tags like glistwan and I did… This to keep it readable and understandable.

I can ping I also can ping

What happens, if you enter the proper gateway address, and use and as the DNS servers (they’re google’s DNS servers)

the first command(cat /etc/resolv.conf) gave me


the second one (nslookup) and the just timed out. Apparently, the problem is related to DNS but I do not know how to resolve it

You can manually edit the /etc/resolv.conf file with your favourite text editor. Put there a line as previously suggested :


This should work. For a permanent solution You have to change your router setting in order to supply you with the proper DNS server. I think you can also edit the NetworkManager profile used to connect to this network and set up your DNS manually there.

I will try, however what I do not quite understand is why everything is ok with DNS in the one network and wouldnt the changing of DNS do any harm in one working network? In other words, I do not understand what the universal solution of this problem is?

The most widely adobpet solution (as far as I can tell) is geting the DNS ip address through DHCP. Typically you ISP provides the DNS server. You may want to ask them why You don’t get the proper address of DNS server or You might check your router configuration. Botomline You could always set up your own DNS server but i guess that’s not what You want to do. nameserver works in most networks as google doesn’t restrict it. With NetworkManager You can create many profiles and use a profile with manual DNS configuration at home and other profile somwere else.

Best regards,

ok, I tried. It started working. What I did was I just added the line


to the file /etc/resolv.conf.
However, with this google DNS the google search does not work though I can surf the internet. and it seems internet became slower. I guess, I need to use DNS from my ISP which, for some unknown for me reason, was not provided automatically?

This is something to ask your ISP about or figure out by checking your router configuration.

Best regards,

Thank you very much for the helpful replies

No problem. Clad we could help.

Best regards,