Selection of Cinnamon desktop with new installation

I downloaded the Tumbleweed DVD iso from:

and assumed that I’d be able to select the Cinnamon desktop during installation, after reading the instructions under ‘One-click install’ at:

Not so, I guess. The install menu would have let me select Gnome, KDE, XFCE, etc., but not Cinnamon.

I’m new at openSUSE, and am not sure how to proceed. Is there an option to install Tumbleweed without a desktop, and then add Cinnamon afterward with zypper? My preference would be to download an ISO that already includes Cinnamon, if one is available.

Thanks for reading.

As you’ve discovered, Cinnamon is not listed as a Desktop option.

You can try installing as an original Desktop(I haven’t tried this on TW, I’ve only tried on 42.3 and it fails at least today).

When you’re installing, select “Other” or “Custom” (Depending on the Installer) which should display some variant of YaST Software Manager. On 42.3, the default is the Patterns view, it may be something else in Tumbleweed but in either case there should be a “search” somewhere…
Click on “Search” and search for “cinnamon”
Install only the cinnamon package, supposedly all necessary dependencies should also be selected and installed automatically.
Accept and save, continuing the installation.

If the installation fails, I’d recommend re-installing with the XFCE Desktop, then install the Cinnamon Desktop either using YaST Software Manager similar to what I described above or use the one-click install button on the SDB Cinnamon page.

Good Luck,

Took a look at this.
Cinnamon is currently non-functional just like installing on 42.3.

When installing Cinnamon as the original Desktop,

When you arrive at the screen for selecting your Desktop, click the “Configure Online Repositories” button and complete.
When you arrive back at the Desktop selection screen,
Select “Custom”
On the next screen click on the “Details” link
When the Software Manager page displays, click on the “Search” tab
Enter “Cinnamon” into the search field and hit “Enter”
Select only the “cinnamon” package
Click “Accept”
Click “Confirm”
Continue your installation.


Thanks for your response, tsu2!

I decided to experiment by following your suggested steps while creating a new virtual machine in VirtualBox. All went well: I selected only the cinnamon package, and saw that this automatically included the muffin and nemo packages listed under ‘Basic information about Cinnamon packages’ at: .

Installation completed without errors. I rebooted, but Cinnamon didn’t come up. Instead I got a terminal prompt, and couldn’t find a way to start the Cinnamon desktop from the command line.

cinnamon --replace

I’m afraid not!

cinnamon --replace

Unable to init server: Could not connect: Connection refused
Window manager error: Unable to open X display

It’s not fair to ask for additional support help when I’m eyeing the exits, so I’ll add a second message as a follow-up:

I see from googling Unable to init server: Could not connect: Connection refused that I could take other troubleshooting steps. I created an .xinitrc file, as one page suggested, but got nowhere with it, and think it wise to quit while I’m ahead.

I don’t know Linux well enough to comfortably use a distro like Arch, and configuring an .xinitrc file puts me in Arch territory in terms of user effort. I like the idea of a stable, tested rolling release, and had believed that I could use openSUSE Tumbleweed with Cinnamon “out of the box.” I now gather that this isn’t the case, and think I should either resign myself to Tumbleweed with KDE, or to use of another distro.

Sincere thanks to tsu2 and xorbe for taking the time to try to help a stranger.

You need a display manager such as lightdm that lets you select the cinnamon desktop session upon boot.

So, install lightdm and change /etc/sysconfig/displaymanager DISPLAYMANAGER=“xdm” to DISPLAYMANAGER="lightdm"

Then upon boot ( or if you issue systemctl restart display-manager.service ) you will be greeted with a nice login screen and a session button that allows you to select Cinnamon (it’s the little wrench icon in the top right corner)

The end result should look like this;

If you want a prettier login manager, use sddm

Specifying lightdm as the Display Manager works,
A machine I set up a week ago which didn’t work even with lightdm works now.

This looks like a good solution when adding Cinnamon to a system with a different Desktop, but is still problematic when Cinnamon is the original Desktop (I guess can try installing lightdm manually during install but otherwise no way to configure lightdm until first boot and login).


A FYI for anyone installing Cinnamon at this point…

Even after solving the Display Manager issue (or not),
Looks like there is a Desktop Background issue… a grey silverish layer is laid on top.
So, even if you select the only default available background image (42.1 image), it remains underneath.
I also manually added a couple of Cinnamon themes in /user/share/themes/Mint* but those just add background images under the silverish background.

I resolved what appears to be the same a few months ago when LXQt was experiencing this by manually setting the Desktop’s default path to the image folder location, but I don’t see something similar here in Cinnamon (It might be in a text configuration file somewhere).


Success! I wound up combining the suggestions of tsu2 and Miuku, with a wrinkle of my own:

First, from tsu2:

When you arrive at the screen for selecting your Desktop, click the “Configure Online Repositories” button and complete. When you arrive back at the Desktop selection screen, Select “Custom,” On the next screen click on the “Details” link. When the Software Manager page displays, click on the “Search” tab. Enter “Cinnamon” into the search field and hit “Enter.” Select only the “cinnamon” package. Click “Accept.” Click “Confirm.” Continue your installation.

I believe this step delivered me to the ‘enter user name and password’ screen. I clicked the ‘back’ button, and returned to the screen that allowed me to select the X-Windows environment. I then clicked ‘search’ again, and – remembering Miuku’s advice – selected LightDM.

The install program then did its thing, adding Cinnamon, X-Windows and LightDM to my configuration. On first boot after install, there was the LightDM menu letting me select Cinnamon, as Miuku had promised. Cinnamon looks great; I do not have the silver background problem described by tsu2.

Thanks again very much for the help!

I write again with good news and bad news … mostly, bad. :frowning:

The good: Users installing lightdm can also opt for the lightdm-slick-greeter, which makes for a much nicer log-in screen (that I’d be happy to show you, if I could figure out a way of uploading a .jpg to this forum). Configuration requires creation of a file: /etc/lightdm/lightdm.conf . Mine reads:


The bad: The Cinnamon desktop has hung repeatedly. I can move the mouse, can’t do anything else, knew of no alternative but the Magic SysRq key. This happened after opening a terminal to run zypper up, and left me with a nice mess.

My openSUSE newbie impressions: Tumbleweed may be absolutely top notch with KDE, Gnome or one of the other desktops available on the install iso. I haven’t found it ready for prime time with Cinnamon.

Before you completely dismiss TW though, you might want to try KDE with it - it’s pretty snappy and works well.

Especially now that kernel 4.12.8 has landed.

Hi Tuner!

Just a side note, if you decide to stay with us: “zypper up” is NOT the recommended way to update Tumbleweed. You should instead use

zypper dup --no-allow-vendor-change

or simply “zypper dup”, since the --no-allow-vendor-change should be the default now.

Just my 2 c.


Thanks for the feedback, Miuku and Cris70. I may take another stab at configuration with the KDE desktop. I haven’t decided.

Cris70, my understanding (or misunderstanding) of this thread:

and of this Richard Brown post:

convinced me to use zypper up instead of zypper dup. But I now see additional responses have been added, including Fraser_Bell’s recommendation to use only dup.

Agreed with the “up” and “dup” posts.
For a few months (almost a year?) it looked like the two did the same thing, but for several months now they appear to do different things on my TW systems.


I did not understand if you could use Cinnamon or not ?

Hi, V-idocq

I did get it to work using the steps above, and it looks terrific, but I was unhappy to see Cinnamon freeze as described in post #13, above. It has behaved since, but I feel reluctant to trust it.

I say this because I installed it for curiosity and works well with all its effects
I’m writing from it, started an hour ago