Selecting video card drivers and screen resolution on 11.4 KDE

The installer has left me with 1,024 by 768 pixels and a driver that will not reach anything like the res my card and monitor will cope with. The display is currently blanking every 30secs or so for a very brief interval as well.

I may have missed something on the install but there didn’t seem to be any opertunity to choose either a driver or monitor type. I was eating my dinner through most of it.

I had a brief flirtation with Mandriva and know that linux should be able to nearly fully support my monitor which is 1680x1050 by Belinea. Earlier open suse install gave the option of seting this sort of thing up and listed all of Berlinea’s monitors as well.

The card is an nvidia 210 by Asus. Reported as a 200. I do not want to try installing an nvidia driver yet as I understand that there will be problems. Also I have a YAST ipv6 dns problem = no updates.

Any painless ideas, even installing again? Please be gentle with me I am not fond of the consol.

John

Have you read these:

openSUSE Graphic Card Practical Theory Guide for Users
SDB:Configuring graphics cards

It’s worse now. I have managed a temporary fix for the ipv6 problem and have updated including an nvidia driver. This now gives me a max resolution of 640x480 as installed. Just how can yast etc pick a res like that? The card is a 210 silent and it does recognise that it’s a 200 series and that it’s more recent than many other nvidia driver options.

I have had a quick look but strongly suspect it wont help much but I can try some of the suggestions.

On the initial problem before the update a generic vesa driver will offer far better resolutions especially if it gets the info from the card itself. No doubt that is included in the distro.

John

As I suspected the links are of no use what so ever. May be of use if graphics do not work at all.

What I have is the correct drivers for my nvidia card installed by yast. They even seem to be loaded correctly but on every boot screen suse shows a low res vga mode in the boot options. For some reason and with no explanation I can now boot either of 2 11.4 installations. Both behave in the same way. Deleting the video boot mode makes no difference on either,

I have managed to generate a fresh x11 conf file for the card. Nvidia offer a lot better help on that aspect. Doesn’t make any difference so Suse must also have tucked something away some where while installing the nvidia driver that is causing the problem. Talk about making things worse.

Looking though X’s files it also seems that X needs monitor information to do it’s job properly. It also notes that some aspects of the set up yast has established are larger than the display size.

Frankly if a distro involves this degree of problems people who can easily cope with these sort of issues would probably be better off going down the Archlinux route. There you are likely to be dealing with near vanilla code from top to bottom. Suse used to offer a relatively safe easy route to linux and a desktop. That doesn’t seem to be the case these days and it looks to me like there are better and easier options elsewhere especially for people who do not really want to get involved with the console. This is from some one that has used linux for rather a long time and has spent most of his working life at the sharp end of software of one sort or another.

John

Hi John. It would be useful if you could share the Xorg.0.log contents with us. Upload it to SUSE Paste (or equivalent) and post the link to it here. Then someone may be able to provide further assistance with your problem.

For most of us hardware detection just works, but some monitors do not play nicely with respect to EDID. Fortunately, the nvidia driver comes with nvidia-xconfig and nvidia-settings utilities that can assist with configuring xorg.conf to produce a suitable display resolution. (There are many threads on this already if you’re prepared to spend a little time searching and reading).

If you’re familiar with editing /etc/X11/xorg.conf files by hand, you could use nvidia-xconfig to generate a working xorg.conf, then add a manual modeline (use the cvt utility to generate one suitable for your monitor).

Here is a good reference for xorg.conf options available for the nvidia driver:

Appendix B. X Config Options

The following options can be used to disable EDID if required:

  Option "UseEDIDFreqs" "FALSE"
    Option "UseEDIDDpi" "FALSE"
    Option "ModeValidation" "NoEdidModes"

Hi I did use nvidia-xconfig to generate the xorg.conf file. I also used it’s modeslist feature to add modes which are suitable for the card and my monitor.

I’ve found the nvidia man files very useful. I have used it’s suggested shell command to check what is actually loaded at run time and that is correct. The only issue is the resolution. It’s just offers 640x480 and 320x240 in the nvidia desktop facility. I assume this is down to the automatic boot parameters added by YAST as these are the max resolution that I can obtain. The only error (warning) in the x log file is the one that I have already mentioned - it’s using it’s default display size and that it isn’t big enough. I would guess that the initial kde bar was twice the width of the screen so maybe the default is an old 80 column vdu.

I’ve played with cvt. Here I have some confusion. X appears to need screen size and resolution to calculate dpi in real terms. Going back to 9.x this was actually asked for during installation / could be added later - long time ago so not sure. Also the installation offered to upgrade to nvidia drivers immediately. Not that the long term ipv6 problems would allow that after they were introduced in 9.something this time. 10.1 my last upgrade before this one fully utilized my nvidia 7600 card. The 11.4 upgrade did too for a while and then dropped back. Later it dropped even further and the screen flashed every 30 secs. Fresh install, new card - the 210 and I get the same low res and flashing. Install the nvidia driver and lowest res to date - two kernel boot options etc etc but no screen flashes any more.

I note the link and it’s content but I think the best way forwards is a system wide file search for the graphics mode boot parameter YAST has stuffed in as this clearly over rides everything else. 2nd standard utilities will report all modes a card can support. Seems I will have to enter them by hand. 3rd I should have a floppy for my monitor but haven’t any more. Maybe belinea will still have it as it’s still on sale. This might help with X’s other problems but means a completely fresh install rather than one that for some reason seems to take note of the previous one even when I tell it not too - how else did the 1st install keep my earlier screen resolution etc. Worse still why did it loose it. All I did was reboot a few times trying to get yast to use ipv4. Seems the earlier os nvidia driver was more capable than the current one. I can think of no other explanation.

All a bit sad really as from my perspective suse took a dive with the release of 11.0 as far as kde was concerned. Looks to me like they still haven’t surfaced and have gone even deeper.

John

It looks like the problem is down to the default monitor size. The boot parameters is actually setting 800x600 16bit colour.

What I really need now is info on setting up display parameters to do the job properly.

John

You didn’t post /var/log/Xorg.0.log output as requested.

The only issue is the resolution. It’s just offers 640x480 and 320x240 in the nvidia desktop facility. I assume this is down to the automatic boot parameters added by YAST as these are the max resolution that I can obtain.

I note the link and it’s content but I think the best way forwards is a system wide file search for the graphics mode boot parameter YAST has stuffed in as this clearly over rides everything else.

YaST has nothing to do with it. Configuration is done by the X-server and the driver (with EDID from the monitor) - usually automatically, but /etc/X11/xorg.conf can still be used when automatic detection fails for some reason.

2nd standard utilities will report all modes a card can support.

The command you’re referring to is ‘xrandr’. However, this does not always reliably report all the display modes when using a proprietary driver. I think you should read the guides that consused provided links to, so that you gain some useful knowledge about this. (You seem to be a bit confused about how it all works).

What I really need now is info on setting up display parameters to do the job properly.

It is still possible to create/etc/X11/xorg.conf via nvidia-xconfig and edit by hand if necessary. One can add manual modelines if required. I was leading up to that, but you haven’t supplied the first requested Xorg.0.log output (via suse.paste or similar due to its length).

BTW, what type of video cable/connectors are you using? (VGA, DVI…)

rotfl! What I now have is 640x480 display which is one of the modes I have added and x starts up ok but the kde login is in the top left of the display and most of it is off the screen. I can log in though but only the bottom right hand of the kde desktop is visible in the top left hand corner. I would say roughly 1/4 area wise. I assume that the higher res modes are now available in the nvidia config utility but can’t get at them to check and I assume it wont alter the position of kde’s screen.

Any ideas?

Curiously X wouldn’t let me put a list of modes in one line in the monitor section or for some reason it doesn’t like 800x600 which was the 2nd mode in the list.

John

Without the /var/log/Xorg.0.log file being posted in SUSE Paste and that URL shared, its likely not possible to help to get this working.

I note my wife’s PC has a nVidia G210 and it ‘just works’ at the maximum resolution of her monitor (1280x1024) so my guess is this is NOT the graphic card, but it could be a problem with X identifying the monitor. But thats a guess. Why is it a guess ? It is a guess because the only way to tell that is to look at the /var/log/Xorg.0.log file. If the user refuses to share the content of that file then there is not much help that can be given.

Here’s what I would try based on your declared monitor resolution (1680x1050). If you use the cvt utility to generate a modeline (60Hz refresh assumed):

 cvt 1680 1050 60
# 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

Note: I took a guess at your display size (based on resolution and 96 DPI assumed). You could measure this, or read the specs for your monitor, then input the correct dimensions.

Then create (or edit) /etc/X11/xorg.conf with these entries:

 
Section "Monitor"
    Identifier     "Configured Monitor"
    #Your custom modeline. It must be valid for graphics card and monitor
    Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

HorizSync   60-75
    VertRefresh 60
    # Your monitor's physical screen size in mm (if required)
    DisplaySize 444 278
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nvidia"
    Option "UseEDIDFreqs" "FALSE"
    Option "UseEDIDDpi" "FALSE"
    Option "ModeValidation" "NoEdidModes"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    DefaultDepth    24
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
        # Declare your modeline reference here
        Modes      "1680x1050_60.00"         
    EndSubSection
EndSection

Now, if it doesn’t work, the general approach is to examine the Xorg log files for errors to identify what it is not happy with (eg invalid modelines, or options that the nvidia driver might not support…). Then go back and edit xorg.conf as necessary. It will be trial and error, and the users level of experience may determine the outcome. :slight_smile:

I’m not refusing. I have mentioned the only sign of an error in it. I will post it but afraid I can’t at the moment - see my last post. Currently the machine isn’t usable. It seems I may have inadvertently entered the cards modes in the wrong order. One good aspect though is that as I suspected adding some monitor information has cause X to select one of the modes. Basically I have made these changes because the x log file mentions using defaults - also mentioned in earlier posts in this thread.

From the screens position on the monitor I hope that adding the monitors dot clock rate will enable x to correct that.

On the other moderators post ok I’m not a happy bunny as I expect to get a new installation up and running virtually immediately. That didn’t happen in this instance in several respects one of which is monitor resolution. It changed itself to one I wasn’t at all happy with. I switched to a newer video card based on comments made on here about kde’s desktop effects. I used yast to install the nvideo driver - the results of that are what started this post.

John

Thanks Deano_. I have been trying to find a more comprehensive conf file for x. I more or less (often) understand what I have read.

One point though I want to set several possible modes. No problem with screen as modes will accept several on the same line. Seems largest must be first. No such luck in monitor. I entered 640x480 800x600 etc and x bailed out on boot complaining about the 800x600. I’m not sure if this down to the order or if I need a different type of mode section here? As the max refresh rate of my monitot is 60hz at full res and 75hz at the rest I also limited the max vertical rate to 60 for all modes. That will be satisfactory. Min refresh rate is 56hz

I did play with cvt following nvidia’s primer on using the driver but gained the impression that x only needs straight resolution information. From the same source I also gathered that the card will comply with any required resolution but it’s declared vesa resolutions from interrogating the card directly do not include the max res of my monitor. This might be down to the fact that vesa may not recognise 16:10 monitors.

Sorry if I sounded a bit blunt earlier. I often do. Sometimes it does get things moving in the right direction.

John

:wink: I’m now hoping I can edit the files with knopix keeping the access rights the same.

I did play with cvt following nvidia’s primer on using the driver but gained the impression that x only needs straight resolution information.

The modeline timing parameters contain all the info needed to set resolution AND refresh rates.

One point though I want to set several possible modes. No problem with screen as modes will accept several on the same line. Seems largest must be first. No such luck in monitor. I entered 640x480 800x600 etc and x bailed out on boot complaining about the 800x600. I’m not sure if this down to the order or if I need a different type of mode section here? As the max refresh rate of my monitot is 60hz at full res and 75hz at the rest I also limited the max vertical rate to 60 for all modes. That will be satisfactory. Min refresh rate is 56hz

Post your xorg.conf contents if you would like us to look it over…

It turned out that my initial suspicion was correct. X needs more info than than the install gives it. Basically taking nvidia driver install for a 210 silent as an example and knowing the parameters of the monitor

Use YAST to install the driver and follow the nvidia’s instructions for installing the driver.

Edit /etc/X11/xorg.conf This will have been modified by the nvidia installer,

Within the Section “Monitor”
Correct horizontal vertical rates if needed. HorzSync in Khz, VertRefresh is in Hz
eg
HorzSync 51.0 - 81.0
VertRefresh 56.0 - 60.0

Add a monitor size in mms - This the item that X needs to do it’s sums correctly
eg
DisplaySize 474 296

Further down the file is the Screen Section with a subsection “Display”
There will hopefully be 2 lines in it, Depth is colour depth and Modes are the resolution.

eg
Depth 24
Modes “1660x1050” “1280x1024” "…
as many as you like

Everything should work then but the modes must be in descending order or X will try and use them as virtual screens - This I haven’t the time to look into.

One problem for me. The nvidia desktop set up utility didn’t offer me the 1660x1050 mode but did give me the one I wanted 1280x1024. It also gave me a number of higher ones I don’t want. I suspect the solution for this is to use the console cvt routine as mentioned earlier in this thread to the monitor section. I don’t think that disabling ##edid## etc mentioned earlier is really a good idea. There is a slight chance that a monitor could be damaged.

There are some good guides to this whole area in nvidia’s tech support area. Most that relate to Linux can be bought up by searching Linux. There is loads of info on the web about X11 but hardly any example files. Maybe Suse would like to do one and include it in the distro. An insane one that uses all of the facilities commented in the usual way.

The results are interesting. PDF’s launch at just about the right size for instance. KDE looks good. I suspect it will become number 1 again despite the moans from some. One thing for sure - it’s different.

Just in case some one is worried about doing this sort of thing.

The way I do this is to use a file manager in su mode to access the file I want to work on. I would then normally use open terminal here but it doesn’t work in Dolphin. There are many ways of doing the same thing. So using xorg.conf as an example

Copy xorg.conf to another file called say OLDconfig.org. This can be done from the editor.

Edit xorg.conf as needed and save as xorg.conf and as NEWxorg.conf. I use kWrite which is why I navigated there with dolphin in super user mode. It’s then just a case of clicking on it.

Reboot or what ever is needed to reload the file that’s been worked on.

All goes wrong and the desktop doesn’t load.

Log in as root

Type cd /ect/X11 - that changing to the correct directory
Type LS - if you like to see what’s in it. type man more and read up on that if there are loads in it. In that type q to get out.

Then use the linux copy command.

cp OLDxorg.conf xorg.conf

It will just overwrites the file so things are back where they started.

type more xorg.conf if you want to make sure you have restored things back to how they were.

ctrl-alt-del will reboot the system.

John

It turned out that my initial suspicion was correct. X needs more info than than the install gives it.

No, this is not the case generally. It comes down to the display device (with respect to EDID), and sometimes the cables involved. In your case, manual overrides are necessary to assist X with setting the correct display modes and DPI values.

One problem for me. The nvidia desktop set up utility didn’t offer me the 1660x1050 mode but did give me the one I wanted 1280x1024.

Don’t you mean 1680x1050?

I don’t think that disabling ##edid## etc mentioned earlier is really a good idea. There is a slight chance that a monitor could be damaged.

For LCD monitors, this is no longer true. The display simply won’t work if the display mode is not compatible.

Yes I did mean 1680. My tft monitor will display higher res modes which are out of it’s range. It just flashes up none standard mode and displays what it can. Some modes cause it to display invalid mode and usually a messy colour patch on the screen. No comment on edid but if there which it isn’t in my case I’m not sure I would remove it. The refresh rates limit power dissipation anyway.

The only odd aspect really is nvidia offering me higher res modes than I asked for via X. >:( Had enough for a while but will investigate later.

The odd aspect of 1680x1050 is that X has enough info to offer it but it isn’t there. Using cvt really is just doing the sums and saving X the work as far as I can see.

On monitor size maybe newer monitors do provide it. My belinea plus its orginal lead doesn’t seem to. There was a floppy for that sort of thing that came with it and this can still be downloaded but in some ways short of a re install it’s not worth the bother. Others may find themselves wanting to install very old monitor. My original Belinea tft for instance still works perfectly. I’d guess it’s well over 10years old. lol! I’m thinking of glueing it on to the top of this one. Anyway in this sort of case the screen sizes are likely to be needed otherwise from what I have read there is no way X can sort things out correctly.

John

The odd aspect of 1680x1050 is that X has enough info to offer it but it isn’t there. Using cvt really is just doing the sums and saving X the work as far as I can see.

The use of manual modelines, horizontal sync rates, vertical refresh rates, and display size, is so that X has something to work with. The X-server is otherwise unable to know the display capabilities because the EDID information is either absent, incomplete, or buggy. Examination of /var/log/Xorg.0.log contents would have revealed the exact situation to us. Anyway, it looks like you now have a working xorg.conf, so we’ll consider this ‘solved’. :slight_smile:

Couldn’t help having another play

I added specific modelines to the monitor section and de activated edic. Now have the correct set of resolutions. I used cvt to generate them and copied them out of the console into xorg.conf with kedit in su mode using the mouse. Curious aspect is that x is still rejecting them but the card is providing them! :wink: I assume this is because I forgot to add the mode descriptor to the mode list in the screen section.

Only other remaining oddity is that the nvidia utility still shows resolutions that I haven’t asked for and do not want. If I can’t find some way of getting rid of those I think I will have a ***** at nvidia as it’s untidy.

Also wonder if it’s possible to play with the rendering by adding dpi settings.

John