Selecting Correct Port for Recording Devices

My computer has three “Ports” for Recording Devices: Front Microphone, Internal Microphone, and Headset Microphone. I have always had problems where, after connecting the Headset, I had to manually select Headset Microphone.

But, starting a couple of weeks ago, I am having a problem where it will not stay on Headset Microphone, even after I manually select it. Sometimes I can watch it switching between Front Microphone and Headset Microphone several times a second.

What can I do to get it to either:

  1. Use the Headset Microphone any time it is plugged in
    or
  2. Just ONLY use the Headset Microphone, and disable all of the others?

What audio server are you running?

Run this to find out:

$ pactl info

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 1425
Tile Size: 65472
User Name: KHolloway
Host Name: Ken-System76
Server Name: PulseAudio (on PipeWire 0.3.69)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: 00d5:ed17

What you are describing could be a bug, particularly if you can’t change the mic. A couple more questions, which connection this headset uses (USB, jack, bluetooth)? Laptop or desktop computer?

If you are using Plasma you can turn off the devices you don’t need.

  1. Right-click the sound applet on task bar
  2. Click on Configure Audio devices
  3. On the dropdown for a given device, select Off or Output (rather than Duplex)

This headset using a jack connection.

It looks like it allows me to disable (Off) a Device that I do not want, but not a Port that I do not want. (All of my inputs show up as different “Ports” under my one “Recording Device”.)

And, it lets me pick which port to use - it just does not stay on that port. It automatically changes to another port, anywhere from 0.1 seconds to several minutes later.

Could it be a defective port and/or cord?

I have no problems with the headset on other devices, so I am pretty sure it is fine.

I am not sure how to tell if the port has a problem. The computer is pretty new (6 months), and the Headset Microphone works fine as long as it is selected. I don’t know how else to test the port.

Is there any way to tell the software to ALWAYS use the Headset Microphone, regardless of weather it thinks it is connected or now? (I.e., never use any of the other ports.) If I could do that, I would be able to tell if the port is bad or not…

Is there any way to tell the software to ALWAYS use the Headset Microphone, regardless of weather it thinks it is connected or not? (I.e., never use any of the other ports.)