Seit Upgrade auf Leap15.1 kein Internet möglich

Hier noch eine interessante Ausgabe:

server:~ # ping -dv 1und1.de
ping: socket: Keine Berechtigung, attempting raw socket...
ping: socket: Keine Berechtigung, attempting raw socket...
ping: 1und1.de: Der Name oder der Dienst ist nicht bekannt

orf liefert:

server:~ # ping -dv www.orf.at
ping: socket: Keine Berechtigung, attempting raw socket…
ping: socket: Keine Berechtigung, attempting raw socket…
PING www.orf.at (194.232.104.142) 56(84) bytes of data.
64 bytes from 194.232.104.142 (194.232.104.142): icmp_seq=1 ttl=57 time=7.42 ms
64 bytes from 194.232.104.142 (194.232.104.142): icmp_seq=2 ttl=57 time=6.12 ms
64 bytes from 194.232.104.142 (194.232.104.142): icmp_seq=3 ttl=57 time=6.05 ms
64 bytes from 194.232.104.142 (194.232.104.142): icmp_seq=4 ttl=57 time=18.3 ms
^C
— www.orf.at ping statistics —
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 6.051/9.475/18.305/5.127 ms

allerdings liefert die domain folgendes:

server:~ # ping -dv orf.at
ping: socket: Keine Berechtigung, attempting raw socket…
ping: socket: Keine Berechtigung, attempting raw socket…
ping: orf.at: Der Name oder der Dienst ist nicht bekannt

Evtl. doch ein Berechtigungsproblem?

/etc/resolv.conf umbenennen.
Neue /etc/resolv.conf erstellen mit:

nameserver 8.8.8.8
systemctl restart network.service

@Sauerland:
wenn ich die resolv.conf nach /etc kopiere (kein Link nach /var/run/netconfig/resolv.conf) dann funktioniert alles!
Es hat also irgendwie etwas mit dem Link zu tun.

meine resolv.conf:


search fritz.box
nameserver 192.168.3.1
nameserver 1.1.1.1
nameserver 1.0.0.1

Dann ist ja dein Problem behoben.

Ja, aber ganz sauber ist es leider nicht.
Ich würde ja gerne den Grund verstehen und auf diese “Krückenlösung” verzichten.

Aber vorerst kann ich gut damit leben.

Vielen Dank an alle

Falls aber jemand noch einen Tipp zur sauberen Lösung hat, nehme ich den gerne an.

Scheinbar, ist bei dir auch ein AVM FRITZ!Box DSL Router in Einsatz aber, irgendwie ist das DHCP nicht ganz in Ordnung – zum Beispiel, mein AVM FRITZ!Box liefert folgende (verlinkte) ‚resolv.conf’:


### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
### autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
### Call "netconfig update -f" to force adjusting of /etc/resolv.conf.
options inet6 edns0 single-request single-request-reopen
search fritz.box
nameserver fd00::5e49:79ff:fedc:e1aa
nameserver 192.168.178.1

Irgendwie, ist das DHCP bei dir nicht ganz in Ordnung – bei dir:


server:~ # host fritz.box
fritz.box has address 192.168.3.1
fritz.box has IPv6 address fd00::9a9b:cbff:fe2a:f42a
fritz.box has IPv6 address 2a02:1748:dd1d:fb71:9a9b:cbff:fe2a:f42a

In anderer Worten, das AVM DHCP Server bei dir liefert die IP Adressen für DNS nicht wie es sein sollte.

Probier mal, in „/etc/sysconfig/network/config” folgendes: „ NETCONFIG_DNS_RESOLVER_OPTIONS=“inet6 edns0 single-request single-request-reopen

Weiterer Hinweis: in meine Erfahrung, AVM will IPv6 unbedingt benutzen – tue nichts auf ein FRITZ!Box LAN dass IPv6 verweigert …