Segmentation fault using smartcard on openSUSE 11.3

Hi all,

I have a problem with OpenSC while trying to use cardreader OMNIKEY CardMan 6121.
I’ve installed drivers from manufacturer website (ifdokccid_lnx_x64-3.5.1.tar.gz).

After that I run opensc-tool and everything seems to be OK.
But pkcs11-tool gives me a “Segmentation fault” error.
Firefox crashes immediately when I insert cardreader into USB. I’ve installed OpenSC PKCS#11 Module (/usr/lib64/ on my Firefox.

I tried to debug using “pcscd -fd” and I saw that pcscd uses right drivers “ifdokccid”.

All this works fine for 6 months on openSUSE 11.2 x64 and it stopped working when I made clean install of openSUSE 11.3 x64.


opensc-tool -l
Readers known about:
Nr.    Driver     Name
0      pcsc       OMNIKEY CardMan 6121 00 00

pkcs11-tool -lt 
Segmentation fault

Hi all,

I have the same exact problem, but with 32 bits and another smartcard reader. I tested it with OpenSuse 11.2 and OpenSC 11.3 and all was ok, but now, with Suse 11.3 I have the same error in pkcs11-tool and pkcs15-tool. Have you found a solution?


Same issue here, with the inbox drivers of OpenSUSE for CCID readers (pcsc-ccid-1.3.11-5.2.x86_64.rpm)

One more bit of information, the same crash happens in Evolution if you copy the secmod.db from firefox to it.
I suspect the issue to be more or less inside the pcsc framework.
Also, if I have the smart card inserted when I start firefox or evolution, they won’t start, just hang.


While it’s fixed oficially you may want to test with the opensc (and libopensc2) package from home:RedDwarf.


Same problem here.
I installed opensc, pcsc and pcsc-ccid. Dongle is OmniKey CardMKan 6121 and card is Siemens.
It used to work with my old distro, I switched week or something to OpenSUSE.

opensc-tool -l
Readers known about:
Nr.    Driver     Name
0      pcsc       OmniKey CardMan 6121 00 00

pkcs11-tool -I
Нарушение на разделянето(segfault)

Нарушение на разделянето - means segmentation fault. I have my openSUSE configured to display most of the thing in my native language.

I also tried with manufacture driver for pcsc ifdokccid and same result.

EDIT: RedDwarf version of opensc made things work for me.

Thank you, those packages work for me too!