Segmentation fault during shutdown

I updated kernel to yesterday and now i have problem with shutdown.
Everything goes as usual and system shutting down, but after all monitor keeps to work, and computer also doesn’t halt.
The last two lines i see on screen are:
The system will be halted immediately
Segmentation Fault

Also i hear that some cooler or may be hard disk stops after this. But monitor and the rest of computer are still working
With previous kernel i had no this problem.
Reboot command works normal

Since yesterday I have the same problem on my OpenSuse 11.2 x64 system with logical volumes: system ends but does not halt the computer automatically. You have to press the on-off-switch long time to switch off the computer. A new start later does not make problems. It is the kernel

I have the same problem, with the same arch (X86_64). I had to downgrade to previous kernel ( Now all works fine…

Hey there,
got the same problem with the kernel.
I opened a bug report, so perhaps someone fixes this problem:

Just wanted to add that I’m having the same issue on OS 11.2 x86_64 system running KDE. I get the same lines about the system being halted immediately and then the seg. fault.

On my system the hard disks spin down, but the fans, etc keep running. Only way out is holding down the power button. I ran fsck on my disks and got no errors, which is a good thing.

Hope this gets fixed soon.

Welcome to the forums, you came to the right place, same goes for bugreport.

I’ve just upgraded and experienced exactly the same problem as everyone else here…

each here with this problem should go to the bug report
and, add your specific comments…the sooner it is recognized to be
more than one or two isolated incidents, the sooner the repair will


Jeff Mahoney said that bug was fixed. I wondered how long must i wait to get the right kernel from
Index of /repositories/Kernel:/openSUSE-11.2/openSUSE_11.2
I don’t want to check every version.

I wonder if there is a fix via normal update repo :\

Bug is fixed, you can get the up to date kernel via the opensuse repo.

I’m using the jengelh RT Kernel so I have to wait, 'cause his repo is not (yet) up to date

I don’t understand, the kernel which caused the problem was provided through openSUSE update repo. If there is a fix, why don’t they upload it to the same repo?

Do we have to add the kernel repo for this?

Watch the comments in bugreport.
Awaiting answer there :wink:

I tried installing the kernel-default package, as Jeff Mahoney says, but it requires an up to date preload-kmp-default package, which doesn’t exist in that repo. Guess I’ll wait for the official update, seeing as it will come eventually :slight_smile:

Btw, this problem also happens in x86 systems, not just in x86_64.

I have the exact same problem with kernel or My machine has a dual core x86_64 processor (AMD Athlon 64 X2 Dual Core 4200+) with 2GB ram and an Nvidia GeForce 6500 graphics card.

They are looking at a fix coming through the update channel about a week or so according to the comments in the bugzilla entry.

Same problem here. Bug still alive.

  1. I’ve updated to Jeff Mahoney kernel rpm but not results.

From hwinfo output: = ‘Linux’
system.kernel.version = ‘’
system.kernel.version.major = 2 (0x2)
system.kernel.version.minor = 6 (0x6)
system.kernel.version.micro = 31 (0x1f)
system.kernel.machine = ‘i686’

  1. I’ve modify the clockevents.c program adding the following conditional:
    (line 262)

     	if (cpumask_test_cpu(cpu, dev->cpumask) &&
     	    cpumask_weight(dev->cpumask) == 1 &&
                        !tick_is_broadcast_device(dev)) {
  2. Clean logs and temporary files with BleachBit as Administrator.
    (BleachBit version 0.7.2)
    platform.platform = Linux-

Does anybody have any suggestion to solve the problem?


Same problem. Same kernel. openSUSE 11.2 32 bit. :slight_smile: Someone was drunk while committing kernel sources lol!

i also got the same problem, the shutdown process run well but stop at “the system will be halted immediately” message.
i don’t get the segmentation fault message, it simply stopped but the power is still on. have to hold the power button to turn it off.
using kernel on HP Compaq 510. hibernate and suspend works though, so i’m using hibernate all this time.

sounds like the known bug in the most recent kernel update…should be
fixed and distributed soon…