segmentation fail with VLC and banshee

Hello
I use opensuse 12.3 64 bits (Gnome) and I can’t start vlc nor banshee player.
I get “segmentation fail” error on terminal.
Any solution?

Strangiato wrote:

>
> Hello
> I use opensuse 12.3 64 bits (Gnome) and I can’t start vlc nor banshee
> player.
> I get “segmentation fail” error on terminal.
> Any solution?
>
>

Please post the result of

zypper lr -d

Here is…

| Apelido | Nome | Habilitado | Atualizar | Prioridade | Tipo | URI | Serviço

—±-----------------------------±------------------------------------±-----------±----------±-----------±-------±-----------------------------------------------------------------------------±-------
1 | GS38 | GS38 | Sim | Sim | 99 | rpm-md | Index of /repositories/GNOME:/STABLE:/3.8/openSUSE_12.3 |
2 | Pacman | Pacman | Sim | Sim | 99 | rpm-md | Index of /packman/suse/openSUSE_12.3 |
3 | download.opensuse.org-Apps | openSUSE BuildService - GNOME:Apps | Sim | Sim | 99 | rpm-md | Index of /repositories/GNOME:/Apps/openSUSE_12.3 |
4 | download.opensuse.org-Stable | openSUSE BuildService - LibreOffice | Sim | Sim | 99 | rpm-md | Index of /repositories/LibreOffice:/Stable/openSUSE_12.3 |
5 | opensuse-guide.org-repo | libdvdcss repository | Sim | Sim | 99 | rpm-md | http://opensuse-guide.org/repo/12.3/ |
6 | repo-debug | openSUSE-12.3-Debug | Não | Não | 99 | NONE | Index of /debug/distribution/12.3/repo/oss |
7 | repo-debug-update | openSUSE-12.3-Update-Debug | Não | Não | 99 | NONE | Index of /debug/update/12.3 |
8 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | Não | Não | 99 | NONE | Index of /debug/update/12.3-non-oss |
9 | repo-non-oss | openSUSE-12.3-Non-Oss | Sim | Sim | 99 | yast2 | Index of /distribution/12.3/repo/non-oss |
10 | repo-oss | openSUSE-12.3-Oss | Sim | Sim | 99 | yast2 | Index of /distribution/12.3/repo/oss |
11 | repo-source | openSUSE-12.3-Source | Não | Não | 99 | NONE | Index of /source/distribution/12.3/repo/oss |
12 | repo-update | openSUSE-12.3-Update | Sim | Sim | 99 | rpm-md | Index of /update/12.3 |
13 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Sim | Sim | 99 | rpm-md | Index of /update/12.3-non-oss |

Strangiato wrote:

> I use opensuse 12.3 64 bits (Gnome) and I can’t start vlc nor
banshee
> player.
> I get “segmentation fail” error on terminal.

The repos look OK

So neither VLC or Banshee launch from the launchers
And if you try from a terminal you get a seg fault?

Can I suggest you try this
https://dl.dropboxusercontent.com/u/10573557/Switcher%20Pics/packman%20in%20gnome.png

Ignore that the image is oldish, it’s the switch that matters on
Packman.

Yes.

I can start Banshee now, but the problem with VLC is still present.

Strangiato wrote:

> the problem with VLC is still present.
>
I can’t be sure. But I recal an issue with VLC, but I thought it only
affected Tumbleweed users.

Here I found the thread and comment
https://forums.opensuse.org/english/get-technical-help-here/multimedia/488591-vlc-install.html#post2570825

VLC is working now.
But the problem with Banshee is back. After play one song, the player crashes and I can’t start it again.

Strangiato wrote:

> But the problem with Banshee is back. After play one song, the player
> crashes and I can’t start it again.
>

I don’t use Banshee, even in Gnome
You could try deleting the hidden config folders for it, or just test a
new user login

> But the problem with Banshee is back. After play one song, the player
> crashes and I can’t start it again.
>

Can you run banshee from a terminal, use it until it crashes and then post the output from the terminal here?

Maybe then we can see why it crashes

And also you say VLC is now working - what did you do to get it working? Can you explain?

I followed this tip.

Try removing/renaming the file /usr/lib64/vlc/plugins/codec/libfluidsynth_plugin.so and see if it starts then.

thx for the tip, quickly tested vlc playing mp3 files and DVDs, all ok

had to downgraded to
vlc-2.0.6-131.1.x86_64
vlc-aout-pulse-2.0.6-131.1.x86_64
vlc-codecs-2.0.6-131.1.x86_64
vlc-noX-2.0.6-131.1.x86_64
vlc-qt-2.0.6-131.1.x86_64
as could not find the codecs for newer versions

cheers

banshee crashes when I start it by gnome-shell icon and freezes when I start it by terminal.

Here is…

Native stacktrace:

banshee() [0x4a93e1]
banshee() [0x420faf]
/lib64/libpthread.so.0(+0xf1f0) [0x7fca177e81f0]

Debug info from gdb:

Thread 1 (Thread 0x7fca182ff740 (LWP 4455)):
#0 0x00007fca17461763 in sigsuspend () from /lib64/libc.so.6
#1 0x0000000000603cb1 in ?? ()
#2 <signal handler called>
#3 0x00007fca175607b2 in __memmove_ssse3 () from /lib64/libc.so.6
#4 0x00007fca082c505c in ?? ()
#5 0x0000000001f9c690 in ?? ()
#6 0x0000000001f8e498 in ?? ()
#7 0x0000000001f8e4b0 in ?? ()
#8 0x00007fca082b7b25 in ?? ()
#9 0x0000000000000084 in ?? ()
#10 0x0000000001f8e498 in ?? ()
#11 0x0000000000000000 in ?? ()

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

Aborted

the entire message is very long and this forum does not allow me post it here.

the entire message is very long and this forum does not allow me post it here

I need the thirty or forty lines previous to your post as well. If you use the # button from the post editor to surround the text output on the terminal as CODE then it will be easier.

Can you repeat and post what I request? It is necessary to see the output to see what caused the crash rather than just the stack trace. It could be a missing/bad library or a mono problem but I need to see the last two pages of what banshee was doing up to the point where it crashed.

Thanks

Or use susepaste
SUSE Paste

See please…

myname@linux-gbnq:~> banshee
[Info  19:17:37.262] Running Banshee 2.6.1: [GNOME:Apps / openSUSE_12.3 (linux-gnu, x86_64) @ 2013-07-15 23:59:29 UTC]

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkComponent) to class (__gtksharp_49_Hyena_Gui_BaseWidgetAccessible) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkSelection) to class (__gtksharp_50_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_TrackInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkTable) to class (__gtksharp_50_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_TrackInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkSelection) to class (__gtksharp_56_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_Database_QueryFilterInfo+601+5b+5bSystem_String+2c+20mscorlib+2c+20Version+3d4_0_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3db77a5c561934e089+5d+5d+2c+20Banshee_Services+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkTable) to class (__gtksharp_56_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_Database_QueryFilterInfo+601+5b+5bSystem_String+2c+20mscorlib+2c+20Version+3d4_0_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3db77a5c561934e089+5d+5d+2c+20Banshee_Services+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkSelection) to class (__gtksharp_62_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_ArtistInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkTable) to class (__gtksharp_62_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_ArtistInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkSelection) to class (__gtksharp_68_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_YearInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkTable) to class (__gtksharp_68_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_YearInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkSelection) to class (__gtksharp_74_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_AlbumInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init

(Banshee:1374): GLib-GObject-WARNING **: attempting to add an interface (AtkTable) to class (__gtksharp_74_Hyena_Data_Gui_Accessibility_ListViewAccessible+601+5b+5bBanshee_Collection_AlbumInfo+2c+20Banshee_Core+2c+20Version+3d2_6_0_0+2c+20Culture+3dneutral+2c+20PublicKeyToken+3dnull+5d+5d) after class_init
[Info  19:17:39.952] Updating web proxy from GConf
[Info  19:17:40.492] All services are started 2,657415
[Info  19:17:41.012] AmazonMP3 store redirect URL: http://integrated-services.banshee.fm/amz/redirect.do/
[Info  19:17:41.575] nereid Client Started
[Info  19:17:41.752] GStreamer version 0.10.36.0, gapless: True, replaygain: False
Stacktrace:


Native stacktrace:

*** Error in `banshee': invalid fastbin entry (free): 0x00000000021ed630 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x7abf6)[0x7f8dc0b28bf6]
/lib64/libc.so.6(+0x7b973)[0x7f8dc0b29973]
/lib64/libc.so.6(+0x30ab7)[0x7f8dc0adeab7]
/lib64/libc.so.6(+0x30910)[0x7f8dc0ade910]
/lib64/libc.so.6(+0x2ffac)[0x7f8dc0addfac]
/usr/lib64/libgconf-2.so.4(+0x1e77c)[0x7f8db1dbb77c]
/usr/lib64/libgconf-2.so.4(gconf_engine_get_fuller+0x1d5)[0x7f8db1dbd275]
/usr/lib64/libgconf-2.so.4(gconf_engine_get_entry+0x8e)[0x7f8db1dbd58e]
/usr/lib64/libgconf-2.so.4(+0x1a83e)[0x7f8db1db783e]
/usr/lib64/libgconf-2.so.4(+0x1cf5d)[0x7f8db1db9f5d]
[0x40e04f91]
======= Memory map: ========
00400000-00734000 r-xp 00000000 08:03 667121                             /usr/bin/mono
00934000-00935000 r--p 00334000 08:03 667121                             /usr/bin/mono
00935000-0093e000 rw-p 00335000 08:03 667121                             /usr/bin/mono
0093e000-00979000 rw-p 00000000 00:00 0 
01cf8000-0380f000 rw-p 00000000 00:00 0                                  [heap]
400be000-400cf000 rwxp 00000000 00:00 0 
400f8000-40109000 rwxp 00000000 00:00 0 
40186000-40187000 ---p 00000000 00:00 0 
401ba000-401cb000 rwxp 00000000 00:00 0 
40224000-40235000 rwxp 00000000 00:00 0 
4025e000-4026f000 rwxp 00000000 00:00 0 
402e9000-402ea000 r--p 00000000 00:00 0 
40376000-40387000 rwxp 00000000 00:00 0 
405ce000-405df000 rwxp 00000000 00:00 0 
4081a000-4082b000 rwxp 00000000 00:00 0 
40a11000-40a22000 rwxp 00000000 00:00 0 
40a91000-40aa2000 rwxp 00000000 00:00 0 
40c65000-40c76000 rwxp 00000000 00:00 0 
40c9b000-40cac000 rwxp 00000000 00:00 0 
40d6a000-40d7b000 rwxp 00000000 00:00 0 
40d96000-40da7000 rwxp 00000000 00:00 0 
40df7000-40e19000 rwxp 00000000 00:00 0 
40e9c000-40ead000 rwxp 00000000 00:00 0 
40f6b000-40f7c000 rwxp 00000000 00:00 0 
40fbf000-40fd0000 rwxp 00000000 00:00 0 
41070000-41081000 rwxp 00000000 00:00 0 
410da000-410eb000 rwxp 00000000 00:00 0 
410f9000-4110a000 rwxp 00000000 00:00 0 
41478000-41489000 rwxp 00000000 00:00 0 
415ea000-4160c000 rwxp 00000000 00:00 0 
41631000-41642000 rwxp 00000000 00:00 0 
41c0d000-41c1e000 rwxp 00000000 00:00 0 
41d34000-41d45000 rwxp 00000000 00:00 0 
41e33000-41e44000 rwxp 00000000 00:00 0 
7f8d74000000-7f8d74057000 rw-p 00000000 00:00 0 
7f8d74057000-7f8d78000000 ---p 00000000 00:00 0 
7f8d78000000-7f8d78021000 rw-p 00000000 00:00 0 
7f8d78021000-7f8d7c000000 ---p 00000000 00:00 0 
7f8d7c000000-7f8d7c06d000 rw-p 00000000 00:00 0 
7f8d7c06d000-7f8d80000000 ---p 00000000 00:00 0 
7f8d83fff000-7f8d88000000 rw-s 00000000 00:0f 14408                      /dev/shm/pulse-shm-3311858116
7f8d88000000-7f8d88021000 rw-p 00000000 00:00 0 
7f8d88021000-7f8d8c000000 ---p 00000000 00:00 0 
7f8d8c000000-7f8d8c021000 rw-p 00000000 00:00 0 
7f8d8c021000-7f8d90000000 ---p 00000000 00:00 0 
7f8d91c83000-7f8d91ce3000 r-xp 00000000 08:03 1048626                    /lib64/libssl.so.1.0.0
7f8d91ce3000-7f8d91ee2000 ---p 00060000 08:03 1048626                    /lib64/libssl.so.1.0.0
7f8d91ee2000-7f8d91ee6000 r--p 0005f000 08:03 1048626                    /lib64/libssl.so.1.0.0
7f8d91ee6000-7f8d91eec000 rw-p 00063000 08:03 1048626                    /lib64/libssl.so.1.0.0
7f8d91eec000-7f8d91eed000 rw-p 00000000 00:00 0 
7f8d91eed000-7f8d91ef3000 r-xp 00000000 08:03 271781                     /usr/lib64/libusbmuxd.so.1.0.8
7f8d91ef3000-7f8d920f2000 ---p 00006000 08:03 271781                     /usr/lib64/libusbmuxd.so.1.0.8
7f8d920f2000-7f8d920f3000 r--p 00005000 08:03 271781                     /usr/lib64/libusbmuxd.so.1.0.8
7f8d920f3000-7f8d920f4000 rw-p 00006000 08:03 271781                     /usr/lib64/libusbmuxd.so.1.0.8
7f8d920f4000-7f8d9210b000 r-xp 00000000 08:03 270864                     /usr/lib64/libimobiledevice.so.3.0.1
7f8d9210b000-7f8d9230b000 ---p 00017000 08:03 270864                     /usr/lib64/libimobiledevice.so.3.0.1
7f8d9230b000-7f8d9230c000 r--p 00017000 08:03 270864                     /usr/lib64/libimobiledevice.so.3.0.1
7f8d9230c000-7f8d9230d000 rw-p 00018000 08:03 270864                     /usr/lib64/libimobiledevice.so.3.0.1
7f8d9230d000-7f8d92317000 r-xp 00000000 08:03 270702                     /usr/lib64/libplist.so.1.1.8
7f8d92317000-7f8d92516000 ---p 0000a000 08:03 270702                     /usr/lib64/libplist.so.1.1.8
7f8d92516000-7f8d92517000 r--p 00009000 08:03 270702                     /usr/lib64/libplist.so.1.1.8
7f8d92517000-7f8d92518000 rw-p 0000a000 08:03 270702                     /usr/lib64/libplist.so.1.1.8
7f8d92518000-7f8d92521000 ---p 00000000 00:00 0 
7f8d92521000-7f8d92719000 rw-p 00000000 00:00 0                          [stack:1393]
7f8d92719000-7f8d92789000 r-xp 00000000 08:03 274654                     /usr/lib64/libgpod.so.4.3.2
7f8d92789000-7f8d92989000 ---p 00070000 08:03 274654                     /usr/lib64/libgpod.so.4.3.2
7f8d92989000-7f8d9298f000 r--p 00070000 08:03 274654                     /usr/lib64/libgpod.so.4.3.2
7f8d9298f000-7f8d92990000 rw-p 00076000 08:03 274654                     /usr/lib64/libgpod.so.4.3.2
7f8d92990000-7f8d92991000 rw-p 00000000 00:00 0 
7f8d92991000-7f8d9299d000 r--p 00000000 08:03 801710                     /usr/lib64/banshee/Extensions/libgpod-sharp.dll
7f8d9299d000-7f8d929a6000 ---p 00000000 00:00 0 
7f8d929a6000-7f8d92b9e000 rw-p 00000000 00:00 0                          [stack:1392]
7f8d92b9e000-7f8d92ba7000 ---p 00000000 00:00 0 
7f8d92ba7000-7f8d92d9f000 rw-p 00000000 00:00 0 
7f8d92d9f000-7f8d92da6000 r-xp 00000000 08:03 272512                     /usr/lib64/liborc-test-0.4.so.0.16.0
7f8d92da6000-7f8d92fa5000 ---p 00007000 08:03 272512                     /usr/lib64/liborc-test-0.4.so.0.16.0
7f8d92fa5000-7f8d92fa6000 r--p 00006000 08:03 272512                     /usr/lib64/liborc-test-0.4.so.0.16.0
7f8d92fa6000-7f8d92fa7000 rw-p 00007000 08:03 272512                     /usr/lib64/liborc-test-0.4.so.0.16.0
7f8d92fa7000-7f8d92fb6000 r-xp 00000000 08:03 272350                     /usr/lib64/gstreamer-0.10/libgstaudioresample.so
7f8d92fb6000-7f8d931b5000 ---p 0000f000 08:03 272350                     /usr/lib64/gstreamer-0.10/libgstaudioresample.so
7f8d931b5000-7f8d931b6000 r--p 0000e000 08:03 272350                     /usr/lib64/gstreamer-0.10/libgstaudioresample.so
7f8d931b6000-7f8d931b8000 rw-p 0000f000 08:03 272350                     /usr/lib64/gstreamer-0.10/libgstaudioresample.so
7f8d931b8000-7f8d931ce000 r-xp 00000000 08:03 272357                     /usr/lib64/gstreamer-0.10/libgstaudioconvert.so
7f8d931ce000-7f8d933ce000 ---p 00016000 08:03 272357                     /usr/lib64/gstreamer-0.10/libgstaudioconvert.so
7f8d933ce000-7f8d933cf000 r--p 00016000 08:03 272357                     /usr/lib64/gstreamer-0.10/libgstaudioconvert.so
7f8d933cf000-7f8d933d0000 rw-p 00017000 08:03 272357                     /usr/lib64/gstreamer-0.10/libgstaudioconvert.so
7f8d933d0000-7f8d933d7000 r-xp 00000000 08:03 272390                     /usr/lib64/gstreamer-0.10/libgstequalizer.so
7f8d933d7000-7f8d935d6000 ---p 00007000 08:03 272390                     /usr/lib64/gstreamer-0.10/libgstequalizer.so
7f8d935d6000-7f8d935d7000 r--p 00006000 08:03 272390                     /usr/lib64/gstreamer-0.10/libgstequalizer.so
7f8d935d7000-7f8d935d8000 rw-p 00007000 08:03 272390                     /usr/lib64/gstreamer-0.10/libgstequalizer.so
7f8d935d8000-7f8d935fe000 r-xp 00000000 08:03 271518                     /usr/lib64/libgstcontroller-0.10.so.0.30.0
7f8d935fe000-7f8d937fd000 ---p 00026000 08:03 271518                     /usr/lib64/libgstcontroller-0.10.so.0.30.0
7f8d937fd000-7f8d937fe000 r--p 00025000 08:03 271518                     /usr/lib64/libgstcontroller-0.10.so.0.30.0
7f8d937fe000-7f8d937ff000 rw-p 00026000 08:03 271518                     /usr/lib64/libgstcontroller-0.10.so.0.30.0
7f8d937ff000-7f8d93800000 ---p 00000000 00:00 0 
7f8d93800000-7f8d94000000 rw-p 00000000 00:00 0                          [stack:1390]
7f8d94000000-7f8d94021000 rw-p 00000000 00:00 0 
7f8d94021000-7f8d98000000 ---p 00000000 00:00 0 
7f8d980d8000-7f8d980e0000 r-xp 00000000 08:03 272352                     /usr/lib64/gstreamer-0.10/libgstvolume.so
7f8d980e0000-7f8d982df000 ---p 00008000 08:03 272352                     /usr/lib64/gstreamer-0.10/libgstvolume.so
7f8d982df000-7f8d982e0000 r--p 00007000 08:03 272352                     /usr/lib64/gstreamer-0.10/libgstvolume.so
7f8d982e0000-7f8d982e1000 rw-p 00008000 08:03 272352                     /usr/lib64/gstreamer-0.10/libgstvolume.so
7f8d982e1000-7f8d9848b000 r-xp 00000000 08:03 1048618                    /lib64/libcrypto.so.1.0.0
7f8d9848b000-7f8d9868a000 ---p 001aa000 08:03 1048618                    /lib64/libcrypto.so.1.0.0
7f8d9868a000-7f8d986a5000 r--p 001a9000 08:03 1048618                    /lib64/libcrypto.so.1.0.0
7f8d986a5000-7f8d986b0000 rw-p 001c4000 08:03 1048618                    /lib64/libcrypto.so.1.0.0
7f8d986b0000-7f8d986b4000 rw-p 00000000 00:00 0 
7f8d986b4000-7f8d986cb000 r-xp 00000000 08:03 272581                     /usr/lib64/libspeex.so.1.5.0
7f8d986cb000-7f8d988cb000 ---p 00017000 08:03 272581                     /usr/lib64/libspeex.so.1.5.0
7f8d988cb000-7f8d988cc000 r--p 00017000 08:03 272581                     /usr/lib64/libspeex.so.1.5.0
7f8d988cc000-7f8d988cd000 rw-p 00018000 08:03 272581                     /usr/lib64/libspeex.so.1.5.0
7f8d988cd000-7f8d98b80000 r-xp 00000000 08:03 272508                     /usr/lib64/libvorbisenc.so.2.0.9
7f8d98b80000-7f8d98d7f000 ---p 002b3000 08:03 272508                     /usr/lib64/libvorbisenc.so.2.0.9
7f8d98d7f000-7f8d98d9b000 r--p 002b2000 08:03 272508                     /usr/lib64/libvorbisenc.so.2.0.9
7f8d98d9b000-7f8d98d9c000 rw-p 002ce000 08:03 272508                     /usr/lib64/libvorbisenc.so.2.0.9
7f8d98d9c000-7f8d98dd2000 r-xp 00000000 08:03 272568                     /usr/lib64/libFLAC.so.    banshee() [0x4a93e1]
    banshee() [0x4feb0f]
    banshee() [0x420f27]
    /lib64/libpthread.so.0(+0xf1f0) [0x7f8dc0e6a1f0]
    /lib64/libdbus-1.so.3(+0x266f0) [0x7f8db193b6f0]
    /lib64/libdbus-1.so.3(+0x252fd) [0x7f8db193a2fd]
Aborted

Seems to be similar to
https://bugs.archlinux.org/task/32390

Waiting for a bug fix…

Typically I use Rhythmbox, it seems to work better with devices.

Rhythmbox is fine. It does look from the bug report that was found, that banshee 2.6.1 has a problem. I have banshee 2.6.0 (from here software.opensuse.org: ) running on a clean 12.3 x64 under KDE and it has been working absolutely fine without any crashes or problems.

You may want to try going back a version and see if that solves your problem. Just for completeness can you post the following

rpm -qa | grep gstreamer
rpm -qa | grep mono
rpm -qa | grep gconf
rpm -qa | grep banshee

After that it looks like either waiting for a bug fix, or going back to 2.6.0 or switching to another application.