Segmentation errors after online update

Two nights ago I used Yast Online Update which downloaded softwaremgnt. This patch had to be installed before any of the other patches.
After I installed this patch anytime I used Online Update or Software Management I get the following error
YaST got signal 11 at YCP file /usr/share/YaST2/clients/online_update_select.ycp:105
/sbin/yast2: line 437: 5980 Segmentation fault $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS
This error kicks me out. How do I reverse this problem so I can use this Yast modules.

Look here
Yast Software Manager Segfaults - Page 2 - openSUSE Forums

I went to the forum question that you mentioned. The question deals with KDE which I do not have installed. I did have yast2-qt-pkg installed but the forum talked about removing the package which I did through zypper since yast does not work. After I removed the package I tried yast again but got the same error.

I see it say about downgrading the yast2-qt-pkg

Try this. Disable all repos except the oss and non-oss and update
Check in software management - filter by repository - Updates

Are all or most of the Yast packages red?
If they are we want to click on the check box(s) to roll them back. Try just the : yast2-qt-pkg first

If they are not Red. Try disabling the Updates repo
Filter by repo, select OSS
See if you can roll back just; yast2-qt-pkg