segfault error 6 in

Running 12.1 x64 Gnome Shell 3.2.1 w/tumbleweed and all updates. No other repos installed. Anything that may help ask and I’ll post right away. I’m currently thinking about doing a backup and totally reformatting, so I’m trying to figure out how I can rearrange my partitions so I don’t have to reinstall Windows 7 when I need it, but hell I never use it anyways.

I’ll try to make as much sense as possible, but I don’t understand why this is happening. Last night I was simply browsing in firefox and all of the sudden things started closing for no obvious reason, so I said okay that’s weird, I’ll just reboot as it had been a while. That may have been my first mistake.

Upon reboot it opens Gnome 3, shell, and appears to have a xorg/video driver related problem, i.e the desktop background appears to be covered by artifacts, which I have seen before when I had driver problems. So first off I though ok I’ll delete xorg.conf and .ICEauthority from my home dir well there wasn’t a normal xorg.conf anywhere I could see but I found /etc/X11/xorg.conf.fglrx, regardless that didn’t seem to make any difference at all, and it would now appear it has nothing to do with my video drivers

I can’t really tell though as I have no functionality in gnome shell other than being able to load it and stare at everything and switch between overview and looking glass and such, but whenever I try to open something from the shell i get something like this(dmesg output):

   32.020663] python[1635]: segfault at 7fff07b85fb8 ip 00007f1d6449ce2a sp 00007fff07b85fc0 error 6 in[7f1d64438000+185000]
   34.939807] nautilus[1561]: segfault at 7fffde0fffd8 ip 00007f851c5a3e2a sp 00007fffde0fffe0 error 6 in[7f851c53f000+185000]
   66.911657] nautilus[1690]: segfault at 7fff96040fe8 ip 00007f0dbc42ce2a sp 00007fff96040ff0 error 6 in[7f0dbc3c8000+185000]
  110.763295] gnome-terminal[1712]: segfault at 7fffe5918fd8 ip 00007f576eb59e2a sp 00007fffe5918fe0 error 6 in[7f576eaf5000+185000]
  114.630003] lxtask[1716]: segfault at 7fffc2d23ff8 ip 00007ff2eea311c0 sp 00007fffc2d24008 error 6 in[7ff2ee9bf000+185000]
  116.336136] nautilus[1717]: segfault at 7fffa1e6afe8 ip 00007fda2e8e7e2a sp 00007fffa1e6aff0 error 6 in[7fda2e883000+185000]

I tried reinstalling all of libc but it probably isn’t that simple or it may be totally unrelated, and while I did find similar bugs none seemed to have a resolution, so before further tinkering I thought best to post here.

I’m doing everything now from a icewm session, so with everything in ice functioning it leads me to believe theres a bug in the shell, perhaps? As of now my system is usable but the shell is totally unsuable, and as I said I’m thinking about how I want to do a backup and repartition my layout to start over from scratch, so any ideas at all will be taken to heart!

Honestly, if you are struggling to figure this kind of thing out you shouldn’t use Tumbleweed.

Re-installing openSUSE will not require you to re-install windows
You can actually backup your personal files from openSUSE by copying them to a folder in windows C

You could consider removing tumbleweed repos and running zypper dup
To get plain old 12.1
That may well fix your problem

Well I never would have thought it would have anything to do with tumbleweed considering I read tumbleweed is considered ‘stable’ to some extent, and since I hadn’t done any updates in a few days, I didn’t think it had anything to do with it.

Anyhow, I took your advice and reverted to the original 12.1 repos including packman, and did sudo zypper ref & sudo zypper dup, and all went well. I then rebooted, and logged back in to Gnome 3. The results are the same, it seems nothing has changed, the shell is still unusable.

SO, I checked dmesg again using xterm and I see the same segfaults occurring, and I thought to myself, this can’t just be random. I went to google, and got to searching the error, and I remembered something that literally was JUST posted by denverd about my having chose to use btrfs, and I reread that post and noticed something similar to an error I see when booting.

It has something to do with btrfs cache/free space, I’m going to grab a pic of it with my phone and post it later, but basically I’m betting that when I rebooted last night some kind of corruption occurred, as the problem I found on google was very similar and directly connected to btrfs.

So, I’ll just do it the hard way and make my backups, and this time I’ll stick with ext4.

As for reinstalling, and windows, and back-ups. My concern wasn’t that I’d HAVE to reinstall Windows, it’s that I have to move things around to make space to reformat my home partition to ext4. Sorry I wasn’t more specific but I had to go do a job and wanted to get this posted while I had the time.

So my ‘problem’ is that I had to decide if I wanted to reformat all the way, seeing as / and /home are both btrfs, or just do a backup somehow and only reformat those 2 partitions, which is what I am going to do. Concerning the error or whatever corruption occurred, if there is more I can document, let me know, and I’ll post it. I won’t be doing a new install until later on tonight, so that gives me some time to consider other alternatives.

I’m on ext4 still and all is well.

One thing you could try is a new user login.

But it would be a plan to revert back to ext4 IMO

Okay, while it makes no sense to ME, what so ever, that worked.

So how on earth is it that something on another use account causes such problems?

Is there a way to recover that user without just moving everything over?

I know it would be easiest to move everything, but I sure would love to know what’s going on in case this happens again?

For now I’d like to say thank you, this at least saved me the trouble of having to reinstall right away, not to mention made me feel like a fool lol.

Something is corrupt in your gnome config files. That is what is indicated if a new user works. rename or remove any ./gnome* directories

Yes you will have to re do you desktop configuration.

On 2011-12-04 23:06, l300lvl wrote:
> Okay, while it makes no sense to ME, what so ever, that worked.
> So how on earth is it that something on another use account causes such
> problems?

No surprise here.

> Is there a way to recover that user without just moving everything
> over?

Mmm… the problem is figuring out what part of the user configuration is
bad. It is easier to start over, and only restore things like data, emails,

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

The complication for you is that you use Gnome and Gnome doesn’t keep all it config in one place.
And I don’t use Gnome.
Some here do and may be able to give you the most likely ~. directories that are responsible

Other than that, I do have another method of resolving this but it’s not a purists approach.

I gathered that, but thank you for pointing that directory out. The point was to try and resolve this for future reference, which I still didn’t do.

I defiantly ‘tried’ to figure that out, but no luck.

I wouldn’t mind hearing about that alternative approach, but before you spend too much time on it, this can be considered solved. What I ended up doing is copying over everything I know is safe, then deleting everything in the corrupted home dir, then copying everything from the new dir over minus a couple files like ones that I know are profile specific so I didn’t have to figure that out later, and then I did a chown to reclaim any lost permissions, and logged back into the main account, and deleted the new one I had made.

That did it for me, and the only thing I’m curious about now is how I can do something like create a backup that doesn’t include specific files/file types, perhaps using cron or something? Basically I’d like to make a backup of my home directory just in case this happens again, but only a minimal one. SO it would be a backup that WON’T include, for example, mp3 avi mpg mp4 vob or anything over ~4-5 mbs? I think that would be safe enough to restore all my config files, settings, pictures, and others. I already backup my music and videos so that’s not something I worry about.