seems connected but no internet opensuse 12.3

A new install - I can access the network with a live DVD USB stick in order to update the installation

I’ve followed these instructions

https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/484160-12-3-network-fix-post-install-announcement-sticky.html

I got the green tick for a wireless connection and a network address

I can’t access the internet and I’m a bit stuck

help gratefully received

Please post output of the following commands:


/sbin/lspci -nnk


ip addr


ls -l /etc/resolv.conf && cat /etc/resolv.conf

On 06/03/2013 12:06 PM, gerrygavigan wrote:
> I’ve followed these instructions

is this the same machine you were running 12.3 on in April with wifi
problems?

didn’t you then (if not now) notice there is both a networking forum
and a wireless forum…and, wifi = wireless

and, if this is a new machine, or card, or problem you need to go to
the wireless forum to read and follow the three ‘stickies’ at the
very top of that forum…they will either get you going or tell
you what information you need to put into your next post, which
should be in the correct (wireless) forum.


dd

Try restarting machine or run this in Konsole or terminalhttps://www.suse.com/releasenotes/x86_64/openSUSE/12.3/#sec.123.systemd-nm

no - I solved that problem - this is a new one

actually I can’t get a wired ethernet connection either


linux-0cjx:/home/gerry # /sbin/lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation System Controller Hub (SCH Poulsbo) [8086:8100] (rev 07)
        Subsystem: Acer Incorporated [ALI] Device [1025:0244]
00:02.0 VGA compatible controller [0300]: Intel Corporation System Controller Hub (SCH Poulsbo) Graphics Controller [8086:8108] (rev 07)
        Subsystem: Acer Incorporated [ALI] Device [1025:0244]
        Kernel driver in use: gma500
00:1b.0 Audio device [0403]: Intel Corporation System Controller Hub (SCH Poulsbo) HD Audio Controller [8086:811b] (rev 07)
        Subsystem: Acer Incorporated [ALI] Device [1025:0244]
        Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation System Controller Hub (SCH Poulsbo) PCI Express Port 1 [8086:8110] (rev 07)
        Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation System Controller Hub (SCH Poulsbo) PCI Express Port 2 [8086:8112] (rev 07)
        Kernel driver in use: pcieport
00:1d.0 USB controller [0c03]: Intel Corporation System Controller Hub (SCH Poulsbo) USB UHCI #1 [8086:8114] (rev 07)
        Subsystem: Acer Incorporated [ALI] Device [1025:0244]
        Kernel driver in use: uhci_hcd
00:1d.1 USB controller [0c03]: Intel Corporation System Controller Hub (SCH Poulsbo) USB UHCI #2 [8086:8115] (rev 07)
        Subsystem: Acer Incorporated [ALI] Device [1025:0244]
        Kernel driver in use: uhci_hcd
00:1d.2 USB controller [0c03]: Intel Corporation System Controller Hub (SCH Poulsbo) USB UHCI #3 [8086:8116] (rev 07)
        Subsystem: Acer Incorporated [ALI] Device [1025:0244]
        Kernel driver in use: uhci_hcd
00:1d.7 USB controller [0c03]: Intel Corporation System Controller Hub (SCH Poulsbo) USB EHCI #1 [8086:8117] (rev 07)
        Subsystem: Acer Incorporated [ALI] Device [1025:0244]
        Kernel driver in use: ehci_hcd
00:1f.0 ISA bridge [0601]: Intel Corporation System Controller Hub (SCH Poulsbo) LPC Bridge [8086:8119] (rev 07)



linux-0cjx:/home/gerry # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:23:8b:e2:5d:56 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::223:8bff:fee2:5d56/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:25:56:69:5c:9e brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.8/24 brd 192.168.0.255 scope global wlan0
    inet6 fe80::225:56ff:fe69:5c9e/64 scope link 
       valid_lft forever preferred_lft forever



  ls -l /etc/resolv.conf && cat /etc/resolv.conf
-rw-r--r-- 1 root root 807 Jun  3 01:23 /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search site


I’ve tried restarting the machine - reading your suggestion on another machine (edit)

using the command to check the service returns


Id=NetworkManager.service
lines 1-1/1 (END)

this is with a wired connection


linux-0cjx:/home/gerry # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:23:8b:e2:5d:56 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.9/24 brd 192.168.0.255 scope global eth0
    inet6 fe80::223:8bff:fee2:5d56/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:25:56:69:5c:9e brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.8/24 brd 192.168.0.255 scope global wlan0
    inet6 fe80::225:56ff:fe69:5c9e/64 scope link 
       valid_lft forever preferred_lft forever

Both the devices do connect, otherwise they would not have IP addresses.
But /etc/resolv.conf does not have any nameservers. This means it either has been editted manually, and hence will not be updated by the networkmanager, or there’s something wrong in the router’s config.
What you can do, is

  • use the Networkmanager to disable networking
  • open a terminal window and do

su -c 'rm /etc/resolv.conf'

(enter rootpassword)

  • use the Networkmanager to enable networking.
  • post output of

cat /etc/resolv.conf

after having performed these steps.

Well, I certainly didn’t edit anything manually but as you can see all is now well, thank you


linux-0cjx:/home/gerry # cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
nameserver 192.168.0.1