Seeking advice how to edit grub2 to have aplymouth bootsplash on a second os

I am running an openSUSE tumbleweed in this machine with grub2 boot loader and decided to install another openSUSE 12.2 on another partition
with out a boot loader. After the installation of openSUSE 12.2 I rebooted to the openSUSE tumbleweed and run mkinitrd and reboot and the tumbleweed
grub2 boot loader was able to chain-load the new openSUSE 12.2 but it only loads via text mode. my question is, how to edit the loader to load the new openSUSE 12.2
using the opensuse plymouth bootsplahsh theme.

Thanks in advance

I am a bit confused. If your 12.2 does not have bootloader, what do you chainload then?

It would be more simple to just show Tumbleweed grub.cfg stanza for your new 12.2 installation.

Perhaps you’ll find this to be of some help:
https://forums.opensuse.org/blogs/jdmcdaniel3/gnu-grub2-command-help-config-editor-version-1-90-106/

I know exactly what you are asking. I have the same myself on this Laptop but I just don’t give a ‘rats’… too much effort for no real gain.
There probably is an answer but I don’t know it

Is your openSUSE 12.2 installation using grub or grub2?

This guide shows how to edit /etc/grub.d/ config files (executable scripts) so that you can add the required boot options

PuppyLinux: Grub 2 Made Easy

I assume you just need to add the splash=silent boot option to the relevant boot entry.

Hi all.
Thanks for your kind replies.
To make my question more clearer.
The new openSUSE 12.2 has no bootloader, I intentionally removed the boot loader before I proceeded with the installation.
The existing openSUSE tumbleweed that is installed in the other partition has a grub2 and it is the one I am using to boot the new installed openSUSE 12.2
Like I said in my first post, the openSUSE tumbleweed grub2 boot loader is now loading the new openSUSE 12.2 but only using text mode but I want it to
load the new openSUSE 12.2 with the nice graphical bootsplash.

Need to install grub2 int root section NOT the MBR. Not installing grub at all is probably the problem. I’m guessing that you are starting the kernel directly without any parameters.

Yes, I think this the crux of the issue.

And when you say text mode, what does that mean? When Plymouth does not load, you get a green expanding line at the bottom of the screen, is that what you see? Or, do you mean grub loads in text mode and you must enter the kernel load commands manually? Since Grub 2 is Grub 2, what difference does it make to actually load Grub 2 from openSUSE 12.2? It will still find and set all openSUSE versions as menu options you can select from. In my opinion, I would reload openSUSE 12.2, but custom partition edit, selecting all existing partitions as-in, but reformat root / only and let Grub 2 take over. If you have not seen it, I have a Grub 2 bash script helper you can find here:

https://forums.opensuse.org/blogs/jdmcdaniel3/gnu-grub2-command-listing-helper-help-input-106/

Thank You,

Here is my menu entry for 12.2 KDE which is controlling Grub2

menuentry 'openSUSE' --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-f2556a88-6162-4c10-9e14-70fc3e87bb7b' {        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos5'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  f2556a88-6162-4c10-9e14-70fc3e87bb7b
        else
          search --no-floppy --fs-uuid --set=root f2556a88-6162-4c10-9e14-70fc3e87bb7b
        fi
        echo    'Loading Linux 3.4.11-2.16-desktop ...'
        linux   /boot/vmlinuz-3.4.11-2.16-desktop root=UUID=f2556a88-6162-4c10-9e14-70fc3e87bb7b   resume=/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part2 splash=silent quiet showopts
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initrd-3.4.11-2.16-desktop
}



Here is the entry the same menu has for my Gnome install of 12.2

menuentry 'openSUSE 12.2 (x86_64)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-a144b5e5-54e3-4556-8451-084c864a58d9' {        insmod part_msdos
        insmod ext2
        set root='hd0,msdos7'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0,msdos7 --hint-baremetal=ahci0,msdos7 --hint='hd0,msdos7'  a144b5e5-54e3-4556-8451-084c864a58d9
        else
          search --no-floppy --fs-uuid --set=root a144b5e5-54e3-4556-8451-084c864a58d9
        fi
        linux /boot/vmlinuz-3.4.11-2.16-desktop root=/dev/sda7
        initrd /boot/initrd-3.4.11-2.16-desktop
}



If I select Gnome it boots fine, but it’s verbose

This is what @conram is on about

Actually, you get this when Plymouth loads but does not find framebuffer output. This is text-mode splash screen. When Plymouth does not load, there are no decorations at all.

In my grub2cmd bash script I have the frame buffer command there to determine what is supported. You then go into YaST / System Boot loader, or use the same option from my bash script, then Boot Loader Options, and enter the VGA mode number in the VGA Mode number block (I use 0x034d), right after the number of seconds the menu is to wait. Then on the bottom left, I enter the equivalent Console Resolution number, I am using 1920x1200, that equates to the mode number. I use the highest resolution the Frame Buffer command finds, which may not be the highest supported by your monitor if you are then loading a Proprietary Video Driver I have found. But, it must be a supported Frame Buffer Mode on your setup to work properly. Following this method allows the Plymouth display to work I have found.

Thank You,

Happy New Year! everyone.
Thanks to the overwhelming replies, been busy during the new year
and still haven’t have a chance to look into this issue on top,I am finishing a project
for the second week of January. This is one of the important things I stick with openSUSE for many years, the
community support.

I will be looking into my issues with grub2 in the coming days, and I will base it from the posters advises in this thread.

Once again, many thanks.

Hi

I went to have a quick glance @ the link and I will be back there to read those pointers.

Thanks

Hi,
It could be or it could be not I will post back what will be the outcome.

Thanks

Hi,

When I choose the openSUSE from the tumbleweed grub2 selections it loads normally via verbose (text), no problem and it is quicker to load up to the gui login screen than tumbleweed.
I don’t want to mess this machine too much, this is a UEFI machine and sometimes it can screw-up grub2 if not being careful.

Thanks.

Hi caf,
You hit the jackpot, I think
That is really what happened here.

Thanks for making those clarifications, when i was away and can’t re-post.

That is as I understood. I note there are no boot options. For reference, mine

linux   /boot/vmlinuz-3.4.11-2.16-default root=UUID=a1f65da6-1471-473e-be03-1bea7ff58760   resume=/dev/disk/by-id/ata-Hitachi_HTS542525K9SA00_080402BB3F00WDD6EV6C-part5 splash=silent quiet showopts