Seeing kernel messages while booting opensuse LEAP 15.2

I recently upgraded from opensuse LEAP 15.1 to 15.2 on a Lenovo desktop. It was by no means a smooth process. I ended up having to reformat /dev/sda3 (the root partition) and /dev/sda7 (/boot/efi) in order to get a stable system and I also encountered problems (system hanging without kdm appearing) when switching to the nvidia drivers. This problem went away after a kernel and driver update.

Question: How do I change the boot appearance so that I can see the kernel messages as before? I tried the following which did not work. I changed splash=silent to splash=0 in /etc/default/grub (and then ran grub2-mkconfig) which changed the grub2 screen but not the kernel boot display. I also changed the runlevel to multi-user by running systemctl set-default but this did not even give me a bash prompt (the system seemed to just hang). The display didn’t show anything and I had to use a windows box to login and change the runlevel back to While I now have a working system, I keep my fingers crossed while booting since I’m no longer sure I’ll get to the kdm screen (and do not plan to reboot for a while unless forced to do so by updates).

I just remove the “splash=silent” from the boot string.

If you make that change with Yast bootloader, then it will automatically regenerate “grub.cfg”.

Just tried it (using yast2 as you suggested). I still don’t see any kernel messages during the boot process. The screen goes blank and then after a while it seems to refresh after which the mouse prompt appears followed by the kdm screen. How do I get kernel messages to appear on the screen during the boot process?

Try also removing the “quiet”. That will give you a lot more output.

Disable plymouth loading as well… plymouth.enable=0

Or uninstall Plymout* rpms. There’s no need I’ve personally encountered to keep it bloating initrds, disk consumption and updates bandwidth if not using it. It’s job is ostensibly to prevent horrific and dastardly “flicker” as video modes have occasion to change during init. The kernel initializes display output using a BIOS or UEFI mode initially, which may actually produce nothing but black with some hardware and BIOS, but quickly changes to a mode selected by the kernel most appropriate to either manual configuration, or the display’s reported optimal mode, or possibly some fallback mode that may not sync between GPU and display.

Like OP, I like to see what things are actually happening during init (on plain old legible white text on black background), however little I can actually read, or how quickly it’s all over. :wink:

Thanks everyone. I removed “quiet” and added “plymouth.enable=0” and now see the messages flash by for a second before the kernel switches to video mode (or whatever). I still wish opensuse LEAP would provide more feedback during booting (especially for those of us with proprietary nvidia drivers since they always create problems eventually). I’ll look into uninstalling the plymouth rpms after checking if they are truly as useless as claimed.

Well, there is always the journal to see what is what… I see virtually nothing here a BIOS message, then off to the desktop… I remove the plymouth stuff (as well as all lang packages), remove bloat via omit_dracutmodules and omit_drivers configuration.

Maybe you need to clarify which part of the boot process.

Prior to the grub menu, it’s BIOS POST.
After the grub menu, AFAIK nothing has changed from when I first looked at the boot process…
For most of the time until shortly before the login screen (if it’s activated, otherwise when it should display), the display uses grub’s VESA display driver.
Plymouth won’t load until shortly before the login screen, and only at that point the “advanced display driver” like Nouveau or nVidia proprietary driver loads (if you have an nVidia GPU) loads.

If this is still how things work, then
Until late in the boot process, Plymouth settings won’t do anything
Your display is still under the control of boot and grub settings.

I haven’t looked at disabling the splash screen that displays after the grub menu, so can’t help (sorry).
Of course, until the solution is found there is the normal workaround to hit ESC to view stdout.


Others already did provide guidance about this. :wink: