Security Update openSUSE-2016-37 Fails with libmatroska.so.6(V_1.4.1)(64bit)

When I try to run the captioned security update I get an error massage:-

 vlc-noX-2.2.1-305.1.x86_64 requires libmatroska.so.6(V_1.4.1)(64bit), but this requirement cannot be provided


My system has libmatroska6 1.4.1-7.1.5 installed. Please could somebody explain what is going on and how should I install the missing requirement?

I ran into this with both 13.2 and 42.1.

I first saw it on 42.1, and took the option “solution” to not install that patch. That allowed me to install the other patches, and then investigate.

So I looked at vlc-noX-* in Yast software management.

What I found was that the version installed was 305-something, from packman. But that was no longer in packman. Instead, packman had version 131-something.

So I sure looked as if the packman maintainers knew that this problem was going to arise, and had prepared for it.

So I retried, and took the option to downgrade vlc-noX to the version with the 131 in place of the 305.

I then got another conflict dialog, with some other other (related) software. Again, there was an option to downgrade from a version with 305 to a version with 131.

I’ll suggest you try to do the same. It shouldn’t be a problem to replace a version no longer in the repos with a version that is in the repos, even if that is a downgrade. This assumes, of course, that the repo maintainers know what they are doing.

Known problem, a fix is on the way. Just be patient, this will resolve itself in the next days.

https://bugzilla.opensuse.org/show_bug.cgi?id=961994

PS, an updated vlc to fix the conflict has been released meanwhile, and the one from Packman didn’t have this problem anyway.
Only the VideoLAN package is still outdated, no idea when they will update it.

But:

There is no 2.2.1-305.1 in any repos, this seems to be some outdated version, as nrickert wrote.
So, downgrade vlc to the version currently in Packman and everything should work.
“zypper patch” should actually offer you an option to do so automatically.

The “downgrade” is probably caused by the fact that Packman detached its vlc packge from the official openSUSE one a few weeks ago because of a packaging disagreement. Afterwards it likely got a lower rebuild revision number by OBS because it might have been treated as a new package (the versions are the same though).

Many thanks, now sorted by “downgrading” as you suggest.