Security trust relationship problem.

Hi! :slight_smile:

I’m using Open SUSE 13.1 x64 KDE.
Today update manager pop up this error message:
“You are about to install unsigned packages that can compromise your system, as it is impossible to verify if the software came from a trusted source.
Are you sure you want to proceed with the installation”?

After answering “No”, I received these details:
"A security trust relationship could not be made with the software origin.
Please check your software signature settings.

For repo /var/cache/zypp/packages/KDE:Qt5/x86_64/libQt5Core5-5.3.2-162.1.x86_64.rpm 6f17d3e2843ba83367c9b6ac9005e0dcd060065c246f17ac08a6224af11787d0 is requested but 29888ffcdca6cd575b6063de688f6cb4411e1390980920f61355098096b0b611 was found"!

There are similar errors on the forum, but I couldn’t figure what to do now. :open_mouth:
Any ideas?
TIA!!! :wink:
G.

So for some reason you have added the repo: KDE:Qt5

Probably the signing key has changed (not unusual)

THANKS caf for your help!!! :wink:

Indeed I have.

Now what?
Just blindly accept the updates, because the key may changed?
Is there any way to verify or-and import the new key?

OK. Problem solved.
After the last reboot, everything installed properly.
Maybe repo key changed?
Anyway, this problem is now solved.
Thanks again!!!