secure boot violation

Hi:
i download the opensuse 13.1 64 bit and i used the ImageWriter to install it on USB and every thing went well
then i restarted my laptop and get this massge:

***invalid signature detected. check secure boot policy in setup

***what can i do now? :’(

Disable secure boot (consult your motherboard manual how to do it), boot openSUSE and reconfigure bootloader making sure secure boot is enabled. Normally openSUSE detects secure boot automatically during installation, so it may warrant additional investigation once it is fixed.

Hi
After the download, did you check the iso image against the md5sum, sha file etc?

Are you sure the install booted in secure boot mode?

What is your hardware?

Can you boot the system and press a Fn key to get to the system boot menu and browse to an efi file, if so browse to the openSUSE directory and select the shim.efi file to boot from.

You possibly have this problem:
Booting the Machine that supports only one signature with vendor provided Keys

That happens to me on my Lenovo box.

You will need to:

  1. Disable secure-boot on our computer;
  2. Install opensuse 13.1. Make sure that you boot the install media into UEFI mode.
  3. In the boot configuration section of install, make sure that “secure-boot” support is selected.
  4. After install, follow the steps on that link I provided above.
  5. Re-enable secure-boot.

I’m normally leaving secure-boot disabled. I don’t run Windows on that box, and I’m not persuaded that secure-boot adds anything of value. But I do occasionally turn secure-boot on to test that it can work.

i use asus s551l and pre-instlled win 8.1 and to enter bios which is locked you should enter the bios frome the win :confused: and i think that impossiple in this case

yes i checked the sha-1

i don’t know what is secure boot mode :shame:

my hardwere is:
core i7 1.80
8 GB ram
nvidia 840m

asus s551l

i don’t know what is secure boot mode and how to disable it
and i have asus with win 8.1 and to enter bios who is locked you should do that frome the win

On Tue 22 Jul 2014 02:36:01 PM CDT, 2ntchan wrote:

nrickert;2655238 Wrote:
> You possibly have this problem:
> ‘Booting the Machine that supports only one signature with vendor
> provided Keys’ (openSUSE:UEFI - openSUSE Wiki)
>
> That happens to me on my Lenovo box.
>
> You will need to:
> > >

  • Disable secure-boot on our computer;
  • Install opensuse 13.1. Make sure that you boot the install media
    > into UEFI mode.
  • In the boot configuration section of install, make sure that
    > “secure-boot” support is selected.
  • After install, follow the steps on that link I provided above.
  • Re-enable secure-boot.
    > > >
    >
    > I’m normally leaving secure-boot disabled. I don’t run Windows on
    > that box, and I’m not persuaded that secure-boot adds anything of
    > value. But I do occasionally turn secure-boot on to test that it can
    > work.

i don’t know what is secure boot mode and how to disable it
and i have asus with win 8.1 and to enter bios who is locked you should
do that frome the win

Hi
Restart the computer and press the F2 key (the one with th wireless
icon on it)
See from page 86 on…


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-17-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

thanx :slight_smile:
so by disable windows boot manger the proplem well be solved?

Hi
Follow the instructions from user nrickert about disabling secure boot temporarily etc

In general you openSUSE does support secure boot if the BIOS will accept it. But you have to manually check the secure boot box (it is not auto detected) when installing. or turn secure boot off as been outlined above

i can’t disable secure boot there is no option for that and the link that user nrickert give it to me didn’t solve the proplem

Hi
On page 89? ‘Secure Boot State’ set to disable AFAIKS or ‘Secure Boot Control’

http://im58.gulfup.com/keOvWQ.png
you can’t change “secure boot state” and “secure boot control” give you another menu don’t have any secure boot state option

i solve it !
watch thise:
https://www.youtube.com/watch?v=s4Un_QpDoRQ