Second screen mysteriously not detected properly


I’m having a problem with my second monitor. I run Opensuse 11.1 and I was using two 1680x1050 screens with a Nvidia card using the latest Nvidia drivers. Everything worked fine but then I messed about with some stuff in Opensuse so I had some window managers etc uninstalled and it was a mess. In the end I got it to work again and I can start Opensuse fine, but now for some reason one of the two monitors is not detected properly.

Both monitors are 1680X1050 but different brands, and one of them (from ACER) works brilliantly, but the other one is detected as DFP1 and has got a resolution of max 640x480. This is using the Nvidia drivers. If I go back to vesa drivers I can run one screen and I can use higher resolutions on any screen no matter which brand (only one screen at a time though since no Nvidia drivers). But then when I use Nvidia drivers the ACER screen is detected fine, but the CHIMEI screen is not detected properly.

So my question is, is there some package (that I by mistake uninstalled) that contains hardware drivers etc that I need to update? My setup worked fine a while ago with the same Nvidia drivers, but now it won’t detect one of the screens properly. Any ideas? I also switched around display ports etc and the problem seems to be bound to the specific hardware, since no matter what I do the ACER screen works, but the CHIMEI screen does not work.

Thank you!

I’d try:

  1. check that nvidia driver is really installed and running.

  2. browse /ext/X11/ for any xorg.conf backup file from a time things were working, rename it to xorg.conf (as root) and reboot.

3.1) if (2) above doesn’t work, boot in runlevel 3, login as root and

run sax2 -r -m 0=nvidia

3.2) back in the desktop, run nvidia-settings as root, activate twinview, configure the displays and save (merge) to X configuration.

Others will probably have different/easier ways, I don’t know.