Second monitor is not recognized - nvidia geforce 8600 gt

I have two monitors, opsensuse 11.1 and nvidia geforce 8600 gt. The second monitor isn’t shown in the graphics card / monitor configuration (SaX2: Konfiguration von X11). What can I do now?

jack8 schrieb:
> I have two monitors, opsensuse 11.1 and nvidia geforce 8600 gt. The
> second monitor isn’t shown in the graphics card / monitor configuration
> (SaX2: Konfiguration von X11). What can I do now?

For dual-head support you need to install the proprietary driver from nVidia,
see http://en.opensuse.org/NVIDIA

HTH
T.

If you start the nvidia-settings window before connecting the monitor it wont show up, hit the ‘detect displays’ or close/reopen the window and it will.

the nvidia configuration center doesnt offer me to select 1360x768 for the resolution of my second screen. ImageShack - Image Hosting :: nvidiaay5.png

sax2 doesn’t even show the second monitor. ImageShack - Image Hosting :: saxms0.png

I just need to set the second monitor to 1360x768, any ideas?

Hi
In the second image, you need to select the ‘Dual Head Mode’ to
configure the second monitor.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 23:15, 2 users, load average: 0.58, 0.15, 0.06
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

I tried the dual monitor mode ImageShack - Image Hosting :: dualheadmonitorer7.png

but i get an error when i test the configuration. ImageShack - Image Hosting :: fehlerzr5.png

Here is the contents of the log file pastebin - collaborative debugging tool

Hi
Your monitors need to be configured as LCD<size>@60Hz not vesa.

Also have you installed the nvidia driver? Your card is supported by
180.22 version.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 23:33, 2 users, load average: 0.73, 0.31, 0.16
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

I also get the error with the LCD configuration. Yes i installed the nvidia package with the suse onclick-install. By the way, the second monitor actually gets a signal and shows a desktop, but with 1024x768 (it has only a wallpaper nothing more on it) and i cannot move windows over to it and rightclicking on that desktop doesnt bring any menu up.

Hi
Can you paste you xorg.conf file on pastebin as well?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 1 day 1:11, 2 users, load average: 0.32, 0.14, 0.10
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

yes here is my xorg.conf pastebin - collaborative debugging tool

Hi
The reason your seeing what your seeing is that you have two screen and
driver sections, hence the displays are being treated as separate items.

What you need to do first is write down the specifications for your CRT
and LCD screen (or are they both LCD?). You need to note down the
aspect ratio, physical dimensions in mm (if you can’t set the diagonal
setting), the vertical and horizontal refresh rates.

You need to reconfigure from runlevel 3, logout from your GUI session
then at the login screen press ctrl+alt+F1, to get to the console
login, then login as root user;


init 3
sax2 -r -m 0=nvidia
init 5 && exit

During the sax2 routine make sure you configure as per the noted down
specifications.

See how that goes, then can look at adding in some other options. Note
when running sax2 it will make a backup copy of your current xorg.conf,
but I always make a copy somewhere.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 1 day 1:51, 1 user, load average: 0.38, 0.13, 0.11
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

You need to note down the aspect ratio, physical dimensions in mm (if you can’t set the diagonal setting), the vertical and horizontal refresh rates.

Where do i get these information from? Both are LCDs and I know the first monitor is 19" and 4:3. The second is 40" and 16:9.

Hi
You should be able to obtain the info from the manufactures website
and specification data or in any documentation on the cd that came with
the equipment. Physical size, just measure :wink:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 1 day 8:21, 2 users, load average: 0.58, 1.05, 0.56
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

I just found out my first screen is 5:4. But now i have the data. But when I press Ctrl+Alt+F1 at the login the screen goes black and has no signal anymore.

Hi
What about instead of F1 use F2 through F6. Else logout, then should be
an option to use a console session?

You could also try rebooting and in the GRUB options just enter the
numeral 3 nothing else, this should make the system start at runlevel 3.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 0:19, 1 user, load average: 0.07, 0.09, 0.17
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

I did as you said, but that was just the sax2 configuration thing i also have in a GUI session. well i set my selected my first screen as lcd 1280x1024@60hz and turned on multi monitor head and set the montior to lcd 1366x768@60hz and on xinerama, but as i tested it i got this window to resize and move my screen which didnt even do anything to those white borders i had around the screen. also the white border where stretched wider then the screen and it scrolled when i moved the mouse to the left or right screen edge. so i turned off the multi head thing and the white borders were correct on the screen edges. Now the second screen is turned off again in the nvidia configuration. Icouldnt configure something like aspect ratio, frequenzy, or monitor size. By the way the second screen is a 40" LCD TV is that is of matter.
Here are new screens of sax and nvidia configuration and the xorg.conf
pastebin - collaborative debugging tool
ImageShack - Image Hosting :: dualheadmonitor1sz0.png
ImageShack - Image Hosting :: dualheadmonitor2eb4.png

Hi
The xorg.conf is looking better :slight_smile: Now when you enable the twinview
with sax and look at the physical dimensions on the 40" screen do they
correspond with the specifications? If not what happens if you adjust
the mm to the correct sizes?

Even if it doesn’t look quite right can you save the config and log
back into your desktop and see if it meets your requirements for
functionality?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 2:32, 1 user, load average: 0.11, 0.10, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

Hi
The other thought is to set the 40" as the primary display and see how
that configures up and post the xorg details as this will give more
information to help on potential further customization.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3:06, 2 users, load average: 1.83, 0.90, 0.35
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

There is no twinview setting in sax2. It is only in the nvidia config tool. You mean I should do the same like I just did but this time saving it no matter that the screen is kinda wider? I just did this but now the screen scrolls when i touch the side edges of the screen, it looks like i have some kind of virtual screen that is 1360x768 on my first monitor. The second monitor is black. Maybe I should turn of dual head mode again and try to turn on twinhead mode in the nvidia settings?

I just turned the twinview in the nvidia settings on, and now i can move windows over to my second screen, it also has a desktop now. But still the resolution of the second screen is 1024x768 there is no 1360x768 in the nvidia settings. and sax2 still shows only one monitor to configure. Maybe do i have to write the settings to xorg.conf with the nvidia settings first and reboot?