Second Life viewer fails to load on Opensuse 12.2 64bit

Ok, I’ll wait for the latest release version then. Just to be sure it’s not a different issue in my case, here is my console log. Let me know if anyone sees anything weird.

As this hasn’t been answered yet I had issues with firestorm too, and trying to grab it from the firestorm site, it doesn’t work, install it through yast2 this worked like a charm and started up without issues, even have voice working, am just trying to get streaming music working, but that is another issue, and will not hijack this thread for it. Open Yast2 and do a search for firestorm and you get Phoenix-Firestorm-lgpl and debug sources I installed both just because I had the room and figured more was better. after the install, found it in the menu clicked on it and away I went, joy joy.

Tried, but it finds nothing. What’s the software repository? Thinking about it, SL is open-source so it could be included in the Linux game repositories, including openSUSE’s (along with OpenSim too). I prefer using a repository too because not only is it easier to update, but it’s compiled for that specific distribution so you’ll never have issues like bad libraries.

It would probably be good to make an active list of files needed to run Firestorm and other viewers in openSUSE and other distros !

I would be willing to give it a home if someone wants to build the web, I would I just really don’t have time.

Let me know,

I can confirm latest FireStorm works on openSUSE 12.2 without the need to replace any libraries either. Latest official SL viewer still has the issue, so if you don’t wanna wait till Linden fixes theirs get FireStorm. Although it’s too bloated for my like, it will probably be the viewer I’m switching to for multiple reasons.

the answer is to use teapot viewer its been working great for me with opensuse 12.2 heres the link

I know this is old, but I too can only get Singularity to run. Teapot throws this error:

./teapot: line 121: 8837 Segmentation fault LD_LIBRARY_PATH="pwd"/lib64:"pwd"/lib32:"${LD_LIBRARY_PATH}" $LL_WRAPPER bin/do-not-directly-run-teapot-bin --channel “Teapot” --settings settings_.xml
*** Bad shutdown. ***