searching drivers

Hello everybody.

Im novice in Linux OS so Im asking for some help…:frowning:

Here is my computer configuration:
AMD Athlon X2 4400+
nVIDIA Ge-Force 8600GT
Gigabyte GA-M52L-S3
2Gb RAM
So,please,guys,help me find drivers for my hardware …:shame: I`d be very pleasant…:wink:
P.S. Do not send me to google =)

What kind of drivers do you need?
Normally the hardware is detected automatically during the installation. Just connect scanners, printers and modem/network cable to your computer before you start the installation.
During this, you have to set a root password! You will be asked for this.
The only thing you have to do afterwards should be the installation of your NVIDIA driver, if you want to have 3D possibilities.
This can be done by adding the NVIDIA repository under YAST (can be found under menu - computer) open it with root. (Next steps depend on your version of openSUSE. If you use 11.1, the next menu looks a bit different to the one of 11.2. But this is only optical.)
Here go to “Software Repositories”, choose “add”, choose “community” and “next”, choose “NVIDIA”.
Than make an actualisation of your repositories.
Stay in YAST an open “Adding/Deleting Software”, search for “nvidia” - without the quotations marks;). There will be offered a list of different drivers
Now it depends, what kind of kernel you use. You can find your version, if you open a console an typ in:
uname -r
This showes you your kernel. Maybe it is desktop/default/PAE/smp, or what ever. Search the driver, with the right ending. It might look like nvidia-gfx02-kmp-YOUR KERNEL. By choosing the driver, there will be also choosen a x11-video-xxxxx driver through YAST. Accept it and let it download.
After this you only have to start a new x-session (or just make a newstart) and you have your nvidia driver running - with 3D effects possiblelol!.
I have a 64Bit suse running here with SLI-NVIDIA cards. Everything worked and works fine here.
Afterward you will find a new menu under “programms / system / configuration / nvidia x-server”. Here you can set everything you want to have, depending on your grahiccard and your screen.
My system runs with a LG W2252TE. Resolution and format was detected automatically by suse.

Hope this was helpful for you. Good luck so far:).

few questions:
how to log-in by root & how to close X-server`s work? And is there any differents between GNOME & KDE ? Does SUSE create VPN connection(in what i doubt) ? Cuz i use one

Don’t login is as root, ever. Get root power in a terminal like this
Become su in Terminal - HowTo - openSUSE Forums

Always disable auto login
Disable Auto-Login - openSUSE Forums

leave X by: logout and
do a console login
http://public.bay.livefilestore.com/y1pZuZxTopUfJ2N01eXWGlnHskTyewlti_HKN8SAnGPpWshQ8bkGQhTQEiQoLx-qhTQRS6V0pwZmMaUKa3wDqYLFQ/console.login.png

Hello segaman91
First: Yes, SUSE creates VPN connections. But the tool, which is found under “network manager”, is not yet stable enough (only my tests, maybe anyone other has more success?). Furthermore you may install a few more packages to use it. This depends on your distro. For example network-manager-openvpn / -pptp or -vpnc. Afterwards you get an VPN-Connections Icon, which leads you through the configuration.
Second to your question about the desktops: There is not real technical difference between KDE and Gnome. It is your personal decision;).

Big thx! =)
Lets say,I`ve configured LAN. How can I actually run it? Because double-lick just opening setting…I heard smth about kinternet…

Are we talking wireless or eth0?

we`r talking about eth0

Yast - Network Devices - Network Settings

Probaly all you need to do is run thru the config by selecting your device and edit, then just next, next and so on -usually just accept the defaults for dhcp and finish.

@segaman
Strange thing, that network was not auto-detected? Was the networkcable not connected to yout PC while installation?
It does not matter so far, it is only for my interest. Normally network is found and configured during installation. What went wrong?

seems like the cable was not connected…So I`m going to reinstall opensuse)

Plugging the power in would be a good move toorotfl!

Ehm…so unusual after being under windows )

just reinstalled,cable was plugged in & still not working…I insert IP,DNS etc. But maybe I just dont run it? Cause I saw only “Add” and “Edit” buttons…:frowning:

open a terminal and do

/sbin/lspci -nnk

post result

00:00.0 RAM memory [0500]: nVidia Corporation MCP61 Memory Controller [10de:03ea] (rev a1)
Subsystem: Giga-byte Technology Device [1458:5001]
00:01.0 ISA bridge [0601]: nVidia Corporation MCP61 LPC Bridge [10de:03e0] (rev a2)
Subsystem: Giga-byte Technology Device [1458:0c11]
00:01.1 SMBus [0c05]: nVidia Corporation MCP61 SMBus [10de:03eb] (rev a2)
Subsystem: Giga-byte Technology Device [1458:0c11]
Kernel driver in use: nForce2_smbus
00:01.2 RAM memory [0500]: nVidia Corporation MCP61 Memory Controller [10de:03f5] (rev a2)
Subsystem: Giga-byte Technology Device [1458:0c11]
00:02.0 USB Controller [0c03]: nVidia Corporation MCP61 USB Controller [10de:03f1] (rev a3)
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ohci_hcd
00:02.1 USB Controller [0c03]: nVidia Corporation MCP61 USB Controller [10de:03f2] (rev a3)
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ehci_hcd
00:04.0 PCI bridge [0604]: nVidia Corporation MCP61 PCI bridge [10de:03f3] (rev a1)
00:05.0 Audio device [0403]: nVidia Corporation MCP61 High Definition Audio [10de:03f0] (rev a2)
Subsystem: Giga-byte Technology Device [1458:a002]
Kernel driver in use: HDA Intel
00:06.0 IDE interface [0101]: nVidia Corporation MCP61 IDE [10de:03ec] (rev a2)
Subsystem: Giga-byte Technology Device [1458:5002]
Kernel driver in use: pata_amd
00:07.0 Bridge [0680]: nVidia Corporation MCP61 Ethernet [10de:03ef] (rev a2)
Subsystem: Giga-byte Technology Device [1458:e000]
Kernel driver in use: forcedeth
00:08.0 IDE interface [0101]: nVidia Corporation MCP61 SATA Controller [10de:03f6] (rev a2)
Subsystem: Giga-byte Technology Device [1458:b002]
Kernel driver in use: sata_nv
00:09.0 PCI bridge [0604]: nVidia Corporation MCP61 PCI Express bridge [10de:03e8] (rev a2)
Kernel driver in use: pcieport-driver
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
Kernel driver in use: k8temp
01:07.0 Communication controller [0780]: Conexant Systems, Inc. HSF 56k HSFi Modem [14f1:2f00] (rev 01)
Subsystem: Conexant Systems, Inc. Dynalink 56PMi [14f1:2004]
02:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600 GT] [10de:0402] (rev a1)
Subsystem: Giga-byte Technology Device [1458:3455]

This is your device

00:07.0 Bridge [0680]: nVidia Corporation MCP61 Ethernet [10de:03ef] (rev a2)
Subsystem: Giga-byte Technology Device [1458:e000]
Kernel driver in use: forcedeth

Look here
HCL/Network Adapters (Wired) - openSUSE

For Nvida and Forcedeath

support default install…
but how to “connect” to my connection? Is there any buttons\commands or just its enabling while system is loading?

2 comment I see

  • This is the NVIDIA NForce 4 integrated NIC. It is NOT detected by hot plug. makes use of the FORCEDETH driver. There is a bug in bios that stops the driver loading. You need to add a line into /etc/modprobe.conf “options forcedeth msi=0 msix=0” then in yast specify an external ethernet card

  • This is the NVIDIA NForce 4 integrated NIC. It is detected and configured by yast and works until shutdown, but driver does not load on reboot. Add “forcedeth” to the list of modules in the “MODULES_LOADED_ON_BOOT=” line in the /etc/sysconfig/kernel file. Observed on ASUS A8N-VM CSM.

okay) big thx!)