Seamonkey 2.48-1.1 shows graphical glitches

Seamonkey looks as shown. If I resize the windows or hover over the controls, they appear. But they disappear as I scroll on the page.

I restarted without acceleration and in safe mode with a new profile. The terminal shows no special output. Seamonkey 2.46 is fine, there are no problems.

I do believe this is the gtk3 bug that the gnome people seam to be ignoring
you can try the workarounds suggested in the opensuse bugzilla
or use 2.46 which still uses gtk2 and will get security updates
I do believe this is one of the main reasons firefox-esr is the default build for 42.3 and TW

I have similar problems. Today Seamonkey 2.48-1 installed with a big update in Tumbleweed. All pages looked garbled. I installed seamonkey-2.46-12.26.x86_64.rpm that I found on the Leap 42.3 repositories. Now Seamonkey works again.

do you use a custom dpi and a non gnome desktop if so it’s the aforementioned gtk3 bug you need to manually set the dpi see this gnome bug thread for a possible fix

I use KDE (but no custom dpis) and had numerous issues following that big update. Most are sorted now, but this Seamonkey one remains. Having tried Tumbleweed for about a year, I seem to spend more time updating it (over 2000 this weekdnd alone) than actually using it, so may be leaping back to Leap.

I use KDE as desktop, with Nvidea graphics with Nouveau on a 2560 x 1440 monitor. I don’t use custom dpi.
In bug 1022830 the title suggests that something is wrong with KDE cursor. Tabs and menu in Seamonkey started grey. Moving the mouse over tabs, menu and even pages made text appear. But for the pages not to the extent that it was readable. If I waited long enough (about 1 or 2 minutes) text became visible, until I moused over or tried to scroll.

I’m happy to provide more information, attach some info to a bug or submit a new bug.

I have the same problem. I installed seamonkey-2.48-1.1.x86_64 via “zypper up” from current Tumbleweed repo-oss ( It is not usable. I didn’t consciously change the DPI setting. My screen resolution is 1600x900. I tried the suggestion with adding to ~/.Xresources the line “Xft.dpi: 192”, but it didn’t help. Actually it doesn’t seem to be a problem with the resolution, these typically look different. It seems to be a screen update problem, although minimizing and restoring the window doesn’t help, it seems that the content of the window is not redrawn on restoring the window, bit that a bitmap of the window is somewhere cached.

I have attached two screenshots. The first is after starting Seamonkey. It is the top section of the Seamonkey window. You will notice that the area where the URL is displayed is empty and there are arrows down where the buttons should be, but there are no button images. The second screenshot is the same area of the screen. The difference is just that I moved the mouse pointer from the left to the right, without pressing any button. Just moving the mouse over a button will replace the default image with a slightly highlighted version of the same image, and leaving the area will again replace it with the default version. So moving the mouse pointer over the area will force it to display the right content, but it should have been there from the start. Besides, this is just a solution for areas that actually change when the mouse is over them, and it is not practical to move the mouse over the whole screen just to get a correct picture.
Immediately after startup:
After moving the mouse over the title area:

The email client seems to be even worse, it doesn’t scroll lists properly, and no amount of moving the mouse pointer fixes this, although it does help display a little more than is visible initially.

The good news is, at this moment, the directory containing the repository has the files
in addition to the newer version, and they still work, so get them while they are there, and maintainers, please keep them there.

I didn’t get zypper to install it directly from the repository, so these are probably not listed in the list of available packages, but the files are there and you can either download them or supply the URL directly to zypper.

I think this is the compilation bug
Bug 1056699]( - SeaMonkey GUI/web page rendering completely broken
I think your choice is to wait for a fix or temporarily downgrade to 2.46
maybe try a binary from
as those are tar balls you could get both 2.46 and 2.48 and unpack them in separate folders

I tried Seamonkey version 2.48-1.3. Still broken. So back to version 2.46.
I don’t see any progress on “Bug 1056699]( - Seamonkey GUI/web page rendering completely broken”.