Seahorse does not work properly


I have had a problem with the seahorse application for a few days. Before, it started when I started my system, I unlocked and I was comfortable with my encrypted ssh keys, etc.
Now, for some reason that is unknown to me (ok, I changed my ssh key/passphrase without using seahorse ?!), it does not start at startup. Worse, I can’t normally connect in ssh with registered remote hosts. For example, to connect to a remote machine in ssh on which I saved the key, I get the answer “sign_and_send_pubkey: signing failed: agent refused operation”. For sweater on a github repository, same problem. (of course, I tried to change the keys, using directly seahorse… There is always the same message then)
I can of course do a trick to use the ssh agent, but then I have to enter my key each time.

I don’t know where to start to fix this problem. I would like to come back to the situation of unlocking at startup, and letting seahorse manage my ssh keys.

I tried lot of things found on the Internet… :confused: But I need some help. Please :confused:

info :
OpenSuse 15.0
gnome-keyring: 3.20.1

It is working fine here. However, I did not change ssh passphrase, so I don’t know how that affects things.

Here’s one difference, though. For me, the Gnome login keyring is already open when I login to Gnome. It is using the login password for that. So maybe you are using auto-login, and never give your password.

So I wonder whether you ever changed your login password, and whether that would affect anything.

Can you post the output of

zypper lr -d

We might as well look at your repos. It’s always possible that a rogue repo is causing problems.

Hello, thanks for your reply ! Glad to see someone trying to help.

# zypper lr -d

#  | Alias                             | Nom                                     | Activé | Vérification GPG | Rafraichir | Priorité | Type   | URI                                                                      | Service
 1 | Atom                              | Atom Editor                             | Oui    | (r ) Oui         | Non        |   99     | rpm-md |                      |        
 2 | | Packman Repository                      | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |   |        
 3 | openSUSE-Leap-15.0-1              | openSUSE-Leap-15.0-1                    | Non    | ----             | ----       |   99     | rpm-md | hd:///?device=/dev/disk/by-id/usb-Generic_Flash_Disk_91E8741E-0:0-part2  |        
 4 | repo-debug                        | openSUSE-Leap-15.0-Debug                | Non    | ----             | ----       |   99     | NONE   |      |        
 5 | repo-debug-non-oss                | openSUSE-Leap-15.0-Debug-Non-Oss        | Non    | ----             | ----       |   99     | NONE   |  |        
 6 | repo-debug-update                 | openSUSE-Leap-15.0-Update-Debug         | Non    | ----             | ----       |   99     | NONE   |                 |        
 7 | repo-debug-update-non-oss         | openSUSE-Leap-15.0-Update-Debug-Non-Oss | Non    | ----             | ----       |   99     | NONE   |             |        
 8 | repo-non-oss                      | openSUSE-Leap-15.0-Non-Oss              | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |        |        
 9 | repo-oss                          | openSUSE-Leap-15.0-Oss                  | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |            |        
10 | repo-source                       | openSUSE-Leap-15.0-Source               | Non    | ----             | ----       |   99     | NONE   |     |        
11 | repo-source-non-oss               | openSUSE-Leap-15.0-Source-Non-Oss       | Non    | ----             | ----       |   99     | NONE   | |        
12 | repo-update                       | openSUSE-Leap-15.0-Update               | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                       |        
13 | repo-update-non-oss               | openSUSE-Leap-15.0-Update-Non-Oss       | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                   |        
14 | sublime-text                      | Sublime Text - x86_64 - Stable          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md |                       |        

I did not change my password for my login. My install is young (2 months)…

I’m not seeing an obvious problem with the repos. You have two non-standard repos, but they seem unlikely to cause problems.

I’ve been assuming that your desktop environment is Gnome. But maybe it isn’t. So can you tell us what desktop environment you use, and what display manager (login GUI) you are using.

Yes, my desktop is Gnome. Or… “was”

While trying to fix the problem, I broke my system, and I can’t boot anymore :confused:
I try to recover my files with a live session before reinstalling everything.

I changed the starup program to launch the key manager, and Gnome does not open any session anymore for the moment… :confused:


I fixed the problem. After reinstall OpenSuse, I kept my ssh and configuration from the previous install, and I had exactly the same problem.
I only removed all the .ssh/* content, recreated a ssh key using seahorse, and it seams to work, now.

I don’t know what was the problem… But now it’s solved.

I only have to reinstall all my programs :slight_smile:

It looks as if the problem was in user settings.

I don’t know what was the problem…

I don’t know either. But, later today, I will experiment with changing the password on an ssh key to see if that causes problems.

But now it’s solved.

That’s the most important part.

Okay, I have done that experiment.

I setup a new user account, and created an ssh key for that user. I created the key while logged into Icewm.

I then logged into Gnome, and used the key for an ssh-connection to another computer. Seahorse prompted for the passphrase, and saved it in the Gnome keyring.

I then logged out from Gnome, and back into Icewm, where I changed the passphrase (at the command line with “ssh-keygen -p”.

I again logged into Gnome, and tried to use that key for a connection. And Seahorse prompted me for the new passphrase, and saved that in the Gnome keyring. So all was working the way that it should.

Actually, for my first attempt at doing this, I created an ed25519 key. And Seahorse did not recognize that at all. So I created an rsa key to complete my tests.