SDL_RWseek version SUSE_2.0.10 not defined in file

Hey everybody,

I have a problem with some library dependencies.
As I tried to play Warhammer 40.000 Dawn of War II (port done by Feral Interactive) I had 2 issues, the first one I was already aware of is some missing stuff with libcurl because Feral shipped libcurl.s0.4 from and older Ubuntu release which also occurd on any other non Ubuntu based distro (may even newer Ubuntu releases I’m not sure) the solution for this was just to replace the libcurl.s0.4 in the game folder with a symlink to libcurl of the host system /usr/lib64/

But recently I had a new issue as you can see in the title.
After appliing the above fix for libcurl the game is compalining about a missing SDL_RWseek function.

/z004/sdc1/user/vortex/Games/SteamLibrary/steamapps/common/Dawn of War 2/bin/DawnOfWar2: relocation error: /usr/lib64/ symbol SDL_RWseek version SUSE_2.0.10 not defined in file with link time reference

Mad Max also have this issue after the curl problem.
Further more I tired to launch steam via:


After this the game will launch but the sound is heavily distorted and video sequences seems not to be synchronized at all and run the the actual frame rate of the game and also have very distorted sound.

And I wonder why and how to fix this.

Thank you in advance,

Solved over here: