SDL-Game (OpenTTD) very slow with OpenSuse 12.1 and proprietary ATI driver (fglrx)


I have yesterday installed the OpenSuse 12.1 distribution on my computer and tried to get my favorite game “OpenTTD” to work again. (an open source transport game which uses SDL as graphics “driver”).
Because it runs very slow i’ve tried to install the ATI fglrx driver (I have a ATI Radeon 4450 HD graphics card), tried it to install from YaST, also tried it directly from the ATI homepage, but it does not seem to make any difference regarding the game, it is still very slow!

I had OpenSuse 11.2 before installed on my computer, also with proprietary ATI driver and the game worked perfectly at good performance, even with large maps.
But with the new installation it’s still very slow, even in the start screen the mouse cursor jumps from one place to another.
I’ve searched several forums for the problem, but can’t get it work faster, so now I try and hope to get help here in this forum.

The output of fglrxinfo is:

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 4550   
OpenGL version string: 3.3.11631 Compatibility Profile Context

The output of hwinfo --gfxcard:

31: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.319]
  Unique ID: VCu0.VGRc1HH3wh8
  Parent ID: vSkL.kW+yjvQ4Lu7
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "ATI RADEON HD 4550"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x9540 "ATI RADEON HD 4550"
  SubVendor: pci 0x174b "PC Partner Limited"
  SubDevice: pci 0xe106 
  Driver: "fglrx_pci"
  Driver Modules: "fglrx"
  Memory Range: 0x80000000-0x8fffffff (ro,non-prefetchable)
  Memory Range: 0x90700000-0x9070ffff (rw,non-prefetchable)
  I/O Ports: 0x3000-0x3fff (rw)
  Memory Range: 0x90720000-0x9073ffff (ro,non-prefetchable,disabled)
  IRQ: 48 (1445066 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d00009540sv0000174Bsd0000E106bc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: radeonhd
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

Primary display adapter: #31

I would really appreciate any help!

glxgears also runs without problems with following output:

22925 frames in 5.0 seconds = 4584.934 FPS
17006 frames in 5.0 seconds = 3401.077 FPS
18394 frames in 5.0 seconds = 3678.710 FPS
19067 frames in 5.0 seconds = 3813.296 FPS


Is there noone who can help?
Cause my only other option is to use Windows, and that’s not an option I like :slight_smile: (installing 11.2 again is not really an option for me :()